LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (https://www.linuxquestions.org/questions/linux-general-1/)
-   -   How do I stop linux from probing for HDA and HDB? (https://www.linuxquestions.org/questions/linux-general-1/how-do-i-stop-linux-from-probing-for-hda-and-hdb-7722/)

rdaves@earthlink.net 10-19-2001 11:42 AM

How do I stop linux from probing for HDA and HDB?
 
When my computer is booting, it performs an IRQ probe for HDA and HDB. I have no HDs attached to the Primary IDE connector. Instead, they are attached to Primary Ultra ATA 100 IDE connector and are identified as HDE and HDF.

So, how do I tell linux not to probe for HDA and HDB?

Following are the messages that I get on bootup. It takes several seconds for this unnecessary probe;
Code:

Oct 18 07:59:15 localhost kernel: hda: IRQ probe failed (0xffffff78)
Oct 18 07:59:15 localhost kernel: hda: IRQ probe failed (0xffffff78)
Oct 18 07:59:15 localhost kernel: hda: no response (status = 0x0a), resetting drive
Oct 18 07:59:15 localhost kernel: hda: IRQ probe failed (0xffffff78)
Oct 18 07:59:15 localhost kernel: hda: no response (status = 0x0a)
Oct 18 07:59:15 localhost kernel: hdb: IRQ probe failed (0xffffff78)
Oct 18 07:59:15 localhost kernel: hdb: IRQ probe failed (0xffffff78)
Oct 18 07:59:15 localhost kernel: hdb: no response (status = 0x0a), resetting drive
Oct 18 07:59:15 localhost kernel: hdb: IRQ probe failed (0xffffff78)
Oct 18 07:59:15 localhost kernel: hdb: no response (status = 0x0a)


linuxcool 10-19-2001 10:20 PM

Try hda=noprobe hdb=noprobe or hda=none hdb=none. The none is supposed to be used when there is no drive connected.

rdaves@earthlink.net 10-20-2001 10:39 PM

Not sure where these commands go
 
I am using System Commander menu facility to dual boot my computer. When the menu comes up, and I want to boot linux, I chose "linux", then I get a RedHat window with only one option, "linux" I can click on "linux" or wait three seconds for an automatic boot.

I don't seem to have a place to type either of the commands you suggest.
So I assumed that these commands could be put into my lilo.conf as follows:

Code:

append="hdd=ide-scsi hdc=ide-scsi hda=noprobe hdb=noprobe"
I have added both of the entries you suggested, but the probe still occurs. The probe happens before the RedHat stuff starts up.

Any ideas?

wdingus 10-21-2001 09:42 AM

You ran /sbin/lilo after making changes to lilo.conf?

On the LILO screen it should have a text prompt to type "linux hda=noprobe" or whatever at the bottom if older RedHat or for newer it will say "Press CTRL-X for text mode" or something similar to that for newer.

To make it permanent though, what you did in lilo.conf should be correct.

rdaves@earthlink.net 10-21-2001 10:36 AM

Success!
 
First of all, I forgot to run lilo after changing lilo.conf.

Also, there is an instruction on the RedHat linux startup screen that says "press control-x for text mode". So, I do have a way to enter the suggested text when lilo starts.

But I booted up, ran lilo and rebooted. And, yippee!, no probe.

Thanks.

linuxcool 10-21-2001 04:48 PM

You're welcome. :)

I did a little more checking and you could probably also use in place of hda=noprobe or hda=none, ide0=noprobe or ide0=none. ' ide0 ' is the primary ide channel. ' ide1 ' is the secondary channel. And so forth. The ' ide0=' argument would prevent linux from probing the entire primary ide channel. ' ide1 ' works on the secondary channel. Since you don't have any drives connected, you could use ' none ' instead of ' noprobe '.


All times are GMT -5. The time now is 09:40 PM.