-   Linux - General (
-   -   how do i recover my Hard Disk and MBR? (

Pisces107 12-24-2003 09:28 PM

how do i recover my Hard Disk and MBR?
hi guys,
i'm running RH, Slackware 9 and Windows on two HDDs. while installing Slack, i took some steps(as mentioned below) which caused my primary Hard disk (80gb) to go bad.

now i can't read my first HDD at all, it has NTFS partitions. i'm concerneed about my 50gb plus of data on those partitions. so anyone , pls help me out how do i recover my hard disk and data?
here's what i did and what was the output i got:

1. i reset the MBR ..... and installed LILO.
1.Output1: now my Redhat 9 (kernel 2.4.20-8) is booting off of kernel 2.4.22. which is the slackware's . and it would complain about modprobe couldn't fine modules off of location "/lib/modules/2.4.22" , which doesn't exist , of course. so many of things failed to start (including my modem).

1.Output2. my first hard disk (80gb) is screwed up! none of the partitions show up in the fdisk and fdisk will complain about some error on that disk.
and Windows won't start. and i can't get to my 50g plus data on that disk.

2. luckily, i made a backup of MBR on floppy so,i can get the same old GRUB loader
2.Output1. Redhat loads the way it should , i-e kernel 2.4.20-8. (that's good).

2.Output2. Slack won't, as it used to be before, coz of i don't know what to put in the grub for slack . but for now, i can withstand with that, till my HDD is recovered.

2.Output3. Windows won't load. not good, as i'll loose all my data.

so, as you guys would have figured out, i need help, of course, :) for the following:
1. how do i recover my hard disk, with NTFS partitions?
2. how do i copy MBR from floppy to hard disk?
3. this do i put entries for Slackware in GRUB config file?

thanks guys..i'm waiting to see when i get advice howto fix my problems.

s34n 12-24-2003 10:18 PM

If you have a windows98 startup disk, you can boot off of it and at the prompt enter "fdisk /mbr" without the quotes. This will restore the windows boot loader and you should be able to boot windows if it is still on your drive. Of course now you will have to boot linux off of a floppy.

Pisces107 12-24-2003 10:27 PM

i tried that and i do get winwos bootloader menu ...but Windows itself doesn' bootup as problems with hard disk.

now, i think i have to look for recovery tools so i can get my data recovered.

doen anybody know which tool i should use, to recover hard disk with NTFS partitions on it? i'm not worried about windows, as it can be installed in no time. more i'm concerned about the data.

masand 12-25-2003 12:01 AM

if u can download this
i think u should use f.i.r.e (forensic and incident response environment)
u have to burn that in a cd(578 mb)
it reads ntfs partitions also
it can help u recover data from ntfs parttions andf a lot of other things

Pisces107 12-25-2003 11:03 PM

problem solved-recovered data & HDD
hi guys,

in process of recovering my dard disk and my boot sector. i used the following programs, and i'm writing a very brief ability of their's, so if somebody get into same problem , one can at least have something to start with:

1. Acronis RecoveryExpert Deluxe : when my hard disk was totally unrecognizable and partition table destroyed, this was LIFE SAVER. it recovered all my deleted partitions completely and accurately.

2. R-Studio DataRecoverer : it recovers data for FAT/NTFS/EXT2 partitions, and even recovers most of data after deleted/formatted partition.

3. GetDataback for NTFS : data recovery tool specific for NTFS, but has flavors for FAT too.

in short, using these three tools, i got my windows, redhat and slack back the way they were before.

happy holdiay.

thegeekster 12-26-2003 12:12 AM

I wish I had seen this post before now but, for future reference, after restoring the mbr, you probably could have run the 2K/XP (whichever one you have) installation cd and use the recovery console to 'fixboot', which would have restored your NTFS parition to what it was before. For a Win 9x installation, the equivalent command is 'sys c:' from the startup floppy. This is assuming you have not done anything other than altered the boot records.....the data would still be there.

All times are GMT -5. The time now is 01:42 AM.