-   Linux - General (
-   -   How do I get my kernel to support NTFS file systems? (

axess_denied 06-12-2004 11:37 AM

How do I get my kernel to support NTFS file systems?
I have tried to configure the kernel, no luck with the directions I used, so I am stuck... I have media on my secondary harddrive (Windows XP is the OS) and the file system that was installed is NTFS, okay. So, now what do I do?

# mount -t ntfs /dev/hdb1 /mnt/Windows
mount: fs type ntfs not supported by kernel

I have done
make modules_install
after configuring kernel... WHAT NOW... I am sooo lost, I just want my files :(

crazyeddie740 06-12-2004 12:03 PM

You might try mounting it read-only (check the mount man page on how to do this). You might also want to see if Fedora calls ntfs something funky. NTFS read support is pretty standard these days, and Fedora 2 should support it out of the box. Write support is still *very* experimental though, and that could be what's doing you in.

For sharing files across the two OSs, I personally have about a 30GB ntfs partition for windows, 30GB ext2 for Linux, and vast expanses of FAT32 for actual data files. However, that might not be an option for you.

If you can backup your Windows data to another computer, you might want to try putting a 20GB Linux partition and a 20 GB Windows partition on the same drive, and use all 40 GB of the second drive as FAT32. Windows XP can't format more than 32 GB FAT 32, but it can mount it up to some very large number. So if you go that route, you'll have to format the drive from linux (Knoppix would probably be your best bet.) But it's worrisome that you can't read NTFS.

John5788 06-12-2004 01:12 PM

maybe u have ntfs compiled as a module..

michaelk 06-12-2004 02:28 PM

Redhat does not provide NTFS support out of the box. See below

crazyeddie740 06-14-2004 01:04 PM

It doesn't? Not even read-only? huh. learn something new everyday.

nanovirus 06-14-2004 09:59 PM

umm well im having the smae there a way to get ntfs support??

qwijibow 06-15-2004 08:03 AM

NTFS suppoer it available in fedora core 2 kernel source, but it not compiled as default.
you will need to re-compile your kernel.

i know you tried this, but you obviously did it in--correctly.

cd into the kernel source.


make menuconfig
select "load configureation from file"
load the Config gile in your /boot/ directory.
navigate through the menu to the File system section.
find NTFS and enable NTFS Read Only support.
Save and exit.


make bzImage
make modules
make modules_install
make install

now open your /boot/grub/grub.conf file with kedit or gedit as root
if there is a line that looks like "kernel /vmlinuz-2.6.6 root=LABEL=/"

then replace the 'LABEL=/' with /dev/hda2 (or wherever your linux root partiton is.

/dev/hda1 = primart master partiton 1
/dev/hda2 = primary master parttion 2
/dev/hdb1 = primary slave partion 1
/dev/hdb2 = primary slave partiton 2

now reboot, and select your new kernel from the options.

try to mount with the disk as you did before... (as root)
if this fails with the driver error, then as root give the command

modprobe ntfs
now try to mount again.

if this works (which it will if you do it correctly, it did for me)
you can add the windows partiton to /etc/fstab.
and add the line "modprobe ntfs" to /etc/rc.d/rc.local" to automatically load the ntfs driver on bootup.

let us know if you get it all working.

okay ???

OR, you could try looking for a Fedora Core 2 NTFS driver in RPM form ?

All times are GMT -5. The time now is 06:43 PM.