LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 03-23-2006, 08:49 PM   #1
Fear58
Member
 
Registered: Feb 2004
Location: Reno, Nevada
Distribution: Mandrake 9.2
Posts: 221

Rep: Reputation: 30
How do I confirm if I installed NVIDIA driver correctly?


Hey all.
I recently installed the Nvidia 8178 Linux 64 bit driver today for my 64bit Mandriva 2006. Now, i think it installed correctly, but I'm not sure. Is there a way to confirm that I installed it correctly? My xorg file boots with driver "nvidia" and all, but games like quake4 demo wont run. I get this when i try to launch it: "WARNING: rvServerScanGUI::Clear() - invalid scanGUI

idRenderSystem::Shutdown()
Sys_Error: SDL_SetVideoMode failed: Couldn't find matching GLX visual
"

any help would be much appreciated.
 
Old 03-23-2006, 09:01 PM   #2
xpromisex
Member
 
Registered: Apr 2004
Location: Statesboro, GA
Distribution: Arch Linux 2007.05 "Duke" (Kernel 2.6.21)
Posts: 447

Rep: Reputation: 30
Does the nVidia logo appear on X's startup?

and have you disabled DRI and enabled GLX in your xorg.config?

just comment out DRI and uncomment GLX if you haven't, may fix the error.
 
Old 03-23-2006, 09:18 PM   #3
Fear58
Member
 
Registered: Feb 2004
Location: Reno, Nevada
Distribution: Mandrake 9.2
Posts: 221

Original Poster
Rep: Reputation: 30
I didn't see Dri in my config file, nor does the nVidia splash screen show on boot. This is my xorg.conf:


# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder26) Tue Nov 22 18:39:32 PST 2005

# File generated by XFdrake.
# **********************************************************************
# Refer to the XF86Config man page for details about the format of
# this file.
# **********************************************************************

Section "ServerLayout"
Identifier "layout1"
Screen "screen1" 0 0
InputDevice "Keyboard1" "CoreKeyboard"
InputDevice "Mouse1" "CorePointer"
EndSection

Section "Files"

# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Mandrake 6.0 and later now use a font server independent of
# the X server to render fonts.
FontPath "unix/:-1"
EndSection

Section "Module"
Load "dbe" # Double-Buffering Extension
Load "v4l" # Video for Linux
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"
EndSection

Section "ServerFlags"

#DontZap # disable <Crtl><Alt><BS> (server abort)
#DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
# allows the server to start up even if the mouse does not work
Option "allowmouseopenfail"
EndSection

Section "InputDevice"
Identifier "Keyboard1"
Driver "keyboard"
Option "XkbModel" "pc105"
Option "XkbLayout" "en_US"
Option "XkbOptions" "compose:rwin"
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "ExplorerPS/2"
Option "Device" "/dev/mouse"
Option "ZAxisMapping" "6 7"
EndSection

Section "Monitor"

# Monitor preferred modeline (60.0 Hz vsync, 64.0 kHz hsync, ratio 5/4)
Identifier "monitor1"
VendorName "Plug'n Play"
ModelName "SyncMaster"
HorizSync 30.0 - 81.0
VertRefresh 56.0 - 75.0
ModeLine "1280x1024" 108.0 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync
ModeLine "768x576" 50.0 768 832 846 1000 576 590 595 630
ModeLine "768x576" 63.1 768 800 960 1024 576 578 590 616
EndSection

Section "Device"
Identifier "device1"
Driver "nvidia"
EndSection

Section "Screen"
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultDepth 16
Option "DPMS"
SubSection "Display"
Virtual 1280 1024
Depth 8
EndSubSection
SubSection "Display"
Virtual 1280 1024
Depth 15
EndSubSection
SubSection "Display"
Virtual 1280 1024
Depth 16
EndSubSection
SubSection "Display"
Virtual 1280 1024
Depth 24
EndSubSection
EndSection
 
Old 03-23-2006, 11:02 PM   #4
cs-cam
Senior Member
 
Registered: May 2004
Location: Australia
Distribution: Gentoo
Posts: 3,544
Blog Entries: 4

Rep: Reputation: 57
Well if X will start with your driver set to nvidia then I guess they're installed.
 
Old 03-24-2006, 10:38 AM   #5
xpromisex
Member
 
Registered: Apr 2004
Location: Statesboro, GA
Distribution: Arch Linux 2007.05 "Duke" (Kernel 2.6.21)
Posts: 447

Rep: Reputation: 30
Looks like they're installed properly to me, but if Quake isn't starting...something else is wrong

I dont know - but try googling the error, may turn something up.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Doom3 demo segfaults, nvidia drivers installed correctly qwijibow Linux - Games 3 12-26-2004 02:02 PM
im not sure if i installed driver correctly Kilahchris Linux - Hardware 1 05-05-2004 01:09 AM
Problems with video in Mandrake 10.0 Nvidia is installed correctly. al3x-jay Mandriva 4 03-30-2004 06:52 PM
NVIDIA DRIVER INSTALLED... but what now? kaega2 Linux - Software 15 10-06-2003 06:23 PM
Nvidia driver installed now what? Devboy Linux - Software 1 07-31-2003 11:00 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 09:22 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration