LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 03-25-2003, 09:09 PM   #1
Stalkz
Member
 
Registered: Mar 2003
Location: Teh 518
Distribution: SuSe
Posts: 68

Rep: Reputation: 15
How can I make my cable internet work?


I'm on Mandrake 9 and on the Installation, my internet worked because it downloaded updated files, so I don't know why it isn't working for me now that it's installed....




I tried the wizard and it doesnt work...
 
Old 03-25-2003, 09:59 PM   #2
Stalkz
Member
 
Registered: Mar 2003
Location: Teh 518
Distribution: SuSe
Posts: 68

Original Poster
Rep: Reputation: 15
...Anyone? This is extremely important to me...
 
Old 03-25-2003, 10:11 PM   #3
Stalkz
Member
 
Registered: Mar 2003
Location: Teh 518
Distribution: SuSe
Posts: 68

Original Poster
Rep: Reputation: 15
I would just reinstall windows and do it on there but I used my whole harddrive for Linux...
 
Old 03-25-2003, 10:28 PM   #4
Irish Whiskey
LQ Newbie
 
Registered: Mar 2003
Location: New Zealand
Distribution: Mandrake 9
Posts: 6

Rep: Reputation: 0
Is it just one PC? or a network?
How do you connect to the cable network? a network card?

Open the Mandrake Control Centre. Go to Network / Internet. Connection. Hit Expert mode. Is there a gateway IP address?
 
Old 03-26-2003, 12:15 AM   #5
Stalkz
Member
 
Registered: Mar 2003
Location: Teh 518
Distribution: SuSe
Posts: 68

Original Poster
Rep: Reputation: 15
One pc.


Ethernet.



No gateway IP
 
Old 03-26-2003, 02:59 AM   #6
Irish Whiskey
LQ Newbie
 
Registered: Mar 2003
Location: New Zealand
Distribution: Mandrake 9
Posts: 6

Rep: Reputation: 0
Well I have just installed Mandrake 9 here and I got an IP address from my cable provider...192.168.*.* . I entered it as gateway and Viola !

Not saying your system is the same tho....but your cable modem should have an IP address....

Good luck.
 
Old 03-26-2003, 09:51 AM   #7
frieza
Senior Member
 
Registered: Feb 2002
Location: harvard, il
Distribution: Ubuntu 11.4,DD-WRT micro plus ssh,lfs-6.6,Fedora 15,Fedora 16
Posts: 3,225

Rep: Reputation: 402Reputation: 402Reputation: 402Reputation: 402Reputation: 402
hmm, not sure if this will help, but a friend of mine has a cable modem via ethernet, and his is configured using dhcp, have you tried that?
 
Old 03-26-2003, 10:44 AM   #8
Timothy Miller
Moderator
 
Registered: Feb 2003
Location: Arizona, USA
Distribution: Debian, Fedora & Arch mostly.
Posts: 2,474

Rep: Reputation: 671Reputation: 671Reputation: 671Reputation: 671Reputation: 671Reputation: 671
What system are you in? I have worked for multiple cable isp's, and may be of service if you give me some more information.
Most likely though, it should work just fine if you have eth0 loading dhcp at boot. Very few isp's still give out static ip's (too bad, in a way). Check to see if somehow your settings for that got changed, and reset them for dhcp.
 
Old 03-26-2003, 02:39 PM   #9
Stalkz
Member
 
Registered: Mar 2003
Location: Teh 518
Distribution: SuSe
Posts: 68

Original Poster
Rep: Reputation: 15
At startup it either:

Tries to load eth0 and fails or tries to load eth0 and freezes.





I am using RoadRunner.


I tried the wizard and put nycap.rr.com as my hostname because I'm pretty sure thats' what it is, because that's my email for it(if I used road runner email)


I put autoIP becuase I don't know mine, but I'm thinking about calling the cable company and asking, but I'm guessing they'll just say "We dont work with Linux" rather than trying to help me, so now I'm thinkin I'll call and ask for a Gateway IP
 
Old 03-26-2003, 03:33 PM   #10
busbarn
Member
 
Registered: Feb 2002
Location: Denver, CO US
Distribution: Arch
Posts: 453

Rep: Reputation: 30
from command line try
ifconfig eth0 up
and see what you get. I had to do some tweeking in mdk9 to get the ethernet up and running. And definately use dhcp. That will make it easier on you when the isp leases you a new ip.
 
Old 03-26-2003, 05:35 PM   #11
Stalkz
Member
 
Registered: Mar 2003
Location: Teh 518
Distribution: SuSe
Posts: 68

Original Poster
Rep: Reputation: 15
tried ifconfig eth0 up


It said it cant run it.
 
Old 03-26-2003, 05:39 PM   #12
busbarn
Member
 
Registered: Feb 2002
Location: Denver, CO US
Distribution: Arch
Posts: 453

Rep: Reputation: 30
did you enable ethernet set up during installation? If not, is your kernel compiled to recognize your eth card?
 
Old 03-26-2003, 06:41 PM   #13
Texicle
Member
 
Registered: Oct 2002
Location: Northern Ontario, Canada
Distribution: Slackware 10.0
Posts: 789

Rep: Reputation: 30
Have you run netconfig as root yet? Hostname should be whatever you want to call your box. The other stuff pertains to your ISP. Make sure you know your DNS IP and DNS server address as well as your ISP's DHCP IP address and name (if needed). Hope this helps.
 
Old 03-27-2003, 01:47 AM   #14
brabard
LQ Newbie
 
Registered: Nov 2002
Posts: 11

Rep: Reputation: 0
Well , I didn't understand is that NIC working or not - in case that ifup eth0 replies "No such device" or something simular , no mater to play with DHSP or IP addressing .
lspci or cat /proc/pci ?
lsmod ?
insmod ?
 
Old 03-27-2003, 03:33 PM   #15
Texicle
Member
 
Registered: Oct 2002
Location: Northern Ontario, Canada
Distribution: Slackware 10.0
Posts: 789

Rep: Reputation: 30
brabard:

lspci -v shows what pci devices you have installed
cat /proc/pci puts a list of pci devices/process on your screen
lsmod lists the modules that are installed on your system
insmod installs a module after it's been downloaded/compiled, etc.

If you do ifup eth0 and get "no such device", then you'll probably have to try installing it again. Login as root into a terminal and type:

lspci -v

to see if it detects your NIC. It will show all your pci cards (sound, video, NIC, etc.).

If it detects your NIC, then post the name of the NIC here, including chipset. You will need to find the correct module (driver) for it. You can search www.google.com/linux for this (and we'll try to help you as well). After you've found the correct module name, try typing (again as root) into your terminal:

modprobe <modulename>

If it doesn't work, you'll get an error. If you get an error then you'll probably have to download the module (driver) from somewhere and install it with insmod <modulename>. However, you will most likely have the module already on your system unless you've got a really bizarre or brand new NIC.

If you don't get any errors, type lsmod to see if you get the module name in your list of installed modules.

If it's in your list, then great! You will now need to edit your /etc/rc.d/rc.modules file with a text editor (the file name could vary depending on your distro--if you need help with editing the file, let me know). You will need to uncomment (remove the # from the beginning of) the line that has

/sbin/modprobe <correct module name here>

Save the file. After this, you'll need to edit the file called /etc/modules.conf to add a line that says:

alias eth0 <correct module name here>

Again, let me know if you need help with this. A good idea at this point would be to type netconfig as root. This will walk you through setting up your DNS information as well as your DCHP information. Be sure to have this info handy (contact your ISP if you don't have it). If you're running RedHat 8.0, type redhat-config-network instead of "netconfig".

Hopefully this helps you out. If you need anything else, let me know.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How do i make internet work on gentoo? Alexander.s Linux - General 1 04-20-2005 11:32 AM
Cable modem internet connection does not work GeneB Linux - Software 0 01-26-2005 10:10 AM
Cable Internet won't work with Suse 9.1 Personal Fresh Install RazielX SUSE / openSUSE 6 01-23-2005 12:57 AM
Cant get internet to work off cable modem Redbone981sl Linux - Networking 4 03-22-2004 08:57 PM
does comcast cable internet work on linux keeknspin Linux - Newbie 2 12-31-2003 05:22 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 07:50 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration