-   Linux - General (
-   -   Help with Brother Printer DCP7030/ Crunchbang (

Ztcoracat 01-12-2013 06:32 PM

Help with Brother Printer DCP7030/ Crunchbang

In this thread I stuck with this member for days and thought of strategies/practices and tried everything I know and our newest members printer/scanner still is not working.

His printer functioned fine in Arch and in Ubuntu so for whatever the reason it's non- functional in Crunchbang regardless of which kernel he uses; and the Brother drivers don't seem to help at all.

I'm requesting for a Moderator, Senior Member or Member (when you have time) to take a look with me and help.

Ztcoracat 01-15-2013 08:35 PM

A special thanks to Allend; one of our Senior Members who joined the thread.

Ztcoracat 01-16-2013 05:10 PM

And another special thanks to our LQ 5K Club Member; Knuafl ;)

Ztcoracat 01-20-2013 01:00 PM

Apparently, Brother printers/scanners are not the easiest to work with in Crunchbang or Debian.
Brother printers seem to work well with Arch Linux as indicated in the thread.

It's suspected (being suspicious of) that the 64bit sane and Brother libraries are not being loaded.

Further re-search and contacting Brother may provide the resolution.

Anyone with other experience/strategies and advice would be appreciated as I have been assisting this member for a while now and just trying to find the solution.

Ztcoracat 01-21-2013 06:27 PM

Thanks Ferrari!;)

Ztcoracat 01-26-2013 12:38 AM

The USB 1.0 and the USB 2.0 cables are interchangeable.

While the USB 3.0 is not and considerably faster in speeds compared to 1.0 and 2.0-

Waiting for member to respond-

Ztcoracat 01-26-2013 04:16 PM

This is a good thread I think for folks to learn from.

I have learned and gained knowledge myself that otherwise I didn't posses.

Thanks again to the members that jumped in and helped. Couldn't of done it w/o the extra help.

Like to write a article but that's a whole different area that I'm sure would need our Owner and Founders approval- :) Right?

We sure do have some amazingly knowledgeably folks here at linuxquestions !!

Ztcoracat 02-02-2013 01:07 AM

A last thought to this thread and I'll mark this 'SOLVED' as the printer now works.

The only other thought I have on this is that the kernel list 2 different drivers for the same device it can cause the device not to work if drivers are conflicting or the wrong driver is loaded first.

All times are GMT -5. The time now is 11:32 PM.