-   Linux - General (
-   -   Help me to recover data after a dd (

balfred 12-09-2002 01:12 PM

Help me to recover data after a dd
Trying to burn an image I made a mistake and burned 'boot.iso' on a fat partition where i have all my mp3s.
(dd if=boot.iso of=/dev/hda1)

now I can't mount the partition I receive the following message: "wrong fs type, bad option, bad superblock on /dev/hda1, or too many mounted filesystems"

The boot.iso is 18MB, so I'm shure that there is a way to recover the rest of the data of the partition (9,5 GB).

llama_meme 12-09-2002 02:39 PM

Maybe, maybe not :S

Tried fsck? If that doesn't work, you're in difficulties (it probably is possible to recover the data, but you'd have to do it manually, I suppose).


nxny 12-09-2002 03:09 PM

You should be able to recover most of your data from one of your redundant superblocks. Usually if the superblock has been corrupted, I use
/sbin/fsck.ext3 -b8192 /dev/hdX
to use the backup superblock starting at byte 8192. Evidently this one has been overwritten here, so if you can find the address of a redundant superblock that you havent already wiped, you can pass that option to fsck. Hope this helps.

balfred 12-09-2002 03:14 PM

Thanks for your help Alex but I tried fsck, and this is the output:

> fsck /dev/hda1
>Parallelizing fsck version 1.19a (13-Jul-2000)
>fsck: fsck.vfat: not found
>fsck: Error 2 while executing fsck.vfat for /dev/hda1

Do you know how can i recover it manually?

balfred 12-09-2002 03:41 PM

I suppose that i can't do fsck.ext3 because my corrupted partition is a FAT32 fs.

Tinkster 12-09-2002 03:53 PM

@nxny: I'm afraid FAT doesn't have superblocks :\

@balfred: The only (slight!) chance I'd see in this situation
is to boot into DOS, and try to use something like Nortons
Disk-Doctor ... but even then, you'd have at best a coherent
list of allocated blocks, never being able to retrieve the file's
names.... sorry to say that, but your chances would have
been better if you had erased the partition using fdisk.


P.S.: Don't be root if you don't HAVE to...

nxny 12-09-2002 05:35 PM


Originally posted by balfred
I suppose that i can't do fsck.ext3 because my corrupted partition is a FAT32 fs.

sorry, i assumed it was a Linux partition. Good Luck.

All times are GMT -5. The time now is 01:58 AM.