-   Linux - General (
-   -   help me on a strange issue. (

newpenguin 10-04-2002 04:31 PM

help me on a strange issue.
hello dear people i need your help badly at this time becaue this poor penguin lover has only 1 PC.

what happened
i installed VMWARE workstation 3 on win2k and then booted redhat and slackware successfully from there. actually i have 2 harddrives on one i have win2k and on other i have redhat and slackware.
now after that when i booted from linux harddrive. it gave so much errors "dma errors" then " hdc "input out put error" .hdc is a cd-rom. then it stopped at this error.
i gave it no importance and thought that reinstall will work but i was unable to reinstall :cry:
some dma errors and same hdc error.
i uninstalled vmware then formatted that winpartition but didnt worked. windows is running fine on it but linux kernel is not able to boot.
looks like i will not be able to run linux again on this PC.
All linux gurus help this poor person.
thanks + thanks + thanks

Mara 10-04-2002 04:34 PM

Are those errors only about hdc or also about other drives?

newpenguin 10-04-2002 04:36 PM

no as i told you that hdc is cd-rom.
and hda and hdb are mine both harddrives. the dma errors occure for hda and hdb.

Mara 10-04-2002 04:57 PM

Hmm.. Try to boot Linux with nodma option passed to kernel (if I remember correctly).

mrGee 10-04-2002 05:11 PM

yes i think that is correctly remembered, but there are more options concerning the nodma thing.
read also;
it's about the same, tho the question there is different
try ide=nodma for inst.
good luck

newpenguin 10-04-2002 05:12 PM

at lilo prompt how can i type this
boot=nodma ?
but this isn't a permanent solution.
thanks for help.

neo77777 10-04-2002 09:45 PM

When you see lilo graphical boot prompt hit Ctrl-X and you'll get text promt
hda=nodma hdb=nodma
and hit enter

newpenguin 10-05-2002 11:30 AM

all respected LINUX GURUS please tell me is there any way that my hardrive can become as it was when i didnt used it.
and it looks like that vmware has changed something in my bios
i even upgraded my bios but didnt worked.
now when i bios performs post test i can see harddriuves like as
LBA ,ATA 33 1023
LBA ,ATA 33 2205
and cdrom
cdrom ATA 33
it looks like that ATA 33 is the problem .

even now when i put a win98 bootable cd in my cdrom and boot from cdrom and choose the option "start with cdrom support"
then it says that no drivers found for cdrom ,
startting without cdrom support

what the changes wmware has made in my PC.

still i can boot linux from vmware while running it in win2k.

Mara 10-05-2002 03:33 PM

Could you explain? Do you have problems with bootable cds in all your OSes or only in one of them? Or is it under VMWare?

newpenguin 10-05-2002 06:48 PM

fortunately linux is booting now and not giving that dma errors
now the problem is only that i cannot run linux when cdrom is attached so i disbale it in bios and then run linux.
but i will face the real problem when i will try to install linux again :o :( :cry:
so can any body tell me how to change that (LBA ,ATA 33) status with my cdrom and harddrives and back it to only (LBA)? :confused:

mrGee 10-06-2002 05:29 AM

These ata33 messages show up in bios post, so there's
nothing wrong with your installed os's. This means that it is a bios issue or you might have something changed in your
hardware setup (using wrong ide cables for inst.)
And what happens if you disconnect the cdrom and then
I think you have to make some changes in your bios,
maybe not setting your ide's to autodetect filling in the
actual size of your drive (using the autoedetct utility in
your bios) and set the ide where your cdrom is to;
Or if that is how it is setup now; set the ide's to auto-
detect. Just try some.
good luck

newpenguin 10-06-2002 03:42 PM

well i have loaded many times the "load optimized defaults"
and "load fail safe defaults " in bios.
and even have upgraded my bios .
but same thing.
as i have said when i disbale my cd-rom it works fine but the issue is this that when i will have to install through cdrom then what will happen that time .
looks like i will never be able to install through cd-rom.
but no worries i can install slackware and redhat without cdrom . and will learn soon how to install freebsd.
thanks all the gurus for your help.

All times are GMT -5. The time now is 10:25 AM.