-   Linux - General (
-   -   Help! I screw up really bad -file system- and window manager problems, please help. (

alkalinelito 11-23-2001 08:42 AM

Help! I screw up really bad -file system- and window manager problems, please help.
Hi, i think i screw up linux(rh7.1) really bad. Everyhting started when i was on blackbox...trying to conect to the internet-dial up- using 'rp3' the red hat dialer. So my sister picked up the phone, and the modem went crazy trying to find tone. my sister hang up, but then rp3 tried to dial or something, but everything crashed really bad. so linux crashed, this never happend to me, i couldnt do anything rather than reboot with the reset button. ok so i restarted linux... that thing came, 'check forced' or somthing, ok, everything done. so i try to run blackbox, after blackbox finish loading Linux crash again.. and i didnt even try to use rp3. ok. so i restarted llinux again. And i tried to use window maker. same happen i sarted rp3, eveything went fine, but after a will crashed . so i started again, and run window maker again, and it crashed after it finish loading . ok. and the same happen trying to use oroborus and enlightenment . Ok, so i tried to log in as root, yep yep. i started blackbox, and everything went just fine !!, i was "quite" happy . anyway, after i quit blackbox linux crashed again.. arg... so i restarted again... ok more problems, when that thing of 'check file system' came , this time it found an error !, and ti said something like this (im on win98 now): 'if you know root password type it, to go to the shell and fix the file system or press ctrl+d to restart' so i typed the password, and i went to the shell, with a weird comand promt somethign like this: '(repair files) 01 #' im not sure was "repair files" but was something like that, Ok but io have no idea how to repair/fix the file system !!!. so i have 2 problems now, the window manager problem crashing all the time on my normal user name , and now, the file system is with errors, and i have no idea of what to do, should i reinstall linux? or there is a way to fix this ?. thanks a lot for reading this.

acid_kewpie 11-23-2001 09:01 AM

you need to manually check the hard drive, log in as root and get the 'funny prompt' and assuming your system is on hda5 then

fsck /dev/hda5

and confirm the fixes.

All times are GMT -5. The time now is 10:39 PM.