-   Linux - General (
-   -   Help! - After recent updates keyboard not working! (

speedsix 09-13-2005 03:50 AM

Help! - After recent updates keyboard not working!
Using Ubuntu amd-64

Ok here's the full story..

I modified the XkeysymDB file to include refrences for my keyboards multimedia keys. I also added a hidden .X something (forget the name) config file to my home directory.

This worked fine, multimeda keys worked great.

This morning I turn the comp on and download all available updates (X related libs)

Now I can log into my account fine but Gnome doesn't register any keypress', the screen blinks like the key is detected but doesn't print any characters.

Password prompts work fine but anything else, nothing atall.

My wifes user account works fine, I also tried deleting the config file I added to my home directory and rebooting, nothing. I checked the XkeysymDB file I had modifed previously and this had reverted back to normal.

Any idea? Can I roll back updates via synaptic/apt-get?

Many thanks

Mad Scientist 09-16-2005 06:28 PM

Was the file .Xdefaults? I use a version of that file I found on the web somewhere. You can try putting it in your home directory and then adding the line


xrdb -merge .Xdefaults
to your .Xclients-default file (assuming such a file exists on your system). Here's my .Xdefaults file:


!xterm*iconPixmap: ...
!XTerm*iconName: terminal
!Mwm*xterm*iconImage: /home/a/a1111aa/xterm.icon
XTerm*loginShell: true
XTerm*foreground: gray90
XTerm*background: black
XTerm*cursorColor: gray90
XTerm*borderColor: white
XTerm*scrollColor: black
XTerm*visualBell: false
XTerm*saveLines: 1000
!! XTerm.VT100.allowSendEvents: True
XTerm*allowSendEvents: True
XTerm*sessionMgt: false
!XTerm*eightBitInput:  false
!XTerm*metaSendsEscape: true
!XTerm*internalBorder:  10
!XTerm*highlightSelection:  true
!XTerm*VT100*colorBDMode:  on
!XTerm*VT100*colorBD:  blue
!XTerm.VT100.eightBitOutput:  true
!XTerm.VT100.titeInhibit:  false
XTerm*color0: black
!XTerm*color1: red3
XTerm*color1: IndianRed1
XTerm*color2: green3
XTerm*color3: yellow3
XTerm*color4: DodgerBlue1
XTerm*color5: magenta3
XTerm*color6: cyan3
XTerm*color7: gray90
XTerm*color8: gray50
XTerm*color9: red
XTerm*color10: green
XTerm*color11: yellow
XTerm*color12: blue
XTerm*color13: magenta
XTerm*color14: cyan
XTerm*color15: white
XTerm*colorUL: yellow
XTerm*colorBD: white
!XTerm*mainMenu*backgroundPixmap:    gradient:vertical?dimension=400&start=gray10&end=gray40
!XTerm*mainMenu*foreground:          white
!XTerm*vtMenu*backgroundPixmap:      gradient:vertical?dimension=550&start=gray10&end=gray40
!XTerm*vtMenu*foreground:            white
!XTerm*fontMenu*backgroundPixmap:    gradient:vertical?dimension=300&start=gray10&end=gray40
!XTerm*fontMenu*foreground:          white
!XTerm*tekMenu*backgroundPixmap:      gradient:vertical?dimension=300&start=gray10&end=gray40
!XTerm*tekMenu*foreground:            white
!XTerm Profiles (idea from dag wieers)
XTerm*rightScrollBar: true

Does this keyboard wierdness persist when you boot into text mode (changing the run level from 5 to 3 in /etc/inittab)?

All times are GMT -5. The time now is 11:39 AM.