LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 01-13-2003, 01:00 AM   #1
shanebuss
LQ Newbie
 
Registered: Jan 2003
Location: dallas tx
Distribution: Red Hat 8.0
Posts: 4

Rep: Reputation: 0
Cool Help a Newb.. allowing root to telnet and ftp in.


Hey guys I'm fairly new to linux. I just moved to RH 8.0.

Anyway, how do i set ftp up where root can ftp in? I understnad this is a security risk but its just on my lan for testing....

What about telnet? right now i have to telnet in as another user and then type "su root"..


I like RH 8 but WHY IN THE HELL did they get rid of pico... !! i hate vi. linuxconf is gone as well.

I will soon be upgrading my Windows 2000 Counter-strike server to linux because i am hoping to be able to host more clients with the same amount of ram/cpu.. 12.156.5.40 if there are any cs players out there..

The only downside to linux is it's not nearly as easy to configure everything, but such is life.

Thanks,
Shane
 
Old 01-13-2003, 01:06 AM   #2
hatrisc
LQ Newbie
 
Registered: Jan 2003
Distribution: slack
Posts: 21

Rep: Reputation: 15
if vi isn't your bubble try emacs.

you shouldn't use telnet or ftp. instead try using sshd, which allows secure ftp access using sftp and secure remote sessions. it also will allow you to login as root.
 
Old 01-13-2003, 01:21 AM   #3
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 68
BTW, install Pine and you've got pico back

Cool
 
Old 01-13-2003, 05:32 AM   #4
lhiggins
Member
 
Registered: Jan 2003
Location: Sydney, Australia
Distribution: FedoraCore
Posts: 105

Rep: Reputation: 15
Nice peice of info on pine. Thanks. I noticed they took it out of Mandrake 9. I wonder if the same solution works.

For all you guys who have experienced mandrake 9.0 - is it just me or is the installer buggy. It has errors copying packages over. I bought the cds and d/l it. The same thing happens on both. Even on different machines. Is it a driver problem?

Should I just go back to redhat 8.0?
 
Old 01-13-2003, 08:27 AM   #5
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 68
Defintely a big fat NO. I wouldn't give up Mandy for RH if someone paid me to.

Yeah, Pine is the program containing pico, so it will work with any distro.

I've ran into 2 or 3 errors during the install, but they weren't essential, so after the install I'd just go and plug em in, and they worked fine. This was with the download version, the PowerPack gave me no errors.

If you can get through the install, and your system will boot, then I'd not worry too much about errors. If you are missing packages you desire after the install, just use Mandrakes Package Manager to install them, or urpmi, or in a pinch, straight up RPM.



Cool
 
Old 01-13-2003, 08:37 AM   #6
shanebuss
LQ Newbie
 
Registered: Jan 2003
Location: dallas tx
Distribution: Red Hat 8.0
Posts: 4

Original Poster
Rep: Reputation: 0
hey guys thanks for the info.... pine isnt included in RH 8.0 is it?


I would still like to know how to start the telnet service.. when i try to telnet into it it says the connection was actively refused.

I looked for a inet.conf in the /etc directory but there isnt one in RH 8.

:-(
 
Old 01-13-2003, 08:48 AM   #7
lhiggins
Member
 
Registered: Jan 2003
Location: Sydney, Australia
Distribution: FedoraCore
Posts: 105

Rep: Reputation: 15
Thanks heaps for the info mate
 
Old 01-13-2003, 09:18 AM   #8
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 235Reputation: 235Reputation: 235
Quote:
Originally posted by shanebuss
I would still like to know how to start the telnet service.. when i try to telnet into it it says the connection was actively refused.

I looked for a inet.conf in the /etc directory but there isnt one in RH 8.
It is xinetd now since like Redhat 7.0 I think.
 
Old 01-13-2003, 09:38 AM   #9
shanebuss
LQ Newbie
 
Registered: Jan 2003
Location: dallas tx
Distribution: Red Hat 8.0
Posts: 4

Original Poster
Rep: Reputation: 0
i looked at the /etc/xinetd.conf, but there was hardly anything in there...

there must be something else?
 
Old 01-13-2003, 12:45 PM   #10
hatrisc
LQ Newbie
 
Registered: Jan 2003
Distribution: slack
Posts: 21

Rep: Reputation: 15
/sbin/setup is there something about running telnet there?
 
Old 01-13-2003, 02:55 PM   #11
nxny
Member
 
Registered: May 2002
Location: AK - The last frontier.
Distribution: Red Hat 8.0, Slackware 8.1, Knoppix 3.7, Lunar 1.3, Sorcerer
Posts: 771

Rep: Reputation: 30
Quote:
Originally posted by shanebuss
i looked at the /etc/xinetd.conf, but there was hardly anything in there...

there must be something else?
check under
/etc/xinetd.d/
 
Old 01-13-2003, 03:08 PM   #12
charlie123
Member
 
Registered: Jan 2003
Location: S.E. England
Distribution: Redhat 8.0
Posts: 64

Rep: Reputation: 15
hi, im trying to do the same thing, i want to access my linux box remotely from a windows box, so i downloaded a program called PuTTy which is a windows ssh program. i have the ssh server running, and i changed my /etc/hosts.allow and /etc/hosts.deny to accept connections from the windows box, but i still cant access. it says connection timed out. i tried pinging my linux box aswell but it timed out. i spose this is good security wise, but i would really like to be able to access my computer remotely.
is there any other settings i need to change to allow remote connections to ssh?
thanks

CHarlie
 
Old 01-13-2003, 03:23 PM   #13
nxny
Member
 
Registered: May 2002
Location: AK - The last frontier.
Distribution: Red Hat 8.0, Slackware 8.1, Knoppix 3.7, Lunar 1.3, Sorcerer
Posts: 771

Rep: Reputation: 30
If the windows box cant ping the linux box one or more of the following conditions might be causing it.

1) No route to host. ( the linux box is not on the network at all )
2) In case you're using ping <linuxboxname> instead of ping <ipaddress> , there's no nameserver or c:\winnt\system32\drivers\etc\hosts file to resolve the address
3) There is a tcp route to the box, but you have told the linux box to swallow ICMP packets so it doesn't reply to your ping.
4) The windows box is inside a network protected by a firewall that rejects ICMP packets.

But, first of all make sure the server is running by running

ps -ax | grep sshd
and
netstat -na | grep -i listen

Post the output if it is not meaningful to you.

and try ssh localhost from the linux box.
 
Old 01-13-2003, 03:50 PM   #14
charlie123
Member
 
Registered: Jan 2003
Location: S.E. England
Distribution: Redhat 8.0
Posts: 64

Rep: Reputation: 15
cheers for reply

1) the linux box is on the network
2) ping <ipaddress>
3)i dont think i have?
4) firewall on windows box was enabled, turned it off, still no luck. incase it is important, in the firewall logs it blocked ICMP Unreachable messages from my linux box to my windows box.

i did ps-ax into grep and it appears sshd isnt running, even though in the Servers > Services it is ticked. (KDE) ??
also when i do netstat -na, sshd doesnt appear, but port 22 is listening, i thought port 22 was sshd?

i have now run sshd, tried again and still no luck, PuTTy tells me unknown network error.

Also ping now works, i dont know if i typed in my linux box ip wrong last time, but it works now.

when i do ssh localhost it works.
 
Old 01-13-2003, 04:08 PM   #15
nxny
Member
 
Registered: May 2002
Location: AK - The last frontier.
Distribution: Red Hat 8.0, Slackware 8.1, Knoppix 3.7, Lunar 1.3, Sorcerer
Posts: 771

Rep: Reputation: 30
>1) the linux box is on the network
How do you know? Can you access it via http if the webserver is running?
>2) ping <ipaddress>
And it works now. Good!!
>3)i dont think i have?
If you had, then ping wouldnt work
>4) firewall on windows box was enabled, turned it off, still no luck. incase it is important, in the firewall logs it blocked ICMP Unreachable messages from my linux box to my windows box.

>i did ps-ax into grep and it appears sshd isnt running, even though in the Servers > Services it is ticked. (KDE) ??
also when i do netstat -na, sshd doesnt appear, but port 22 is listening, i thought port 22 was sshd?

Looks like you're using xinetd. It must be running.
do a cat /etc/xinetd.d/* | grep -H 22

check to see if /etc/rc.d/init.d/sshd exists. I thought Redhat 8.0 came with sshd configured standalone.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Allowing FTP thru Squid? krishvij Linux - Security 2 06-29-2005 12:40 AM
Apache newb here ... allowing users to DL multiple files? TheVrolok Linux - Software 0 10-14-2004 02:12 PM
GFTP allowing Root access to an FTP user scottpioso Red Hat 2 01-07-2004 07:20 PM
redhat 9: sendmail port 25 not allowing outside telnet aagha Linux - Networking 4 08-29-2003 12:23 AM
allowing ftp connection jeanfey Linux - Security 9 05-21-2002 09:01 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 09:10 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration