-   Linux - General (
-   -   GUI net configuration not working with custom liquorix kernel but does with ifconfig (

aabmass 03-28-2012 10:51 PM

GUI net configuration not working with custom liquorix kernel but does with ifconfig
My system runs Debian Wheezy x86_64. My pci wireless card uses the rt61pci driver. My system is a dell dimension e520 desktop with a Pentium 4. Ask if you need more hardware info!

This was the first time I tried compiling a custom kernel. I started with the sources from, the patches and config.amd64 from and then built like this:


$ cd /usr/src/
$ wget ... #download kernel, liquorix patch and config
$ tar ... #extract kernel and patch
$ cd linux-3.2
$ patch -Np1 -i ../3.2.13-1.patch
$ cp ../config.amd64 .config
$ make localmodconfig
$ make xconfig #outside of the code tag I will expand on how I configured
$ make-kpkg clean
$ fakeroot make-kpkg --initrd --append-to-version=-aaron-liq kernel-image kernel-headers #everything built fine!
$ cd ..
$ sudo dpkg -i *.deb #install new kernel package and headers

Everything built and installed fine! In make xconfig, I removed all of the stuff make localmodconfig missed, mostly drivers, and added a few file system options. I know this step didn't cause the problem because I compiled a kernel with just make localmodconfig and had the same problem.

I can boot into the kernel fine and all is well. However, no GUI has been able to work with configuring my wireless network. I tried KDE's, Gnome's, and wicd, but they don't even list networks.

The weird part is that, out of curiosity because I remember specifically enabling my ralink wireless firmware, I tried configuring my network through iwconfig and ifconfig. It works, but only if I specify a nameserver, ip address, default route, and subnet mask. DHCP with "dhclient wlan0" did not work, and nor did dhcpcd..

I double checked the .config, and I had built DHCP support. This is frustrating because I don't which of those hundreds of options I missed! If anyone can, please help! Just giving this long post a read is appreciated! :)

All times are GMT -5. The time now is 10:36 AM.