-   Linux - General (
-   -   Gtk programs not starting?? (

tearinox 03-02-2004 08:46 PM

Gtk programs not starting??
I had the error one day, The reason I recieved it was because I reinstalled all the slackware packages...

"No fonts found; this probably means that the fontconfig
library is not correctly configured. You may need to
edit the fonts.conf configuration file. More information
about fontconfig can be found in the fontconfig(3) manual
page and on"

So what I did was I read the comments in the /etc/fonts.conf and added the root directory ( / ) as one of the directorys. Now i checked and fc-cache looks at the subdirectories also. So I did fc-cache as root and tried to run many gtk programs, but it still doesn't work.

Any suggestions on how to fix this?

tearinox 03-04-2004 12:08 AM

I reinstalled all my slackware packages. I didn't reformat because I didn't think I needed to. Then all my gtk programs now will not start (gedit, mozilla, etc) because they are missing a font with the error message above. I had fc-cache search the entire hard drive for the fonts to use and it STILL did not work.

I'm thinking I need to add something to font.conf but I read the manual and looked it over but it looks good.

Does anyone know what may be wrong?

tearinox 03-04-2004 05:02 PM

OH YEA!! got it fixed through my own madd skillz =D

#cd /
#find -name *.ttf > file.txt
#less file.txt

And then I found the directories I needed to add! Yay, i fixxored my problemo!

[sarcastic] Thanks for all the help peoples! [/sarcastic]

All times are GMT -5. The time now is 08:05 AM.