-   Linux - General (
-   -   Grub with a USB keyboard and no bios support (

king_scott_2 12-12-2005 04:25 AM

Grub with a USB keyboard and no bios support
I've got this operating system which requires USB mice and keyboards to work. The problem is, I don't have any mouse or keyboard support. I have disabled USB mouse and keyboard support in the Bios settings and it all boots perfectly. But now I can only boot into one OS as grub does not recognise my keyboard. IS there a way I can compile USB keyboard support into the Grub/Lilo/Windows/Darwin bootloader? Thanks

Razze 12-12-2005 05:23 AM


I don't think so. Have you tried enabling USB keyboard support in your BIOS? As far as I understand this is the only way to make it work.


king_scott_2 12-12-2005 05:29 AM

That's the problem. I need to disable USB support in the bios for the operating systems to be able to use my keyboard and mouse. This is going to be one of those visious things I think

Emerson 12-12-2005 08:08 AM

USB keyboard/mice support in BIOS is intended to aid operating systems not aware of these USB devices. Nowadays this feature should be turned always off.
Maybe GAG bootloader will work for you?

king_scott_2 12-13-2005 05:18 PM

No luck. Still no USB keyboard support in that bootloader. Is there a way to compile USB support into Grub or another bootloader?

Emerson 12-13-2005 05:49 PM

There is something really weird going on. Can you go into BIOS setup with that USB keyboard? Because bootloaders are using BIOS I doubt there is an USB option for GRUB at all. Flash in latest BIOS maybe? How old is this motherboard anyway?

king_scott_2 12-13-2005 06:17 PM

New motherboard, just a cheap Medion (aldi) one. It has got legacy USB support and I get get into the bios using it. I just want to be able to select items in Grub using a USB keyboard.

spiug53 01-20-2006 01:54 PM

I seem to have the same problem, my USB keyboard (Kinesis Advantage USB) works for BIOS and is accepted once linux loads but GRUB wont respond to keypresses during the boot and OS selection process. I'm using SUSE10 with kernal 2.6.13 and my motherboard is a new Jetway 939GT4-SLI. I am a :newbie:

Edit 1
I did switch the boot loader via YAST2 from GRUB to LILO but LILO has the same problem as GRUB.
I will be staying with GRUB until a solution is found.

king_scott_2 01-25-2006 08:47 PM

You have a different problem to me. Mine is I want to have control over Grub without USB Bios support. It sounds like you need to go to your BIOS and turn on USB keyboard support, sometimes called Legacy keyboard support I think

spiug53 01-26-2006 08:01 AM

I apolagise for my misunderstanding, I looked again for USB keyboard support in my bios and eventually found it in a subfolder of a subfolder of a subfolder. I turned it on and my problem is solved.
Thanks for helping me

All times are GMT -5. The time now is 11:49 PM.