-   Linux - General (
-   -   Grub w/ Gentoo 2.6.3 - Kernel Panic - typo? (

smehi 03-21-2004 05:42 PM

Grub w/ Gentoo 2.6.3 - Kernel Panic - typo?
So I installed Gentoo yesterday, using their guide from
I followed the instructions, and everything seems to be setup fine. I did my own kernel compile (as opposed to using genkernel), which I have had no problems doing before (on slackware 9.1, 2.6.3).

I ensured the things the manual told me to enable, were in fact enabled.
Anyway, here's my problem =)

I setup grub.conf for dual booting (win2000/gentoo).
I can boot into windows fine, but when I try to boot into Gentoo, it loads the kernel, goes into Framebuffer mode, and stops when it tried to find the root (/) partition.

Here is the error:

VFS: Cannot open root device "hda4" or hda4
Please append a correct "root=" boot option
kernel panic: VFS: Unable to mount rootfs on hda4

Now, I'm used to lilo, and I guess I could still be considerd fairly newbie, but here is my partition table, and grub.conf. What's wrong?
(remember, /boot mounts fine so it isnt a HD or controller issue?)

Partition Table from CFDISK:

hda1 boot Primary NTFS 48241
hda2 Primary Linux ext2 65.81 (dont ask me why 65 heh)
hda5 Logical Linux Swap 1019
hda4 Primary Linux ext3 30721



default 0

timeout 5


title=Gentoo Linux 2.6.3
root (hd0,1)
kernel /kernel-2.6.3-gentoo-r1 root=/dev/hda4 vga=791

title=Windows 2000
root (hd0,0)
chainloader +1


I have also tried
title=Gentoo Linux 2.6.3
root (hd0,1)
kernel /boot/kernel-2.6.3-gentoo-r1 root=/dev/hda4 vga=791

(and slight variatons)
and renaming the kernel.

I have DISALED initrd support in the kernel build.
I DO have a, and a config-2.6.3-gentoo-r1 in /boot

When setting up grub I did:

grub> root (hd0,1)
grub> setup (hd0)
grub> quit

IDE support IS enabled, because grub can decompress the kernel, and access /boot/
/dev/hda4 IS there
When using TAB completion in Grub, I can see that it knows that /boot, is there as well as my root partition (I can see whats in /).

Is this a simple typo? Have I made a mistake in compiling the kernel?

PLEASE help, it's pretty annoying to get stuck on such a (seemingly) minor error.


computergeek84 03-29-2004 02:24 AM

I am assuming that /dev/hda2 is your /boot partition and /dev/hda4 is your / (root) partition. I have had this exact problem with my kernels before, and while you probably have compiled in ext2 support, you also need to compile in support for ext3 in your kernel for /dev/hda4 if you're not using an initial ramdisk.

Try rebuilding your kernel with ext3 compiled in, and see if that doesn't work...

All times are GMT -5. The time now is 06:27 PM.