Latest LQ Deal: Linux Power User Bundle
Go Back > Forums > Linux Forums > Linux - General
User Name
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.


  Search this Thread
Old 06-15-2011, 12:46 PM   #1
Registered: Feb 2011
Posts: 55

Rep: Reputation: 0
Grub Screen Resolution Setting?

Here's an unusual one...

Debian 6 Squeeze. Suddenly, out of the blue, the following happens.

On the boot up to the Grub loader screen my monitor (Acer X193w) displays a "screen resolution not supported" message in a floating window, even though the Grub screen itself is displayed. It appears as a flattened rectangle, like wide screen format films on a TV (black bar top and bottom), the floating message on top of it.

Once Debian is selected and boots, obviously my xorg.conf takes over and sets the 1440X900 resolution and everything is fine. But the Grub start up bothers me.

How do I set the resolution of the Grub loader screen, please?

Many thanks in advance for any help.


Some additional information. I just ran an rkhunter check and I have a warning of a file;


As well as two warnings which I believe are false alarms;

Xzibit Rootkit.

The former is the unusual one. Could this have something to do with the Grub problem? Some activity on my computer, perhaps?

It also warns me of "SSH root access allowed". As I only recently configured SSH on my computer(s), and am a noob at it, I was worried about this sort of thing from the start. Am I being unduly paranoid? Is it unrelated to the Grub problem.

Again, thanks for any help.


Last edited by feeblebrain; 06-15-2011 at 01:08 PM.
Old 06-15-2011, 01:11 PM   #2
Senior Member
Registered: May 2010
Location: Chicago Metro
Distribution: Arch, Gentoo, Slackware
Posts: 1,690

Rep: Reputation: 308Reputation: 308Reputation: 308Reputation: 308
Originally Posted by feeblebrain View Post

How do I set the resolution of the Grub loader screen, please?
This should do it:
Set the desired resolution in /etc/default/grub
Change the value of GRUB_GFXMODE= (Example: GRUB_GFXMODE=800x600)
If unsure of what resolutions are available to GRUB 2 they can be displayed by typing vbeinfo in the GRUB 2 command line. The command line is accessed by typing "c" when the main GRUB 2 menu screen is displayed.
1 members found this post helpful.
Old 06-15-2011, 01:49 PM   #3
Registered: Feb 2011
Posts: 55

Original Poster
Rep: Reputation: 0
Thanks for that.

However, it appears that neither Grub or my suspicion of infiltration is the source of my problem (I am reasonably satisfied that "ed" is just a text editor app, now). The problem of the screen is also present when I enter BIOS at start up, so I think it is probably my graphics card beginning to go on the blink. They don't seem to last very long these days. The weird resolution problem disappears once I select and load either Debian or Windows 7.


Was not any of that. Got to the bottom of this issue. It is the same old problem of the X193w, with a different angle this time. Finicky monitor. Some application run in full screen had reset it. An auto adjust and all was well again. Sorry for the bother!


Last edited by feeblebrain; 06-16-2011 at 08:50 PM.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
[centos] screen resolution setting pcandpc Linux - Distributions 2 03-09-2010 07:22 AM
setting of screen resolution in fedora 11 padubhai Linux - Newbie 18 11-12-2009 08:16 AM
setting boot screen resolution mohtasham1983 Linux - General 6 03-18-2007 12:25 AM
Setting Fedora Core 2 screen resolution danikdj Fedora 4 11-02-2004 03:47 PM
GRUB & Screen Resolution TheSpecial Linux - General 0 01-15-2003 12:22 PM > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 11:23 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration