LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (https://www.linuxquestions.org/questions/linux-general-1/)
-   -   Grub gives "Invalid disk" when dual booting WinXP (https://www.linuxquestions.org/questions/linux-general-1/grub-gives-invalid-disk-when-dual-booting-winxp-324598/)

Archeantus 05-18-2005 01:00 AM

Grub gives "Invalid disk" when dual booting WinXP
 
I have 2 machines that used to be WinXP machines that we have converted to FC3 dual boot with XP machines, with FC3 installed on a brand new disk. Within the same week, they are both started giving me the same exact error. Here's the text I get when selecting "Other" in Grub (I am so ashamed that I even have a Windows partition that I don't want to bother renaming it in grub.conf).

Code:

Booting 'Other'
rootnoverify (hd0, 4)
chainloader +1

Invalid disk
Replace the disk, and then press any key.

As I understand it, the first 3 lines are basically telling you what commands GRUB is executing. It's the last 2 lines that are completly baffling, considering the following.

Both machines have booted into Windows since the last time /etc/grub.conf was edited (one was last changed in January, the other in November.)

Both machines sucesfully mount the Windows drive, and can navigate, view, and edit like I want it to (in other words, no noticable change in the Linux functionality.)

Both machines run FC3 kernel version 2.9

Both machines are behind routers, and networked with other machines in the house.

Both machines are in different cities, operated by different people (Though it's a Mother-Father relationship, and the Father is an 80 year old Navy Vet :) :) It's really fun to be his tech support :) )

One machine is a P2 450, 256 MB RAM.
The other is a P4 1GB, 512 MB RAM.

Thanks for reading, and thanks in advance for any help you can offer. If you do no more than provide a link to a thread I could not find that adresses this issue, I would be just as pleased.

Thanks again!

homey 05-18-2005 06:51 AM

Quote:

rootnoverify (hd0, 4)
chainloader +1
Take that space out from behind the comma .....
Code:

rootnoverify (hd0,4)
If that doesn't do it, post the resuslts of the command: fdisk -l

Archeantus 05-18-2005 11:05 AM

There was a typo in what I posted earlier. In this line
Code:

rootnoverify (hd0, 4)
I posted it like above with a space after the comma, when infact, the grub.conf has no space in it, just the comma like this
Code:

rootnoverify (hd0,40)
I went and tried it with the space and comma and with no comma with only a space, and both gave me the same result:
Code:

Booting 'Other'
rootnoverify (hd0 40)

Error 11: unrecognizable device string
Press any key to continue.

With both situations, it took me back to the GRUB OS Selection screen. If I have just the comma in it, it gives me the error above, but when I hit any key, it takes me to the GRUB screen and says "Booting default in 3 seconds..."

So I think we have the syntax correct with the comma or space.

Since I only live in the house with one of the machines in it, I'll post the fdisk results for that one here, and get the other asap.

Code:

Disk /dev/hda: 16.9 GB, 16907304960 bytes
255 heads, 63 sectors/track, 2055 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
 
  Device Boot      Start        End      Blocks  Id  System
/dev/hda1              2        511    4096575    5  Extended
/dev/hda2  *        512        2055    12402180    c  W95 FAT32 (LBA)
/dev/hda5              2        511    4096543+  b  W95 FAT32
 
Disk /dev/hdb: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
 
  Device Boot      Start        End      Blocks  Id  System
/dev/hdb1  *          1        127    1020096  83  Linux
/dev/hdb2            128        382    2048287+  82  Linux swap
/dev/hdb3            383      19457  153219937+  83  Linux

Thanks for the speedy response! :)

homey 05-18-2005 12:18 PM

Quote:

/dev/hda2 * 512 2055 12402180 c W95 FAT32 (LBA)
That seems to indicate that Windows is on /dev/hda2 or (hd0,1) in grub speak.
So, try this in the grub.conf
Code:

title Windows
        rootnoverify (hd0,1)
        chainloader +1


Archeantus 05-18-2005 04:52 PM

Amazingly enough, it worked. Thank you very much.

I was wondering if you'd be so kind to work your magic again, and translate the proper line into grub speech for this machine?

Code:

Disk /dev/hda: 41.1 GB, 41174138880 bytes
240 heads, 63 sectors/track, 5318 cylinders
Units = cylinders of 15120 * 512 = 7741440 bytes
 
  Device Boot      Start        End      Blocks  Id  System
/dev/hda1  *          1        5317    40196488+  7  HPFS/NTFS
 
Disk /dev/hdb: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
 
  Device Boot      Start        End      Blocks  Id  System
/dev/hdb1  *          1        127    1020096  83  Linux
/dev/hdb2            128        382    2048287+  82  Linux swap
/dev/hdb3            383      19457  153219937+  83  Linux
 
Disk /dev/hdd: 270 MB, 270663680 bytes
14 heads, 40 sectors/track, 944 cylinders
Units = cylinders of 560 * 512 = 286720 bytes
 
  Device Boot      Start        End      Blocks  Id  System
/dev/hdd1              1        944      264300  83  Linux


Now, both machines report to have not had the /etc/grub.conf files changed in months, and have both booted into windows since it was modified. So the question that follows is, Do you know how it could have been changed, and how to prevent that sort of thing happening again in the future?

Thank you very much!

homey 05-18-2005 05:19 PM

Quote:

/dev/hda1 * 1 5317 40196488+ 7 HPFS/NTFS
This machine seems to have Windows on /dev/hda1 (hd0,0) in grub speak.
So the grub.conf should look like this...
Code:

title Windows
        rootnoverify (hd0,0)
        chainloader +1

Sorry, I have no idea how that got changed, never had that happen myself. Do you have other people using the machine?

Archeantus 05-20-2005 07:51 PM

The first machine is used by my 50 year old mom, and the second is my 80 year old grandpa's. Both of them live in house holds that have machines for everyone living there. I don't think there was any tampering done, but you would think that the modified date would have given that away. How ever it works. I'll ssh to my grandpa's machine asap and let ya know if that works.

Thanks for the help!

Archeantus 05-22-2005 03:55 PM

Ok, I'm sitting at the second computer, and the grub.conf is now set as you've prescribed. Still having problems though. Now I get this.

Code:

Booting 'Other'
rootnoverify (hd0 40)
chainloader +1

After that, it'll hang. I've let it sit for about 10 minutes so far, but I think I'm going to let it sit over night tonight, just to make sure. Any suggestions on where to look next? I'm lost.

I have the windows partition mounted as /C and can browse the folder, and open files, so I'm fairly confident it's not a hardware issue. But I was wrong about the grub.conf being unmodified.... :)

Thanks so much for your help. Lemme know if there's something else I can post.

homey 05-22-2005 04:41 PM

Can you post the grub.conf and fdisk -l for that machine?

Archeantus 05-30-2005 08:01 PM

Sorry for not getting back, long weekend.

I don't have acess to the computer today, but I will tomorrow. This computer is the second one I've been working with, and posted the grub.conf earlier, but I'll post it again for you here.

Code:

Disk /dev/hda: 41.1 GB, 41174138880 bytes
240 heads, 63 sectors/track, 5318 cylinders
Units = cylinders of 15120 * 512 = 7741440 bytes
 
  Device Boot      Start        End      Blocks  Id  System
/dev/hda1  *          1        5317    40196488+  7  HPFS/NTFS
 
Disk /dev/hdb: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
 
  Device Boot      Start        End      Blocks  Id  System
/dev/hdb1  *          1        127    1020096  83  Linux
/dev/hdb2            128        382    2048287+  82  Linux swap
/dev/hdb3            383      19457  153219937+  83  Linux
 
Disk /dev/hdd: 270 MB, 270663680 bytes
14 heads, 40 sectors/track, 944 cylinders
Units = cylinders of 560 * 512 = 286720 bytes
 
  Device Boot      Start        End      Blocks  Id  System
/dev/hdd1              1        944      264300  83  Linux

I'll get the fdisk -l to you tomorrow.

Thanks again :)

Archeantus 06-02-2005 03:25 PM

And here's the fdisk -l (finally...)

Code:


Disk /dev/hda: 41.1 GB, 41174138880 bytes
240 heads, 63 sectors/track, 5318 cylinders
Units = cylinders of 15120 * 512 = 7741440 bytes
 
  Device Boot      Start        End      Blocks  Id  System
/dev/hda1  *          1        5317    40196488+  7  HPFS/NTFS
 
Disk /dev/hdb: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
 
  Device Boot      Start        End      Blocks  Id  System
/dev/hdb1  *          1        127    1020096  83  Linux
/dev/hdb2            128        382    2048287+  82  Linux swap
/dev/hdb3            383      19457  153219937+  83  Linux
 
Disk /dev/hdd: 270 MB, 270663680 bytes
14 heads, 40 sectors/track, 944 cylinders
Units = cylinders of 560 * 512 = 286720 bytes
 
  Device Boot      Start        End      Blocks  Id  System
/dev/hdd1              1        944      264300  83  Linux


homey 06-02-2005 03:58 PM

Try setting the grub.conf in post #6

Archeantus 06-02-2005 08:47 PM

I just realized how I goofed. I posted the fdisk -l twice. I took your advice, and edited the grub.conf file, and found that it was the same. So I have a grub.conf that looks just like you posted in #6, and it still does the same thing. By that I mean it displays this and hangs:
Code:

Booting 'Windows'
rootnoverify (hd0,0)
chainloader +1

It won't move from there.

I've begun to think that since you say the grub.conf file is correct that it may be an issue with the Windows software. While I wait for another suggestion from ya, I'm going to attempt a windows Restore from the boot disk.
Thanks again!

For grins, here's the grub.conf

Code:

# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE:  You have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /boot/, eg.
#          root (hd1,0)
#          kernel /vmlinuz-version ro root=/dev/hdb3
#          initrd /initrd-version.img
#boot=/dev/hda
default=0
timeout=5
splashimage=(hd1,0)/grub/splash.xpm.gz
hiddenmenu
title Fedora Core (2.6.9-1.724_FC3)
        root (hd1,0)
        kernel /vmlinuz-2.6.9-1.724_FC3 ro root=LABEL=/
        initrd /initrd-2.6.9-1.724_FC3.img
title Fedora Core (2.6.9-1.681_FC3)
        root (hd1,0)
        kernel /vmlinuz-2.6.9-1.681_FC3 ro root=LABEL=/
        initrd /initrd-2.6.9-1.681_FC3.img
title Windows
        rootnoverify (hd0,0)
        chainloader +1

And the fdisk -l is posted twice in a row, cause I'm not the sharpest knife....


All times are GMT -5. The time now is 03:31 PM.