-   Linux - General (
-   -   GRUB Error 21 again (

wannabelinux 06-05-2007 07:51 AM

GRUB Error 21 again
Please help! I'm VERY new to Linux, in fact this problem is rearing it's ugly head on my first installation.
I tried installing SUSE Linux 10.1 on my work PC as a client is using Linux throughout their organisation and I wanted to test my software on the platform. BUT . . .
Once the Installation was completed (without errors) it rebooted and I've been plagued with the Error 21 screen since.
I have read the thread addressing the same problem that Sebastian had but my situation is a lot worse it would seem.
He at least had a clue as to what to try but I do not.

Now some background, the PC is running 2 SATA hard drives and I'm sure that I installed the Linux on the master drive. I can go into my BIOS and I did try changing settings but to no avail.
If I leave the DVD in it loads up to the Installation menu and I've tried repairing the installation which gives an OK to everything but it gives an error when it gets to the 'Mounting All Partitions' where it says it's problematic.

Now I know that this is the problem, but how (and please explain every step as simply as possible) can i fix this or (worst case scenario) remove the Linux installations so that I can at least access the Windows system. (I have some very expensive software on the windows system which can not be re-installed so a re-format is not an option!)

PLEASE help!!

Crooksey 06-05-2007 08:37 AM

To what location did you install the bootloader, it wants to go into the MBR of /dev/sda

Emerson 06-05-2007 08:47 AM

Tell us where was Windows installed before you installed SUSE. Windows cannot boot from a secondary drive, please clarify.

wannabelinux 06-06-2007 02:37 AM

First to answer your Qs - Windows is loaded on the Primary drive (Master drive!?)
Bootloader I can only assume from what I've discovered (read below) is loaded into sdb7
PS - what is MBR?
I pretty much didn't change anything in the setup other than the disk space that Linux wanted when installing, I gave it 30GB.
Could this have screwed up my installation?
Please read what I've found out and advise accordingly.
Thanks in advance for the help - it's much appreciated.

So I did get it to work, but in a very round about way. If i boot from the CD and do an installation selecting "repair installed system", do an automatic repair (activating the swap area [/dev/sdb6]), get the message "an error occured during installation" it brings up the main menu (kernel default) where I select 'Start Installation or System', then 'Boot Installed System'.
It lists the root partitions as:
sda1 : ntfs
sdb1 : ntfs
sdb5 : ntfs
sdb7 : reiserfs
sdb8 : reiserfs
From there I select /dev/sd7 as sdb8 is an invalid selection
This gets me into Linux (Yay!)
Now, my question is:
What must I do to point it straight to sdb7?
And How can I load up Windows (still not able to)?

syg00 06-06-2007 03:07 AM

The MBR is the Master Boot Record - it's what enables you to boot an operating system. The fact that you get a grub error means that you did install to the MBR.
So we can tick that box.

Do you get a (usable) grub prompt when you get the "21" ??? - i.e. will it accept keyboard input ??. If so, try (no quotes) "find /boot/grub/stage1"
Hopefully it'll return with "(hd1,6)". If it fails try "find /grub/stage1".
Whatever you get back use in the next command - enter both of these then reboot.

root (hd1,6)
setup (hd0)

If you dont get a usable grub prompt at boot, open a terminal from your Linux system, then type in "grub", and start with the find command above.

Edit: fixed reference to error code.

wannabelinux 06-06-2007 04:50 AM

I did as you said, grub prompt is unusable so in the terminal I did as you said
"find /boot/grub/stage1"
it did return with "(hd1,6)"

then I ran


root (hd1,6) setup (hd0)

and rebooted, to get the same error again.
You seem to know what you are talking about. Are we on the road to success? And can I get into my Windows system at all?

syg00 06-06-2007 05:00 AM

This isn't making a lot of sense.
To get your Windoze booting again, boot the XP CD, and hit the <r> key when it says so on the splash screen. This will get you into the Recovery Console.
Enter fixmbr then reboot (you might get a "scare" message - I've never heard of this causing a corruption).

You should be right to go - however you'll need the (Linux) CD to get to your Linux system.

wannabelinux 06-06-2007 05:44 AM

And the Linux?

Is it possible that the hard drives are SATA that is causing the hassles?
Does anyone know what I can do?

All times are GMT -5. The time now is 02:35 PM.