-   Linux - General (
-   -   Grub error 17, and wont reinstall using grub-install! (

chiefreborn 06-27-2005 06:42 PM

Grub error 17, and wont reinstall using grub-install!
Okay, I had FC4 running well. I went to use WinXP and I rebooted my computer for some updates I did, and I wanted to go to FC4 real quick. When it started to load grub, it gave me an error 17. I looked around on the forums, and all of people's problems seemed to be solved by reinstalling grub. (I have already done this once) I figured, okay, I'll just run grub-install /dev/hda. But it wont install! It tells me:

The file /boot/grub/stage1 not read correctly.

Got any ideas?

chiefreborn 06-27-2005 07:01 PM

Okay, I fixed it, as it turns out, Windows changed my partition type to Amoeba instead of the Linux type it should be...anyone know how to fix this??? The partition type changes every time I boot WinXP!!!!

homey 06-27-2005 07:37 PM

I've never seen that one! You could get even and boot up with a livecd and delete the windows partition. :)

chiefreborn 06-27-2005 09:25 PM

:D Yeah but I would lose all valuble WinXP programs that I have...such as Macromedia Studio MX 2004 and all my 3D modeling programs...3ds max...Maya...etc.

micahgeek 03-07-2006 06:02 PM

Change Partition Types
Use the program CFDISk. It lets you change the partition type. Type in cfdisk to go to it. Then select the Linux partition with the up and down arrows. Press t to go to the type page and then press enter to select the default. (Linux)

kadhiravan.r 06-06-2007 10:48 AM

try this....if it is not a critical box.
First boot through winxp and Press R for repair->press 1 for windows->give admin passwd if asked..--> run new boot loader will be created and only windows works.

After that boot through FC4 cd and rescue mode--?chroot /mnt/sysimage-->grub-install /dev/..

this will work Hope..


saikee 06-06-2007 11:29 AM

micahgeek's suggestion is the easiest and the quickest way.

The terminal programs like cfdisk or fdisk can be used to changed the partition number. For Linux it is always type 83. Swap has a partition type 82.

Red Hat family which Fedora belongs does not have cfdisk but sfdisk. So use fdisk which is available virtually in every distro.

All times are GMT -5. The time now is 01:52 AM.