-   Linux - General (
-   -   grub - dual boot fedora / XP probs (

linuxmfx 08-15-2005 04:50 PM

grub - dual boot fedora / XP probs

I've got a problem dual booting with Grub (version with fedora 3) - to windows XP. I've read some really informative threads here (aus9's for example) and have learnt a lot about grub, tried many examples and feel like my settings should work - but to no avail.

Here is my setup:
I have 3 hard disks [2 parallel (disks 1 and 2), and 1 SATA (disk 3)].
For reasons I won't go into - my windows XP is on SATA disk 3, which when I was just running XP, was set to be the boot disk in the bios - and sucessfully go's straight into XP at boot. All is well.

Now I have loaded linux and the grub bootloader on the first hard drive. If I set the bios to boot from the first drive, I get the grub menu. I can boot into linux from it. I also want to be able to boot to XP from here, but that's where the problem starts.

Booting from disk 1 in the bios - my XP hard drive is disk hd2 in grub terms, and the XP system partition is the first one (hd2,0) - formatted NTFS 15GB.

I've tried pretty much every setting I can find for grub to boot XP - Some examples are various combinations of the listings below:

map (hd2) (hd0)
map (hd0) (hd2)
chainloader +1
[* items sometimes removed]

Various things happen (I can be specific) - from just staying at the grub screen and not doing anything, or I get cant find NTLDR (spelling?).

What is odd, is that there are 3 partitions on the XP SATA drive, but when I tab in command line grub mode
grub>root (hd2, [tab]
I only get the option of having 0 - it can't see the other partitions.

Please help!!
Obviously, I can just choose the boot drive from the BIOS for now if I want Linux or XP - but it would be nice to have it tidy and not have to keep changing the bios.

Thanks for any input - this site is invaluable for people experimenting with Linux.

leonscape 08-15-2005 05:05 PM

I'm having exactly the same problems, the mystery is that I once had this working with XP, Linux and Win2k. I removed win2k and reinstalled with just Linux, and XP. did the XP first, then installed Linux. Now XP won't load.

Something has definatley changed in the way XP gets booted up but I can't figure what it is, maybe the Bootblock for XP has become more critical so you just can't boot the partition, it has to be the full disk, almost like they're trying to make it harder to dual boot into Windows from Linux. Now I'm sound like a conspiracy theroist gotta lay off a bit...

Luckily for me I can just press F8, and the MOBO gives me a booting option and I boot into WinXP that way ( Not that I use it much anymore ).

Something weird is definatley going on.

bushidozen 08-15-2005 05:13 PM

You might want to install GRUB on the MBR of the SATA drive that Windows is on.

linuxmfx 08-15-2005 05:31 PM

Thanks for the feedback so far.
Yes - I'm using F8 a lot too!
Any additional explanation on moving grub to the other drive would be appreciated, although I'm a little reluctant to touch that drive as it is very stable and I rely on XP for many reasons..... If grub ended up not working on that drive, I'd be stuck!

aikidoist72 08-15-2005 05:47 PM

Just remember that some SATA drives are not really SATA drives but fake ones!! I know....cause I got one! You will need to do some research about this, because if it is fake like my Promise Fasttrak TX2 - meaning it is just an Ultra ATA software driven connection, then GRUB will see this as the first hard drive. IE hd0.

Also if it is a real SATA - lucky you, then the GRUB entry changes from hd to sd. IE sd0

From the original post the entry would look like this


chainloader +1

The mapping is only needed if you have XP anywhere other than the first drive.

linuxmfx 08-20-2005 06:30 PM

Thanks for your feedback. I finally managed to get it working. Knowing that the SATA drive might not be the drive number I thought it should be (thanks aikidoist72) got the problem solved.

So, here's my final grub.

map (hd0) (hd1)
map (hd1) (hd0)
chainloader +1

Why the SATA comes up as hd1 in grub, when it shouold be hd2 according to my bios, I still don't understand. I found it very useful from aus9's post to know that if you go to grub command line and tab when at the >rootnoverify (hd1, stage, it lists the partitions - which is how I worked out what disk was what.
It seems in grub, the SATA disk is still hd? not sd? (sorry - no hash key on this mac laptop!).

So - finally a bootloader that works. Thank again.

All times are GMT -5. The time now is 10:36 PM.