LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 06-10-2007, 02:38 PM   #1
arnuld
Member
 
Registered: Dec 2005
Location: Punjab (INDIA)
Distribution: Arch
Posts: 211

Rep: Reputation: 30
GRUB does not timeout


as i installed this new ATA hard disk, GRUB have stopped giving default timeout option. GRUB no longer boots the default selection after chosen time, HECK i cannot see any timeout option on my splash screen and this problem is same on all distros i have tried. earlier i had SATA and there were no problems with timeout. right now i am using CRUX:

-----------from my Terminal -------------
arnuld@crux ~ $ cat /boot/grub/grub.conf
splashimage (hd0,0)/grub/crux03.xpm.gz

timeout 25
default 0

title CRUX GNU
kernel (hd0,0)/linux-2.6.20.13-crux root=/dev/hda5 vga=773

title CRUX Fallback
kernel (hd0,0)/linux-2.6.20.13-crux.old root=/dev/hda5


arnuld@crux ~ $ cat /etc/fstab
#
# /etc/fstab: static file system information
#
# <file system> <dir> <type> <options> <dump> <pass>

/dev/hda1 /boot ext2 defaults,noatime 1 2
/dev/hda5 / ext3 defaults,noatime 0 1
/dev/hda6 /home ext3 defaults 0 1
/dev/hda2 swap swap defaults 0 0

/dev/hda7 /mnt/Backup ext3 defaults 0 1

/dev/cdrom /mnt/cdrom iso9660 ro,user,noauto,unhide 0 0
/dev/dvd /mnt/dvd udf ro,user,noauto,unhide 0 0
/dev/fd0 /mnt/fd0 vfat user,noauto,unhide 0 0

devpts /dev/pts devpts defaults 0 0
none /sys sysfs defaults 0 0
none /proc proc defaults 0 0
tmp /tmp tmpfs defaults 0 0
#shm /dev/shm tmpfs defaults 0 0
#usb /proc/bus/usb usbfs defaults 0 0

# End of file

arnuld@crux ~ $ su
Password:
root@crux arnuld $ fdisk -l

Disk /dev/hda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hda1 * 1 25 200781 83 Linux
/dev/hda2 26 281 2056320 82 Linux swap / Solaris
/dev/hda3 282 6607 50813595 5 Extended
/dev/hda5 282 1741 11727418+ 83 Linux
/dev/hda6 1742 4174 19543041 83 Linux
/dev/hda7 4175 6607 19543041 83 Linux
root@crux arnuld $
 
Old 06-10-2007, 03:52 PM   #2
saikee
Senior Member
 
Registered: Sep 2005
Location: Newcastle upon Tyne UK
Distribution: Any free distro.
Posts: 3,398
Blog Entries: 1

Rep: Reputation: 112Reputation: 112
What are you talking about?

Your menu.lst has
Code:
timeout 25
Do you mean after 25 second the first choice of CRUX GNU doesn't boot?

You don't have another system to boot to, just the same distro with an older kernel of the same version.
 
Old 06-10-2007, 04:10 PM   #3
arnuld
Member
 
Registered: Dec 2005
Location: Punjab (INDIA)
Distribution: Arch
Posts: 211

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by saikee
What are you talking about?

Your menu.lst has
Code:
timeout 25
Do you mean after 25 second the first choice of CRUX GNU doesn't boot?
NO, i meant you can see seconds going down like 25..24..23..22 on GRUB splash screen and after 0 the default selection boots. GRUB *shows* you that decreasing timeout.

BUT i don't see this "timeout going down" on my GRUB splash screen and hence i have to use arrow key and press Enter to select the OS i want to boot.

Quote:
Originally Posted by saikee
You don't have another system to boot to, just the same distro with an older kernel of the same version.
i have 2 selections here and by default 1st one is highlighted. but GRUB neither shows timeout nor able to make it happen.
 
Old 06-10-2007, 04:26 PM   #4
saikee
Senior Member
 
Registered: Sep 2005
Location: Newcastle upon Tyne UK
Distribution: Any free distro.
Posts: 3,398
Blog Entries: 1

Rep: Reputation: 112Reputation: 112
I think we are talking about Grub Legacy here and the development work has frozen since version 0.97 so there is no way Grub can be changed.

In your case I suggest to put a "#" infront of the splashimage statement to disable it, as you will then see Grub in the text mode with nothing to hide.

I use ATA and SATA on my box but never notice any anomaly in the timeout statement. Mind you I seldom use it myself or add couple of zero to lengthen the timeout. I need time to select from the 150 entries and my menu.lst are nested together as a set.
 
Old 06-11-2007, 01:13 AM   #5
arnuld
Member
 
Registered: Dec 2005
Location: Punjab (INDIA)
Distribution: Arch
Posts: 211

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by saikee
I think we are talking about Grub Legacy here and the development work has frozen since version 0.97 so there is no way Grub can be changed.

In your case I suggest to put a "#" infront of the splashimage statement to disable it, as you will then see Grub in the text mode with nothing to hide.

I use ATA and SATA on my box but never notice any anomaly in the timeout statement. Mind you I seldom use it myself or add couple of zero to lengthen the timeout. I need time to select from the 150 entries and my menu.lst are nested together as a set.

somebody at Gentoo Forums shew me this bug of GRUB:

http://savannah.gnu.org/bugs/?14620

i have the same problem...exactly same
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
change GRUB timeout Gijet Red Hat 3 02-12-2004 11:53 AM
timeout (delay) in [RedHat] Grub southsibling Linux - Software 4 12-28-2003 12:24 PM
GRUB timeout problem badar52 Red Hat 3 12-08-2003 12:23 PM
GRUB:is instant timeout possible? unholy Linux - General 2 10-08-2003 07:36 AM
GRUB splash image and timeout not working arobinson74 Linux - General 8 11-22-2002 06:26 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 10:25 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration