-   Linux - General (
-   -   Gnome create launcher for binary (

newbutold 07-18-2003 02:30 AM

Gnome create launcher for binary
I have been trying to create a launcher on my desktop for IBM's eclipse. Apparently the eclipse executable is a binary. When I create a launcher for it I get an invalid directory message...? e.g. /user/java/eclipse/eclipse where the last entry is the program to be executed. I've tried to put a ";" between the "/" and "eclipse" nut nothing seeems to work. Can anyone shed some light here?

Thanks in advance


aizkorri 07-18-2003 03:07 AM

well, I don't know...
are you sure that this is the binary?, I mean, it can be possible to be a binary called eclipse in /usr/bin.
can you execute /user/java/eclipse/eclipse in the console?

newbutold 07-18-2003 09:11 AM

Thanks for your response.

I can go to the directory and execute the eclipse binary using ./eclipse. No problem. When I try it in the launcher it does'nt execute.

newbutold :scratch:

synecdoche 07-18-2003 04:35 PM

I have the same problem.

For example, the binary for Neverwinter Nights is in /home/user/NWN/

And to run it, I would go to that directory and at the bash prompt type ./nwn

I wanted to make an icon for it on my root window, and so made a shortcut pointing to /home/user/NWN/nwn and it didn't work. Tried telling to run in a terminal. Didn't work. Tried changing it to ./nwn and it still didn't work.

I've yet been unable to figure it out.


newbutold 07-18-2003 05:39 PM

Well synecdoche, looks like no one has a solution for us. I've been to the gnome site and red hat to check the docs. There is no indication anywhere that I have looked that tells you what to do with a problem like this. The closest thing I came to involved the file/program associations function. I couldn't find any clear definition about this to understand it sufficiently to allow me to try anything with it. I'm not sure I'm even in the right forum!

Does anyone out there know where to get solid dependable information on how to use GNOME?


aizkorri 07-21-2003 02:28 AM

it could be that the binary is not in the PATH,
you can type

in the console or add it to your .bashrc or .cshrc file so that it is set whenever you log in.
Then you should be able to execute the binary everywhere.

All times are GMT -5. The time now is 01:16 AM.