-   Linux - General (
-   -   Gentoo-PC not booting with root on LVM2 (

Verbato 11-21-2007 10:28 PM

Gentoo-PC not booting with root on LVM2
So I've googled. And I've googled. And I've googled some more.
I thought this was easy. And it probably is. But it isn't.
So how do I get my pc to boot from an LVM2-root?


hda1 - boot
hda2 - swap
hda3 - 8e/LVM2

hde1 - 8e
hdf1 - 8e
hdg1 - 8e

(Old PC, no more than some 60GB in all)

I guess the problem hangs on mkinitrd..?
I have to make an initial ramdisk that will load a (homemade) kernel+modules+vgscan/vgchange (dynamically linked) etc. Right?
But how..?

Please, Mr/Ms kind soul, point me in the right direction. Cause I need this PC to run like this... Thanks :)

syg00 11-21-2007 11:42 PM

Go check the doco at; the best there is.

Given you are compiling your own kernel, you can include LVM2 and dev mapper - no need for an initrd I can see.
I don't use it though, so I'm only guessing ...

Verbato 11-22-2007 07:05 AM

I forgot to mention; I have read the gentoo-documentation, where it says "Make your initrd", and all following.
It seems as though "The cowboy way" is the only one of those that would work. But it doesn't.
Or well, it is too much of a mess for me to get it right. I have tried...
And I've tried googling for another solution on the net. Anything that'd point me in the right direction...
And so I'm asking here for any pointers please. Thank you very much. :)

syg00 11-22-2007 07:17 AM

This would appear a good start.

Verbato 11-22-2007 07:45 PM

Yep. So it was. Thanks :)
I'm still stuck though... Probably something set wrong in grub.
I have tried initrd. I have tried mkinitrd with variuos options (added dm-mod to initrd).
Still stuck. I have tried passing various root=/dev/ram0 ...hda1.../dev/system/lvmroot... No luck.
I have tried having no initrd= in grub. I am stuck.

And this is the page I've tried to follow:
Which isn't too clear for me. Yes I'm stupid. Please help me. ;-)

All times are GMT -5. The time now is 02:20 PM.