-   Linux - General (
-   -   gentoo + emerge --update world (

kurrupt 06-04-2005 03:00 PM

gentoo + emerge --update world
hey guys is there a safer way of updating your world... last night i did an emerge --update world and it distroyed my gentoo box.. i have to reinstall everything :(:confused: :(

jtshaw 06-04-2005 03:30 PM

Umm... what was your ACCEPT_KEYWORDS set to?

oneandoneis2 06-04-2005 04:29 PM

Did you etc-update properly?

jtshaw 06-04-2005 07:56 PM

Another quick thing... I had a problem early this morning (aparently) as a result of an emerge update.

Bunch of programs were complaining that was missing...

Problem was for some reason gcc-config didn't get run when it updated my compiler from gcc-3.4.3-blah to 3.4.4. Once I ran gcc-config it correctly my /etc/ file and everything was groovy again.... you might have run into the same problem?

kurrupt 06-04-2005 08:41 PM

jtshaw!! that was exactly my problem!!!! thats exactly what happend.. shoot.. what was the fix?!!!! i just started to install gentoo again :(

jtshaw 06-04-2005 08:51 PM

Sorry... I wish I had checked the result of my emerge world earlier....

Ok.. what happened was I got a gcc update to version 3.4.4 which replaced the version I had previously... but emerge didn't run the gcc-config tool which updates the system paths and linking information to the new gcc... so as a result the system couldn't find the libstdc++ library. Running gcc-config i686-pc-linux-gnu-3.4.4 updated everything and fixed the program.

rogerius 06-05-2005 12:44 AM

Hello there!

This is my problem too! But... :(
Running 'gcc-config powerpc-unkonwn-linux-gnu-3.4.3' did not work... (Yes, I'm using ppc)
Still looking for that '' and there is a message about missing portage CHOST too...
When I run 'gcc -v' everithing points to the new gcc.

Any idea?

jtshaw 06-05-2005 12:59 AM

Is the correctly directory containing the file in your /etc/ file? If not, add it and you should be all set.

Make sure to run ldconfig anytime you update /etc/

rogerius 06-05-2005 01:18 AM

Yepeee!!!! :) :) :) :)

Thank you!!!! It's working now!!!!

Have a nice day!

All times are GMT -5. The time now is 01:38 PM.