Share your knowledge at the LQ Wiki.
Go Back > Forums > Linux Forums > Linux - General
User Name
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.


  Search this Thread
Old 12-21-2003, 10:00 PM   #1
LQ Newbie
Registered: Sep 2003
Location: Van(rainy)couver
Distribution: Fedora Core 1
Posts: 22

Rep: Reputation: 15
Gconf lock problem when logging in as user

You see, being as clever as I am, I decided to reset the permissions for all the files in my /home/matt directory to 777. You might ask why I would do such a silly act, but then I couldn't really answer it as the reasons are lost to me, somewhere in the sands of time. Simply put, what's important is that you help me. I believe the exact command I used to do it was: "chmod -R 777 /home/matt". After reseting, for some reason this command, or the devlish execution as a result of it, seems to have made it impossible for me to log on as "matt" without viewing a warning message and a somewhat artistically challenged GUI. The part that will probably be of greatest interest to you- as it was to me- would be the error message- to me because it was the only coherent piece of output I received after logging in; and to you, because it will aid you to help me.

I was not presented with the opportunity to copy and paste the message but it generally went something like this: The file ~./gconfd/lock/ior does not exist. Please visit h**p:// for details. And so I did. What I found, however, was not to my liking. Apparently the file I am missing is a lock for the gnome's creative method of storing application preferences which is called GConf- the method not the file. I have already reset /home/matt/ to 755 hoping it will set things right, unfortunatley it did not. My question is: Can I just create the lock file myself (as root)?.

ok I believe the best question I can ask is: "What are the proper permissions for the ~/.gconf/ and ~/.gconfd/ folders and their contents?"

Last edited by garamatt; 12-21-2003 at 10:22 PM.
Old 12-22-2003, 12:16 AM   #2
LQ Guru
Registered: Feb 2003
Location: Colorado Springs, CO
Distribution: Gentoo
Posts: 2,018

Rep: Reputation: 48
Well, to start with, the proper permissions for any file are very rarely 777 Stuff in your home directory should generally be readable/writable only by you...

Anyhow, gconf has given me headaches before. See if deleting the whole ~/.gconf and/or ~/.gconfd folders helps. There's rarely anything but temporary files and such in there. Move them to a temporary location if deleting them is uncomfortable.
Old 12-22-2003, 12:52 AM   #3
LQ Newbie
Registered: Sep 2003
Location: Van(rainy)couver
Distribution: Fedora Core 1
Posts: 22

Original Poster
Rep: Reputation: 15
Well that did work. No more artistically challenged GUI!

Now, the only problem is I lost all my application settings. Perhaps I will meddle with the ~/.gconfd/apps folder.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
problem with gconf Bug Linux - General 3 08-18-2005 10:55 AM
Gconf Error on New User Account! Forezt Linux - Software 1 01-23-2005 09:18 AM
Problem when logging as a user (permission denied) Dartelin Linux - Newbie 3 05-03-2004 01:15 PM
user logging problem brijesh Linux - General 1 07-10-2003 11:36 AM
gconf error/problem gco10996 Linux - General 0 10-24-2002 03:11 PM > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 06:15 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration