-   Linux - General (
-   -   fsck damaged my file system (

Dr_Death_UAE 02-15-2006 10:49 AM

fsck damaged my file system

i was facing some problems with my wireless , when i run some software like wifi_radar and wpa_supplicant, my linux hung.

so i thought its may be some damaged files cause the problem .

i just run "fsck" , it show me that my linux partition in mounted /dev/hda2 (i have windows on /dev/hda1)

and then i reboot , and i cant enter my linux (stuck in the grub).

I boot from knoppix CD, it show my widows partition is ok, but it cant mount my linux partition.
it give me this error message:
mount: I could not determine the filesystem type, and none was specified.

I boot fedora CD, and it show me my /hda2 as Linux native without mounted point.

/dev/hda1 vfat
/dev/hda2 Linux native
/dev/hda3 swap

any advice ?

sorry for my English

Matir 02-15-2006 12:30 PM

Try re-running fsck on /dev/hda2. Fsck should only repair filesystems: I've never seen any damage from using it.

Dr_Death_UAE 02-15-2006 12:38 PM

i cant enter my hda2.

im also shocked, i always use fsck to fix problems.

i think i will format my linux, and recover it later.

i google it, but no clear solution.


Matir 02-15-2006 12:39 PM

You should still be able to fsck it.

Dr_Death_UAE 02-15-2006 03:52 PM

Hi matir,

I fixed the problem, i used knoppix 4.2, its fsck was good and work fine with me, i was using old version of knoppix before.

fsck -a /dev/hda2
its fix most blocks and Inode's

but know when fedora start booting it stop and give me this message:

Uncompressing Linux... Ok, booting the kernel.
Red Hat nash version 4.2.15 starting
exec of init (/bin/sh)failed!!!: 2
Kernel panic - not syncing: Attempted to kill init!

i'll google it now.

Dr_Death_UAE 02-16-2006 01:51 AM

hmmmm, still one issue, there is no mount point for /hda2

any suggestion.


Matir 02-16-2006 01:59 PM

If /dev/hda2 is your root filesystem, it should be mounted on /.

alienDog 02-17-2006 02:19 AM

You did not run fsck while /dev/hda2 was mounted, did you? The best way is to boot your system up from a rescue disk (knoppix works fine) and then fun fsck on your /dev/hda2 without mounting it. Do not run fsck on mounted filesystems, it may indeed break them! If you need to check your root filesystem (which is of course always mounted when your system is up), you can use:


shutdown -rF now
to force the filesystems to be checked on bootup.

Dr_Death_UAE 02-17-2006 09:10 AM

thankx guys, i mount my system from knoppix after fix the block and Inodes issue , i recover my files and formate my system.

Matir, no my /dev/hda2 wasnt mounted on / after i fix it. that was the only problem remained.

alienDog, yes that what i did, i run fsck when my /hda2 was mounted.

you are right, knoppix in the perfect and safest to recover systems.

Best Regards.

frodo 02-02-2010 05:07 AM

Sorry to add to such an old thread, but I thought that it should be added that you should >>never<< run fsck on a mounted file system, always use the rescue mode of your install CD or something like Knoppix as was suggested earlier.

Dr_Death_UAE 02-03-2010 08:21 AM

wooow this thread is 4 year's old (^_*), but thanks for your comment's it may help someone from google

All times are GMT -5. The time now is 09:22 PM.