LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 04-07-2005, 03:45 PM   #1
jasone
Member
 
Registered: Oct 2004
Location: Sweden
Distribution: FreeBSD, OpenBSD, Debian Etch
Posts: 160

Rep: Reputation: 30
from wlan to lan with out reboot?


Hi!

How do I do if Ive used my wireless nic from startup and would like to use my regular one with out rebooting? My eth0 is wlan and eth1 is my wired one. All I could think of was ifconfig eth0 down but i doesn't work. Im using slackware 10.1
 
Old 04-07-2005, 03:58 PM   #2
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Debian Testing
Posts: 19,192
Blog Entries: 4

Rep: Reputation: 475Reputation: 475Reputation: 475Reputation: 475Reputation: 475
I'd guess that your wlan is wlan0 and eth0 is wired, unless you have changed them somehow. What does ifconfig and iwconfig show?
 
Old 04-07-2005, 03:59 PM   #3
Komakino
Senior Member
 
Registered: Feb 2004
Location: Somerset, England
Distribution: Slackware 10.2, Slackware 10.0, Ubuntu 9.10
Posts: 1,938

Rep: Reputation: 55
Why doesn't it work? That looks fine to me.
ifconfig eth0 down
ifconfig eth1 up
should be fine. You need to be root of course.
 
Old 04-07-2005, 04:05 PM   #4
jasone
Member
 
Registered: Oct 2004
Location: Sweden
Distribution: FreeBSD, OpenBSD, Debian Etch
Posts: 160

Original Poster
Rep: Reputation: 30
Well it doesn't (as root) =(

My iwcinfig says eth0 is IEEE 802.11-DS
My ifcinfig says eth0 is IEEE 802.11-DS and eth1 = no wireless extensions...
 
Old 04-07-2005, 04:09 PM   #5
Komakino
Senior Member
 
Registered: Feb 2004
Location: Somerset, England
Distribution: Slackware 10.2, Slackware 10.0, Ubuntu 9.10
Posts: 1,938

Rep: Reputation: 55
Come on, work with us!! "it doesn't work" gives us bugger all to help decide what the problem is and what a solution could be. What actually happens when you try to do it? Are there any error messages? What are they...?
 
Old 04-07-2005, 04:32 PM   #6
jasone
Member
 
Registered: Oct 2004
Location: Sweden
Distribution: FreeBSD, OpenBSD, Debian Etch
Posts: 160

Original Poster
Rep: Reputation: 30
Ok sorry, I thought this was a simple thing!

Nothing happens, no error not anything. I need to reboot without my pcmcia nic put in to get a ip from my router. I dont have a clue. But the right thing to do is:

#ifconfig eth0 down
#ifconfig eth1 up

or what?

Thanks for your time!
 
Old 04-07-2005, 05:04 PM   #7
Komakino
Senior Member
 
Registered: Feb 2004
Location: Somerset, England
Distribution: Slackware 10.2, Slackware 10.0, Ubuntu 9.10
Posts: 1,938

Rep: Reputation: 55
So after you've done:
ifconfig eth0 down
ifconfig eth1 up

what does just:
ifconfig
on its own say about eth1?
 
Old 04-07-2005, 05:25 PM   #8
jasone
Member
 
Registered: Oct 2004
Location: Sweden
Distribution: FreeBSD, OpenBSD, Debian Etch
Posts: 160

Original Poster
Rep: Reputation: 30
#ifconfig

eth1
Link encap:Ethernet HWaddr xx:xx:xx:xx:xx:xx
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric 1
RX packets:21 errors:0 dropped:0 overruns:0 frame:0
Tx packets same as above...................
Collisions:0 txqueuelen:1000
Rx bytes:3352 (3.2 Kb) Tx bytes:0 (0.0 b)
Interupt:11 Baseadress:0xd000

lo
Linkencap:local loopback
inte addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 MEtric:1
RX packets:18884 errors:0 dropped:0 overruns:0 frame:0
Tx packets same as above...................
Collisions:0 txqueuelen:0
Rx bytes:4106668 (3.9 Mb) Tx bytes:4106668 (3.9 Mb)
 
Old 04-07-2005, 05:40 PM   #9
Komakino
Senior Member
 
Registered: Feb 2004
Location: Somerset, England
Distribution: Slackware 10.2, Slackware 10.0, Ubuntu 9.10
Posts: 1,938

Rep: Reputation: 55
You're missing an IP address.
On a lan you'd use dhcpcd or dhclient to get an IP. Try running one of those.
 
Old 04-07-2005, 05:41 PM   #10
Komakino
Senior Member
 
Registered: Feb 2004
Location: Somerset, England
Distribution: Slackware 10.2, Slackware 10.0, Ubuntu 9.10
Posts: 1,938

Rep: Reputation: 55
forgot to mention, if it's at all an option you can specify an IP address when you do ifconfig:
ifconfig eth1 192.168.1.1 up
or whatever.
 
Old 04-08-2005, 04:57 AM   #11
jasone
Member
 
Registered: Oct 2004
Location: Sweden
Distribution: FreeBSD, OpenBSD, Debian Etch
Posts: 160

Original Poster
Rep: Reputation: 30
Thanks!

I thought it was something like that. So is dhcpcd included in slack 10.1 or do I need to install it? I'm at work now so I'll try when I get home to my loved one ;-) Isn't there a way to make this change automatic?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
wlan config lost after reboot dblklk Mandriva 2 08-14-2005 02:10 PM
Automatic switching between LAN and WLAN chrismic Linux - Wireless Networking 0 12-19-2004 07:38 PM
LAN and WLAN configuration geostone Linux - Wireless Networking 1 11-10-2004 01:15 AM
BEST lan or wlan for SuSe 9.0 nuwuser Linux - Wireless Networking 0 02-14-2004 04:22 PM
wlan.conf? where to put w-lan pci settings mi6 Slackware 2 06-03-2003 06:23 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 01:12 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration