-   Linux - General (
-   -   From 2.6.16 to 2.6.19: problems with fglrx and net interfaces (

simopal6 01-02-2007 02:16 PM

From 2.6.16 to 2.6.19: problems with fglrx and net interfaces
I've just upgraded my kernel from version 2.6.16 to 2.6.19, and i've had some problems:
1) the main problem is that my network interfaces switched names, eth0 has become eth1, and eth1 eth0. Why did this happen?
2) the kernel doesn't autoload my ati fglrx module anymore!
3) instead, it loads the ipv6 module. dmesg says that eth1 doesn't find any ipv6 router, so i suppose it automatically uses ipv4. How can i prevent the kernel from loading the ipv6 module?

Thank you all!

crashmeister 01-02-2007 02:25 PM

Got no idea about the eth stuff but it might be helpful to know how you upgraded (from source or binary/distro).
You'll need to reinstall the ati driver - how also depends on your distro and how the kernel got installed and pray to your favourite entity since it is ati.

simopal6 01-02-2007 02:28 PM

I downloaded the source (no patch, the entire kernel) and compiled...
I'll try and reinstall the ati driver...

About the other things??

simopal6 01-02-2007 04:44 PM

By the way, fglrx works now!

jstephens84 01-02-2007 05:53 PM

Not sure why that happened but mine did the same also. just try running netconfig and that should setup your ethernet devices so that it will use ipv4 instead of 6.

simopal6 01-03-2007 07:08 AM

I've just found out that the kernel loads the ipv6 module as soon as I start X. If i don't start X, lsmod doesn't list ipv6, and internet works (ping, lynx, everything's ok). When I run startx (as user, not root), and KDE loads, lsmod lists ipv6 too, and dmesg prints:

eth1: no IPv6 routers present

Anyway, this is not the main problem. I would like to understand why my wireless card has changed name from eth0 to eth1!!!

simopal6 01-03-2007 07:09 AM

Oh, i forgot, i ran netconfig, but nothing changed..!

simopal6 01-05-2007 04:47 AM

Can someone help me, please?

crashmeister 01-05-2007 05:01 AM

Sorry - got no idea how slack handles that.Have a look there and if that doesn't help open a new thread about the problem.

simopal6 01-05-2007 05:13 AM

Ok, thank you!

All times are GMT -5. The time now is 09:03 AM.