-   Linux - General (
-   -   Framebuffer in console on Thinkpad X30 (

Diademed 01-24-2006 02:13 AM

Framebuffer in console on Thinkpad X30
I'm having some trouble getting the framebuffer (with or without Tux, I just want 1024x768 res in the console) enabled and working. I've tried compiling both intelfb and vesafb into the kernel, but nothing seems to work. VGA = 791 doesn't seem to have an effect either, iirc. It seemed to work with the basic 2.4 slack install kernel, but with my 2.6.15, it doesn't. It seems like I always have trouble getting the framebuffer working in 2.6.

Anyway, any help would be appreciated... I'm on my desktop right now, but lspci on my lappy shows:

VGA compatible controller: Intel Coporation 82830 CGC [Chipset Graphics Controller]
It has onboard graphics, rather than an ATI card like some versions of this lappy.


nx5000 01-24-2006 04:00 AM

Have you tried with only


All FB_INTEL, FB_I810, FB_I830, FB_I915 should be set to No

Should work...

Diademed 01-24-2006 01:33 PM

Well, I had FB_INTEL set, but none of the others you listed as 'do not'. I suppose I'll recompile and try again. What kernel option do I pass with 2.6? VIDEO= or VGA= ?

nx5000 01-24-2006 01:36 PM

VGA=791 for 65536 colors and 1024x768

Yes if you are comfortable with recompiling, try it but I do not garantee it changes anything, I just give my configuration which is minimal.
Good luck

Diademed 01-24-2006 01:58 PM

Oh... I've recompiled a time or two. ;)

It doesn't seem to have changed anything with the vga=791 tag, still at 800x600 or less, I'm not sure what the actual res is.

hmmm.... I can never seem to get framebuffering to work once I upgrade to 2.6.

Diademed 01-24-2006 05:33 PM

Consider this solved:

I needed to enable "CONSOLE_VIDEO_SELECT" or something like that to my .config.

Sweet. Now Tux lives at the top of my console, and I no longer have to go into X to do everything. 3 cheers for Tux!

All times are GMT -5. The time now is 09:41 AM.