LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 04-24-2018, 12:04 PM   #1
drudox
Member
 
Registered: Feb 2016
Posts: 131

Rep: Reputation: Disabled
fonts doesn't work right in urxvt terminal


Hi everybody ,
I have a problem with fonts in urxvt terminal , for example if i'm try to use zsh with agnoster themes doesn't appear a > at the end but a sort of little rectangle like in the pictures here : https://pasteboard.co/Hi7JWXg.png and also gtop have the same problem https://pasteboard.co/Hi7KQ3z.png I don't know where is the problem . could somebody help me please?
 
Old 04-24-2018, 01:11 PM   #2
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: MID-SOUTH USA
Distribution: Slackware 14.2 current / Linux Mint / Debian / Void Linux
Posts: 8,128

Rep: Reputation: 1676Reputation: 1676Reputation: 1676Reputation: 1676Reputation: 1676Reputation: 1676Reputation: 1676Reputation: 1676Reputation: 1676Reputation: 1676Reputation: 1676
you're going to have to set it up in its Xresources file

https://www.askapache.com/linux/rxvt-xresources/

https://github.com/clvv/dotfiles/blo...er/.Xresources
 
Old 04-24-2018, 01:38 PM   #3
drudox
Member
 
Registered: Feb 2016
Posts: 131

Original Poster
Rep: Reputation: Disabled
this is my .Xresources (related to urxvt) . what does he missing ?

Code:
urxvt*depth:32
urxvt*background: rgba:2000/2000/2000/cccc
URxvt.font:                      xft:Hack:size=11
URxvt.scrollBar_right:           true
URxvt.cursorBlink: 		 true
 
URxvt*.shading: 20
URxvt*foreground:                     white
URxvg*cursorColor:                    white
URxvt*saveLines:                      7777
URxvt*scrollColor:                    #d1d4e0
URxvt*highlightColor:                 #252936
URxvt*highlightTextColor:             #C0C5CE

URxvt*fading:         				  30
URxvt.perl-lib: /usr/lib64/urxvt/perl/
URxvt.perl-ext: default,url-select
URxvt.keysym.M-u: perl:url-select:select_next
URxvt.url-select.launcher: /usr/bin/xdg-open
URxvt.url-select.underline: true
URxvt.perl-ext-common: ...,resize-font,fullscreen,...
URxvt.keysym.F11: perl:fullscreen:switch
URxvt.resize-font.smaller: C-Down
URxvt.resize-font.bigger:  C-Up
URxvt.letterSpace: -1.5
!



URxvt*color0:                         #101218
URxvt*color1:                         #ee829f
URxvt*color2:                         #a5ffe1
URxvt*color3:                         #ffefcc
URxvt*color4:                         #97bbf7
URxvt*color5:                         #c0b7f9
URxvt*color6:                         #97e0ff
URxvt*color7:                         #d1d4e0
URxvt*color8:                         #7780a1
URxvt*color9:                         #ee829f
URxvt*color10:                        #a5ffe1
URxvt*color11:                        #ffefcc
URxvt*color12:                        #97bbf7
URxvt*color13:                        #c0b7f9
URxvt*color14:                        #97e0ff
URxvt*color15:                        #ffffff
URxvt*color16:                        #f99170
URxvt*color17:                        #fcc09e
URxvt*color18:                        #1f222d
URxvt*color19:                        #252936
URxvt*color20:                        #C0C5CE
URxvt*color21:                        #C9CCDB
 
Old 04-24-2018, 01:48 PM   #4
drudox
Member
 
Registered: Feb 2016
Posts: 131

Original Poster
Rep: Reputation: Disabled
I've try the 2 .Xresources that you posted and the problem persist.
 
Old 04-24-2018, 02:14 PM   #5
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: MID-SOUTH USA
Distribution: Slackware 14.2 current / Linux Mint / Debian / Void Linux
Posts: 8,128

Rep: Reputation: 1676Reputation: 1676Reputation: 1676Reputation: 1676Reputation: 1676Reputation: 1676Reputation: 1676Reputation: 1676Reputation: 1676Reputation: 1676Reputation: 1676
maybe check to make sure your fonts you're trying to use is actually installed, and check your Locale, what else screws up fonts? Because all of them little rectangles are fonts not being recognized. So it is in something to do with your fonts, you're going to have to fiddle with your XResources file until you find the fonts that work.
 
Old 04-24-2018, 04:56 PM   #6
dugan
LQ Guru
 
Registered: Nov 2003
Location: Canada
Distribution: Slackware
Posts: 8,727

Rep: Reputation: 3732Reputation: 3732Reputation: 3732Reputation: 3732Reputation: 3732Reputation: 3732Reputation: 3732Reputation: 3732Reputation: 3732Reputation: 3732Reputation: 3732
I'm totally confused as to what BW-userx thinks needs to be done with Xresources. If he could give more specific advice on how to change it than than "fiddle with it", that would probably be helpful.

In the meantime, though, I'd just install a Nerd Font and set urxvt to use it. To do that you'd probably change the following (after installing the font):

Code:
URxvt.font: xft:Hack:size=11
to something like:

Code:
URxvt.font: xft:Hack Nerd Font Mono:size=11
That should work.
 
Old 04-24-2018, 04:59 PM   #7
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: MID-SOUTH USA
Distribution: Slackware 14.2 current / Linux Mint / Debian / Void Linux
Posts: 8,128

Rep: Reputation: 1676Reputation: 1676Reputation: 1676Reputation: 1676Reputation: 1676Reputation: 1676Reputation: 1676Reputation: 1676Reputation: 1676Reputation: 1676Reputation: 1676
Quote:
Originally Posted by dugan View Post
I'm totally confused as to what BW-userx thinks needs to be done with Xresources. If he could give more specific advice on how to change it than than "fiddle with it", that would probably be helpful.

In the meantime, though, I'd just install a Nerd Font and set urxvt to use it. To do that you'd probably change the following (after installing the font):

Code:
URxvt.font: xft:Hack:size=11
to something like:

Code:
URxvt.font: xft:Hack Nerd Font Mono:size=11
That should work.
fiddle: fiddle with it, keep changing the settings until it works.

Try different fonts and thier size settings until one works. Have you not ever fiddled with something until you get it to work before? though it is American slang. so sorry if you're not understating US slang.

A Brief History of Fiddling and Diddling


to 'fiddle'

Last edited by BW-userx; 04-24-2018 at 05:04 PM.
 
Old 04-24-2018, 05:04 PM   #8
dugan
LQ Guru
 
Registered: Nov 2003
Location: Canada
Distribution: Slackware
Posts: 8,727

Rep: Reputation: 3732Reputation: 3732Reputation: 3732Reputation: 3732Reputation: 3732Reputation: 3732Reputation: 3732Reputation: 3732Reputation: 3732Reputation: 3732Reputation: 3732
I know what "fiddle" means. My point was that if your advice is "change things randomly", then you shouldn't be giving advice.
 
Old 04-24-2018, 05:16 PM   #9
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: MID-SOUTH USA
Distribution: Slackware 14.2 current / Linux Mint / Debian / Void Linux
Posts: 8,128

Rep: Reputation: 1676Reputation: 1676Reputation: 1676Reputation: 1676Reputation: 1676Reputation: 1676Reputation: 1676Reputation: 1676Reputation: 1676Reputation: 1676Reputation: 1676
Quote:
Originally Posted by dugan View Post
I know what "fiddle" means. My point was that if your advice is "change things randomly", then you shouldn't be giving advice.
this actually clarifies it rather specifically as to what to be fiddling with.
Quote:
Originally Posted by userxbw
So it is in something to do with your fonts, you're going to have to fiddle with your XResources file until you find the fonts that work.
 
1 members found this post helpful.
Old 04-25-2018, 02:01 AM   #10
drudox
Member
 
Registered: Feb 2016
Posts: 131

Original Poster
Rep: Reputation: Disabled
I don't think it's a problem of fonts used .. I used the same fonts in mate-terminal and the "retangle" disappear, and the right symbols are used.

what do you think about ?
 
Old 04-25-2018, 10:13 AM   #11
dugan
LQ Guru
 
Registered: Nov 2003
Location: Canada
Distribution: Slackware
Posts: 8,727

Rep: Reputation: 3732Reputation: 3732Reputation: 3732Reputation: 3732Reputation: 3732Reputation: 3732Reputation: 3732Reputation: 3732Reputation: 3732Reputation: 3732Reputation: 3732
Quote:
Originally Posted by drudox View Post
I don't think it's a problem of fonts used .. I used the same fonts in mate-terminal and the "retangle" disappear, and the right symbols are used.

what do you think about ?
I think you should have mentioned that earlier.
 
Old 04-25-2018, 10:44 AM   #12
Myk267
Member
 
Registered: Apr 2012
Location: California
Posts: 417
Blog Entries: 15

Rep: Reputation: Disabled
Quote:
Originally Posted by drudox View Post
I don't think it's a problem of fonts used .. I used the same fonts in mate-terminal and the "retangle" disappear, and the right symbols are used.

what do you think about ?
I tried your config with a powerline patched Hack font in urxvt and it works correctly.

If the font works for you in another terminal, that at least means that it's loaded into your fc-cache, which you could verify with fc-list.

Did you remember to run `xrdb -merge ~/.Xresources` ?

Make sure $LANG ends in UTF-8
Code:
echo $LANG
Make sure you're starting a new urxvt to test out and not just another client connected to the same urxvtd.

Good luck!
 
1 members found this post helpful.
Old 04-25-2018, 11:37 AM   #13
dugan
LQ Guru
 
Registered: Nov 2003
Location: Canada
Distribution: Slackware
Posts: 8,727

Rep: Reputation: 3732Reputation: 3732Reputation: 3732Reputation: 3732Reputation: 3732Reputation: 3732Reputation: 3732Reputation: 3732Reputation: 3732Reputation: 3732Reputation: 3732
TBH, urxvt isn't my favorite terminal. Its font support has always been particularly bad (notice how its kerning is different from other terminals). May I suggest trying something else?

https://github.com/kovidgoyal/kitty

Last edited by dugan; 04-25-2018 at 11:41 AM.
 
Old 04-29-2018, 10:40 AM   #14
drudox
Member
 
Registered: Feb 2016
Posts: 131

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Myk267 View Post
I tried your config with a powerline patched Hack font in urxvt and it works correctly.

If the font works for you in another terminal, that at least means that it's loaded into your fc-cache, which you could verify with fc-list.

Did you remember to run `xrdb -merge ~/.Xresources` ?

Make sure $LANG ends in UTF-8
Code:
echo $LANG
Make sure you're starting a new urxvt to test out and not just another client connected to the same urxvtd.

Good luck!
yes i've run
Code:
xrdb -merge ~/.Xresources
but still I have a problem .. another thing if I use ubuntu mono fonts the rectangular wrong fonts disappear
but not on the start up oh i3 ... I mean that in my i3/config I have put :
Code:
exec urxvt -e 'gtop'
in this first istance also with the ubuntu mono characters the fonts appears rectangular.

Last edited by drudox; 04-29-2018 at 10:41 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] URxvt, ctrl+shift+n to open a new terminal? coralfang Linux - Software 2 05-08-2017 12:32 PM
Is it possible to embed _one_ urxvt terminal but have the rest normal? cravengemetzel Linux - Software 1 12-31-2012 10:11 PM
[SOLVED] -cd command of urxvt doesn't work cyker Linux - Newbie 1 08-14-2010 01:31 PM
Terminal doesn't work properly jaguarm Linux - Software 7 06-05-2010 04:33 PM
urxvt/xterm - diffrence in displaing fonts vermaden Linux - Software 1 11-13-2006 07:04 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 09:27 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration