-   Linux - General (
-   -   Flash player will not work in firefox - attempting to view youtube videos. (

mcmorj 01-19-2013 04:48 PM

Flash player will not work in firefox - attempting to view youtube videos.

I wish to look at youtube videos - using the latest firefox browser, running on Suse 12. When I enable the plugin, I get a blank screen where the video is supposed to be. When I disable, I get a little box saying I need to enable Flash to view the video.

Either way, I am unable to view any youtube video using firefox. I also get the same result using the standard KDE/ Gnome Bundled browser.

I have also tried running as SU and the same result.

I also had a look on the YAST repository and downloaded something named "Gnash" as a RPM. I think I managed to install that but it made no difference, other than presenting another plugin in the firefox browser.

I am afraid I am no Linux Guru and struggling to understand how something as "basic" as this seems to be eluding me.... any help appreciated. I have had a search for other similar threads on Linuxquestions but did not turn up anything.


frankbell 01-19-2013 05:58 PM

What are the contents of your /usr/lib/mozilla/plugins directory? Firefox normally looks for plugins in that location.

You can try this:
  1. Download the tar.gz version of Flashplayer for Linux.
  2. Decompress the file.
  3. As root, copy to /usr/lib/mozilla/plugins.
  4. Restart the browser.

That has always worked for me.

If it doesn't work for you, try starting Firefox from the command line, viewing a video, then looking in the terminal to capture any relevant error messages. In fact, you might try that right now, before you do anything; the error messages might tell you something useful (and they might not, but it's worth a try).

mcmorj 01-26-2013 04:33 PM

Thanks Frank,

I have investigated a little more and something loads in firefox, and mt old 2.2 ghz single core AMD goes to 100% and stays there until I close the browser or move away from the page with the video I am trying to play.

Does this suggest what the problem might be....?!

codergeek 01-26-2013 05:31 PM

Is flash installed or is firefox using flash? To check, open the firefox browser and type this in the URL bar and press enter.


This will list all firefox plugins. If it is not installed, then open your package manager and install flash from there and repeat the above step.

BTW, adobe is stopping flash support in linux, but 11.2x versions is still available.

mcmorj 01-29-2013 04:14 AM

Thanks, I will check the plugin status.

If Flash is to be discontinued in Linux, are there other similar alternatives that I should be looking into?!

brianL 01-29-2013 04:43 AM

There's Gnash and Lightspark - but neither of them are up to the standard of Flash, yet.

codergeek 01-29-2013 12:10 PM


Originally Posted by mcmorj (Post 4879709)
Thanks, I will check the plugin status.

If Flash is to be discontinued in Linux, are there other similar alternatives that I should be looking into?!

brianL has listed the alternatives to flash but they're still buggy. You can try this trick in linux to view youtube videos. You will need two programs mplayer and youtube-dl.

To view youtube videos, type this

mplayer $(youtube-dl -f18 -g
To download the video, type this

youtube-dl -f18 -o "%(title)s.mp4"
Just replace the youtube links above with yours. Anyway, this is just a temporary solution until you get flash working properly in your system.

Drakevr 01-29-2013 12:12 PM

Youtube has an html5 trial which serves you html5 videos with fallback to flash when unavailable.
You could give said trial a try and see whether it solves most of your problems (if you have a firefox >14 you should be fine).

mcmorj 02-11-2013 02:45 PM

Thanks Guys for your suggestions - most of which are way above my noob head.

I do have the latest firefox installed (version 18).
I could not for the life of me figure out the mplayer thing - as far as I can tell I do not have it installed.
I tried the "sudo" commands to install the downloader and not sure if that worked or not either.

I tried the suggested line commands and I just get "google failed to find what you were searching for" - suggesting that the mplayer command and the other one are not recognised in the URL field.

I also checked the plugins and the latest version of flash is there. There was another one which appeared to be "gnash" and I disabled it. This made no difference either.

I tried a bbc iplayer page as well and this did not work - but not sure if BBC bothers to support linux based stuff.

I have also noticed that when I click on a video on youtube, my CPU goes up to and stays at 100% until I close the tab.

Apart from this, I remain totally lost!

Could it be that the flash bit is fine and it's my video / driver that is letting me down? I have a dual boot and my other WinXP partition loads and plays full screen youtube videos no bother at all.

DavidMcCann 02-12-2013 11:39 AM

You say your processor is AMD. Is it 64- or 32-bit? If you have a 32-bit AMD, the answer is here

mcmorj 02-12-2013 12:47 PM

a Flash at the end of the tunnel
Hi David,

This looks promising - I run my linux installation on a socket A Barton core AMD CPU which is indeed 32bit as you suggest.

I will set about applying version 10 rather than 11 of Flash and report back on the findings...

Many thanks

mcmorj 02-12-2013 06:09 PM

My CPU is 32bit as you suggested, I have managed to download from the link in your other post the Flash10 player and will have a go at following the rest of your instructions on installing.

I had a look in YAST2 and I could only find Flash11 as an install option.

Many thanks

mcmorj@Athlonux:~> cat /proc/cpuinfo
processor : 0
vendor_id : AuthenticAMD
cpu family : 6
model : 10
model name : AMD Athlon(tm) XP 2800+
stepping : 0
cpu MHz : 2187.691
cache size : 512 KB
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 1
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 mmx fxsr sse syscall mmxext 3dnowext 3dnow up
bogomips : 4375.38
clflush size : 32
cache_alignment : 32
address sizes : 34 bits physical, 32 bits virtual
power management: ts

AlanSecker 02-13-2013 05:44 AM

This might help

rabirk 02-14-2013 12:08 PM

You might also try installing Chromium on your system. It comes with built-in flash or something else that will play your YouTube videos. It's probably easily installed from your distro's repository.

mcmorj 02-15-2013 12:04 PM

Thanks everyone for your suggestions but..
... whilst mincing about trying to install flash plugin 10 I managed to uninstall KDE. Or at least that's what I think I did. I just got an old looking grey xwindows terminal where KDE used to be.

Amazingly enough, when I found a tiny menu bottom left, firefox was there and it would play youtube videos. However, I decided to reinstall Linux taking the opportunity to got from SUSE 12.1 to 12.2.

It seems I am now back to square one with firefox not showing the video but CPU usage running at 100%.

I will have another go and removing the flash player 11 plugin and install version 10 as previously suggested.

I also installed Chromium before I trashed KDE but that did not work either. Chromium seems to want to employ flashplayer too.

Another thing I did was install "gnash" and although Firefox said the plugin was there, the video would run with errors appearing in the video screen, but no video.

All times are GMT -5. The time now is 12:11 AM.