-   Linux - General (
-   -   fixing grub after install to usb drive (

glvorange 02-01-2013 03:55 PM

fixing grub after install to usb drive
I just installed clearos (centos) on my usb stuck but after rebooting grub drops to the rescue prompt. How can I fix grub? I'm running fedora 17 on my laptop so I can run any commands there. I tried the "install-grub2 /dev/sdb1" but that doesn't seem to work.

John VV 02-01-2013 05:50 PM

i take it you did not heed all the warnings about installing to a usb
make 100% sure that the os installing on the usb puts the bootloader ON the usb

reinstall fedoras grub to the drive


"install-grub2 /dev/sdb1" but that doesn't seem to work.
is sdb1 your fedora boot partition ? ( first partition on the second drive )
if so what is on sda1 ?


is sdb your usb ?

glvorange 02-02-2013 01:15 AM

Well it was the only drive connected to the motherboard, the install was from DVD.
Doing "fdisk -l" lists my usb stick (on the fedora laptop) as sdb with tbe primary boot partition; with the *; as sbd1. There's an error trying to copy grub to sdb1 but it can be copied to sdb although grub still doesn't work when swapping sdb1 for sdb.

The usb drive has clearos on it.

John VV 02-02-2013 08:53 PM

you are fallowing the guide on the CentOS wiki ?

glvorange 02-03-2013 02:36 AM

It seems like I have the same problem as this person here:
Haven't had a chance to try it yet.

glvorange 02-03-2013 02:26 PM

I managed to fix it by pre-formatting the drive with gparted and making sure to align to sector instead of MiB. With the sector set to 63, everything works perfectly

All times are GMT -5. The time now is 03:46 PM.