LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 05-24-2005, 01:04 PM   #1
darktalon96
LQ Newbie
 
Registered: Dec 2003
Posts: 19

Rep: Reputation: 0
Firefox download preferences, nobody knows the answer


Ive already asked this question on numerous forums, and nobody knows the answer. I either don't get responses, or the responses I get are completely irrelevant to the actual problem. I've searched and searched, I've found posts by other people in other forums with the same problems, no one knows the answer.

Here's the issue:

Firefox wants to play WMV files in Totem. I don't. I want to play everything in MPlayer. So, when I click a link to a WMV file, I choose MPlayer from /usr/bin, and then tell Firefox to "Do this automatically for files like this from now on". But it doesn't, nope. It always wants to use Totem, and it always asks, so every single time I click a WMV link, I have to do this.

I don't know how to change the default program for an application in Gnome.. I'm too unfamiliar with it and Linux in general. However, I do know how to change this in KDE, and I tried it. Well, no matter what the default app is for WMV files, it still wants me to use totem, and it still gives me the same problem. Mind you this does not happen with ANY OTHER file types, everything else saves the application I want to use.

P.S. How do you turn repeat on in MPlayer?
P.P.S When I open a WMV from a folder with mplayer, it gives me an error saying that the file is wmv, but the contents are asf. I have to use open>with to open it properly.
 
Old 05-24-2005, 01:30 PM   #2
DavidPhillips
LQ Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,163

Rep: Reputation: 58
In Edit / Preferences / Downloads select the option to "Show Download Manager..."

You can change this back later, this will produce a dialog.

Find a page with a wmv link in it..

http://home.att.net/~cherokee68/wmvtest.html


Select "Open with ..." in the dialog dropdown browse to mplayer and select to "Do this automatically from now on..."


Your settings should be seen in the download tab in "File Types" if you do not get a prompt then see if there is a file type setting already there.

Last edited by DavidPhillips; 05-24-2005 at 01:46 PM.
 
Old 05-24-2005, 06:09 PM   #3
craigevil
Senior Member
 
Registered: Apr 2005
Location: OZ
Distribution: Debian/Raspberry Pi OS
Posts: 4,757
Blog Entries: 14

Rep: Reputation: 487Reputation: 487Reputation: 487Reputation: 487Reputation: 487
Edit>Preferences>Downloads>Plugins uncheck the file type>OK
The next time you click on a file Firefox will ask what you want to do with that file>check open with and choose mplayer then check the box that says remember this choice or something along those lines.
 
Old 05-24-2005, 06:21 PM   #4
SciYro
Senior Member
 
Registered: Oct 2003
Location: hopefully not here
Distribution: Gentoo
Posts: 2,038

Rep: Reputation: 51
Quote:
P.P.S When I open a WMV from a folder with mplayer, it gives me an error saying that the file is wmv, but the contents are asf. I have to use open>with to open it properly.
this is a nautilus problem, it checks the file type, and extension, if they match, it runs the file based on extension, if they don't match it errors out (i guess its trying hard to be like windows, if it can detect file types, it shouldn't check its extension, it already knows what file type it is)

but, WMV is based on ASF, so nautilus is even more broke there. anyways, during my time using gnome, i never found a way to make nautilus behave, i just switched to a different, faster file manager.
 
Old 06-21-2005, 01:03 PM   #5
chemist109
LQ Newbie
 
Registered: Nov 2002
Location: Mississippi Gulf Coast, USA
Distribution: Fedora Core 2, Debian unstable, Kubuntu, Mepis
Posts: 15

Rep: Reputation: 0
Helper application

Did anyone read the parent post? He's tried the first two suggestions already. It also appears that he's using KDE as his DE, so the Nautilus thing shouldn't make a difference.

I have this same problem. I use KDE and Firefox and it ALWAYS asks these questions when I download files. I think there must be a preferences file somewhere that is owned by root and therefore can't be changed.
 
Old 06-21-2005, 01:56 PM   #6
craigevil
Senior Member
 
Registered: Apr 2005
Location: OZ
Distribution: Debian/Raspberry Pi OS
Posts: 4,757
Blog Entries: 14

Rep: Reputation: 487Reputation: 487Reputation: 487Reputation: 487Reputation: 487
In KDE open Konqueror and click on File Associations, change the audio/video to the player you want to use for each file type.

Or in the K control panel under:
File Associations
This is where you configure everything to do with file associations. Here you can select a filetype, and choose what applications you would like to be able to open it with. You can also select which icon you would like to represent each filetype, and whether to show it in an embedded or a separate viewer.
http://docs.kde.org/development/en/k...omponents.html

In Gnome open Preferred Applications. And do the same as above.
Configuring File Types and Programs
http://k12linux.mesd.k12.or.us/docs/gnome/ch11s05.html


If there is more than one app listed move the one you want to the top of the list.

Also if you have plugins make sure they do not conflict. Mplayer-plugin and Kaffeine plugin do not play nice. Mozplugger can also conflict with mplayer-plugin or the Kaffeine plugin.

Depending on the media plugins you have you can edit the appropriate file so the player you want opens.
 
Old 06-21-2005, 01:59 PM   #7
Komakino
Senior Member
 
Registered: Feb 2004
Location: Somerset, England
Distribution: Slackware 10.2, Slackware 10.0, Ubuntu 9.10
Posts: 1,938

Rep: Reputation: 55
I believe it's -loop 0 to loop indefinitely in mplayer. You can probably put that in a .mplayerrc file or somthing.
 
Old 06-28-2005, 11:24 PM   #8
cclo
LQ Newbie
 
Registered: Jun 2005
Posts: 1

Rep: Reputation: 0
Quote:
Originally posted by craigevil

In Gnome open Preferred Applications. And do the same as above.
Configuring File Types and Programs
http://k12linux.mesd.k12.or.us/docs/gnome/ch11s05.html
This is not gonna work because there's no such configuration option in gnome, at last
in my fc4.

I had exactly the same problem as described in the first post. In fact, if
a website treats wmv files as a video stream, my firefox can handle it correctly by
calling mplayer (I have mplayerplug-in installed). However, if a website treats
wmv files as files and asks my broswer to download them, my firefox either asks
me to save them or to play them with totem, which is gnome's default player for wmv.

So, the goal is to change the default wmv player to mplayer in gnome and I found
the solution here:

http://forums.fedoraforum.org/archiv...p/t-26875.html

Quote:
Since GNOME 2.8, MIME types are stored in the new FreeDesktop shared-mime-info database. However, gnome-control-center has not been updated to allow one to easily add MIME types to this database. Therefore, if applications such as Nautilus complain that there is no MIME type associated with a particular file, using the Associate Application interface will not work.
I followed the article memtioned above to edit defaults.list and mimeinfo.cache
under /usr/share/applications/, and the problem solved!

Last edited by cclo; 06-28-2005 at 11:26 PM.
 
Old 07-20-2005, 04:41 AM   #9
ArchArael
Member
 
Registered: Mar 2005
Location: Earth
Distribution: Fedora Workstation 33
Posts: 104

Rep: Reputation: 54
Did you also tried to check the keys in firefox....type about:config in your url bar and write player in the textfield filter.

you should see all keys that have in pattern player...

Check the path of foxytunes.player_class key....if the path leads to totem then change it...

Hope this helps..
 
Old 07-20-2005, 03:07 PM   #10
geeman2.0
Member
 
Registered: Feb 2005
Location: Ontario, Canada
Distribution: Gentoo, Slackware
Posts: 345

Rep: Reputation: 30
Personally I'd try changing the default firefox movie player to mplayer while running the program as root and see if that fixes it.

I've had problems with firefox not actually changing settings due to permissions without it printing out error messages. (e.g. try adding a search engine to your quick search bar while not running as root. It won't work, but doesn't print an error or anything)
 
Old 10-14-2006, 07:13 PM   #11
PatrickNew
Senior Member
 
Registered: Jan 2006
Location: Charleston, SC, USA
Distribution: Debian, Gentoo, Ubuntu, RHEL
Posts: 1,148
Blog Entries: 1

Rep: Reputation: 48
huh?

Okay, so change the default movie player in Firefox while root. I can su to root in a console and start firefox, but how do I change its default movie player?
 
Old 10-15-2006, 12:06 AM   #12
farslayer
LQ Guru
 
Registered: Oct 2005
Location: Northeast Ohio
Distribution: linuxdebian
Posts: 7,248
Blog Entries: 5

Rep: Reputation: 191Reputation: 191
And what's wrong with just editing Firefox preferences through the menu..

Edit -> Preferences -> Downloads -> Download Actions

My setting is as follows.

WMV - Windows Media Interleave - Open with VLC Multimedia Player..


Works Like a charm here, and I didn't have to jump through any of those hoops you are all describing.

And this can be set by File type, so you COULD choose different players for different video types..

Last edited by farslayer; 10-15-2006 at 12:07 AM.
 
Old 10-15-2006, 12:58 PM   #13
PatrickNew
Senior Member
 
Registered: Jan 2006
Location: Charleston, SC, USA
Distribution: Debian, Gentoo, Ubuntu, RHEL
Posts: 1,148
Blog Entries: 1

Rep: Reputation: 48
See, my problem isn't with downloading the file. There's two ways firefox gets files - downloading and direct access. For example, if there is a link on a webpage to a mwv, I have no problem. However, if there is a page with a wmv embedded in it - I'm screwed.
 
Old 10-15-2006, 11:20 PM   #14
farslayer
LQ Guru
 
Registered: Oct 2005
Location: Northeast Ohio
Distribution: linuxdebian
Posts: 7,248
Blog Entries: 5

Rep: Reputation: 191Reputation: 191
Do you use VLC ? VLC has a mozilla plugin, and it works fine for me for most embedded videos.. Only time one won't play is if I dont have the codec for it..

so many darn codecs.. Grrrr

vlc - multimedia player and streamer
mozilla-plugin-vlc - multimedia plugin for web browsers based on VLC

No clue if MPlayer has a similar plugin or not.. I rarely use MPlayer.

http://www.videolan.org/
http://developers.videolan.org/vlc/m...n-compile.html
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Firefox Plugin Preferences james gibson Linux - Software 2 10-07-2005 09:56 PM
Firefox will not download webpages curtis_sampson Linux - Software 6 08-29-2005 11:34 PM
FireFox Wont Download scarabs Linux - Software 1 05-06-2005 12:10 AM
Firefox Preferences gbrewste Linux - Software 5 08-10-2004 05:27 AM
How to fire up Firefox after download coopns Linux - Newbie 14 03-03-2004 12:29 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 09:37 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration