-   Linux - General (
-   -   Files removed from file system during Fedora Core Upgrade (

gryphonavocatio 09-20-2005 12:18 AM

Files removed from file system during Fedora Core Upgrade
Hello. I'm new here. Unfortunately, I come to you with a problem.

I am a Fedora Core user. I just upgraded from Fedora Core 3 to 4 today. Upon rebooting, I discovered that the directory wherein I stored all of my media files had mysteriously vanished (almost 50GB!!).

I'm guessing that this is because I put the directory in the /misc folder, and now that seems stupid, but I did it a long time ago and never bothered to change it. Is this the reason?

But it doesn't seem that the files were deleted, just removed from teh file system. I scanned /dev/mapper/VolGroup00-LogVol00 (the logical volume my root file system is on) with Filelight, and it says that the volume is using 53 GB of it's 168 GB, but that the root file system is only using 6.1 gb.

53 - 6 = 47, the amount of missing data.

I know, this one is bizarre. Any help would be truly appreciated. At the very least, I would like to be able to get back the disk space the missing files are taking up, but I would like the files if at all possible.

saneax 09-20-2005 06:39 AM

Best way to find what has happened is
1) Check what Partitions you have..
#> cat /etc/fstab
and mark all those starting with /dev/mapper/Vol...
2) run mount command to see if they all are mounted
3) If not manually mount them
mount -t ...
4) issue a find for your media files... (assuming .mp3 files)
#>find / -name *.mp3 -print

Check if you can locate any of the missing files ? If Yes then mark the folder and that your folder...

Otherwise you might have just deleted in autopartitioning (maybe!)


archtoad6 09-20-2005 02:14 PM

Good luck & please let us know what happened, I can see this happening to others.

gryphonavocatio 09-20-2005 03:34 PM

I checked out my fstab and compared it to mount:


# cat /etc/fstab
# This file is edited by fstab-sync - see 'man fstab-sync' for details
/dev/VolGroup00/LogVol00 /                      ext3    defaults        1 1
LABEL=/boot            /boot                  ext3    defaults        1 2
none                    /dev/pts                devpts  gid=5,mode=620  0 0
none                    /dev/shm                tmpfs  defaults        0 0
none                    /proc                  proc    defaults        0 0
none                    /sys                    sysfs  defaults        0 0
/dev/VolGroup00/LogVol01 swap                    swap    defaults        0 0
/dev/hda1              /mnt/hda1                auto    defaults        0 0
/dev/fd0                /media/floppy          auto    pamconsole,exec,noauto,managed 0 0
/dev/hdc                /media/cdrom            auto    pamconsole,exec,noauto,managed 0 0

# mount
/dev/mapper/VolGroup00-LogVol00 on / type ext3 (rw)
none on /proc type proc (rw)
none on /sys type sysfs (rw)
none on /dev/pts type devpts (rw,gid=5,mode=620)
/dev/hda2 on /boot type ext3 (rw)
none on /dev/shm type tmpfs (rw)
/dev/hda1 on /mnt/hda1 type vfat (rw)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
sunrpc on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw)
automount(pid2080) on /misc type autofs (rw,fd=4,pgrp=2080,minproto=2,maxproto=4)
automount(pid2133) on /net type autofs (rw,fd=4,pgrp=2133,minproto=2,maxproto=4)

I noticed that /dev/hdb1 did not seem to be mounted according to this, so I tried to mount it, but with no luck:


# mount -t ext3 /dev/hdb1 /
mount: /dev/hdb1 already mounted or / busy
mount: according to mtab, /dev/mapper/VolGroup00-LogVol00 is already mounted on /

I have also tried searching the file system for lost file names, and I have looked for folders of similar in size to the one that disappeared. No luck.

gryphonavocatio 09-20-2005 08:45 PM

I've decided that since I have most of the missing files backed up on a couple of other computers, I'm just going to scrap this. SInce it's a new computer anyway, I'm not standing to lose much. I'm just going to back up ~ and reinstall, this time with a better partition setup.

All I can really say about this is that it pays to have files backed up, and be mindful of where you put things on your system.

By the way, does anybody know what the /misc directory is for?

Thanks for the help, though.

archtoad6 09-21-2005 01:27 PM

There is no mention of '/misc' in the current (2.3) ver. of the FHS (Filesystem Hierarchy Standard), or its predecessor Linux Filesystem Structure -- Release 1.2. I have just checked 4 distros: SimplyMEPIS 3.3, SmoothWall Express, FC3, & FC4. Only the FC's have a '/misc'. My memory says that RH 8.0 & 7.3 also had this directory, maybe it's a RedHat-ism.

At one time I thought that it is for miscellaneous packages (if I were correct, it would seem to have been replaced by '/opt'). However, at least one piece of RH documentation seems to indicate that it's for NFS sharing.

All times are GMT -5. The time now is 08:01 PM.