-   Linux - General (
-   -   Fedora 18 mate and compiz fusion (

Nemesissparadise 04-15-2013 06:23 PM

Fedora 18 mate and compiz fusion
2 Attachment(s)
I nstalled Fedora 18 (Fresh install) then added the mate desktop... all good then i added compiz fusion which brings me to my 2 questions.

1) How can i make compiz start automatically at log in? I remember googling this before and solving it before in previous releases but cant find anything now.
2) When i start compiz in the terminal i get this output

[root@localhost Nemesis]# compiz-mate-emerald
compiz (video) - Warn: No 8 bit GLX pixmap format, disabling YV12 image format

now compiz starts... i know because I get the effects... cube, wobbly windows, etc but i dont know how to describe it easily so here is a screen shot of before enabling and after.. is it just a setting that needs to be changed?

RockDoctor 04-16-2013 04:34 PM

You can autostart just about anything by placing its desktop file in ~/.config/autostart. If you need an example. I offer:

~/.config/autostart$ cat compton.desktop
[Desktop Entry]
Exec=compton --config /home/a/.config/compton/compton.conf
Comment=Another compositing manager for X

Nemesissparadise 04-16-2013 06:08 PM

ok ill be honest this is an aspect of linux i have very little experience.. i found no such file in that location can I create one with that as the text?

Nemesissparadise 04-16-2013 06:19 PM

this may be solved by having compiz auto start idk yet but in the terminal if i do this compiz starts and my border issue does not surface

[root@localhost Nemesis]# compiz --replace ccp & emerald --replace &
[1] 2665
[2] 2666
[root@localhost Nemesis]# compiz (core) - Warn: SmcOpenConnection failed: None of the authentication protocols specified are supported
compiz (video) - Warn: No 8 bit GLX pixmap format, disabling YV12 image format

RockDoctor 04-19-2013 08:19 AM

You can just create the file and the directory if they doesn't exist

Nemesissparadise 04-19-2013 04:18 PM

ok thank you

Nemesissparadise 04-19-2013 04:57 PM

ok i am sorry but can you give a bit more detail... i tried to follow the above method and no fix

All times are GMT -5. The time now is 07:29 AM.