LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
LinkBack Search this Thread
Old 08-21-2010, 02:53 PM   #1
fedora.linux.64
Member
 
Registered: Sep 2009
Posts: 34

Rep: Reputation: 15
Fedora 13 nVidia dual displays help needed


Hello All,
I am using Fedora 13 x86_64 on a Acer Aspire 7730ZG laptop with:
01:00.0 VGA compatible controller: nVidia Corporation G98 [GeForce 9300M GS] (rev a1)
I have kmod-nvidia-2.6.33.6-147.2.4.fc13.x86_64-195.36.31-1.fc13.2.x86_64 installed from rpmfuison
when I plug in the hdmi cable to the tv, my tv says the resoultion is at 720p,
and I can not get any of the resolutions settings to look right on seperate x screen with the nvidia X server settings gui.
my tv is a vizo 42inch.
could someone help me set this up
also another question is their a way to set the video card to output at 1080? this might be part of my problem?
thanks
 
Old 08-21-2010, 07:37 PM   #2
TheMadIndian
Member
 
Registered: Dec 2007
Distribution: Fedora Slackware CentOS slax RHEL
Posts: 114

Rep: Reputation: 23
Quote:
Originally Posted by fedora.linux.64 View Post
Hello All,
I am using Fedora 13 x86_64 on a Acer Aspire 7730ZG laptop with:
01:00.0 VGA compatible controller: nVidia Corporation G98 [GeForce 9300M GS] (rev a1)
I have kmod-nvidia-2.6.33.6-147.2.4.fc13.x86_64-195.36.31-1.fc13.2.x86_64 installed from rpmfuison
when I plug in the hdmi cable to the tv, my tv says the resoultion is at 720p,
and I can not get any of the resolutions settings to look right on seperate x screen with the nvidia X server settings gui.
my tv is a vizo 42inch.
could someone help me set this up
also another question is their a way to set the video card to output at 1080? this might be part of my problem?
thanks
You can try using cvt and xrandr and you'll need to adjust your subsection display to something like "Virtual 1920 1080"
 
Old 08-21-2010, 07:39 PM   #3
TheMadIndian
Member
 
Registered: Dec 2007
Distribution: Fedora Slackware CentOS slax RHEL
Posts: 114

Rep: Reputation: 23
Here ya go this should be it

http://groups.google.com/group/Ubunt...55079c50de7911
 
Old 08-22-2010, 01:44 PM   #4
fedora.linux.64
Member
 
Registered: Sep 2009
Posts: 34

Original Poster
Rep: Reputation: 15
reply

TheMadIndian thanks for your help and your reply.

I am trying to follow the steps from the links your provide, but I am stuck at:

Now you need to add the above mode using the following command

$ xrandr --addmode VGA1 1024x768_60.00

here for VGA1 you have to use what ever that was there for $ xrandr output



when i run #xrandr output
it does not say which vga to use it is just the help file i tryed it with xrandr --output also?

xrandr --addmode VGA1 1024x768_60.00
xrandr: cannot find output "VGA1"


thanks
 
Old 08-22-2010, 06:20 PM   #5
TheMadIndian
Member
 
Registered: Dec 2007
Distribution: Fedora Slackware CentOS slax RHEL
Posts: 114

Rep: Reputation: 23
Quote:
Originally Posted by fedora.linux.64 View Post
TheMadIndian thanks for your help and your reply.

I am trying to follow the steps from the links your provide, but I am stuck at:

Now you need to add the above mode using the following command

$ xrandr --addmode VGA1 1024x768_60.00

here for VGA1 you have to use what ever that was there for $ xrandr output



when i run #xrandr output
it does not say which vga to use it is just the help file i tryed it with xrandr --output also?

xrandr --addmode VGA1 1024x768_60.00
xrandr: cannot find output "VGA1"


thanks
if you run xrandr -q it will tell you what displays connected the one that identifies as your TV should be the one you use, there should only be two connected and the laptop should identify as LVDS
 
Old 08-23-2010, 09:14 AM   #6
fedora.linux.64
Member
 
Registered: Sep 2009
Posts: 34

Original Poster
Rep: Reputation: 15
reply

hello when I run the command I am not sure what is going on if this is right?

xrandr -q
Screen 0: minimum 320 x 175, current 1024 x 768, maximum 1024 x 768
default connected 1024x768+0+0 0mm x 0mm
1024x768 50.0* 52.0 53.0 54.0 55.0
800x600 51.0 57.0 58.0 59.0 60.0 61.0 62.0 63.0
832x624 56.0
720x400 64.0
700x525 65.0 66.0
640x512 67.0 68.0 69.0
640x480 70.0 71.0 72.0 73.0 74.0 75.0
640x400 76.0
640x350 77.0
576x432 78.0
512x384 79.0 80.0 81.0 82.0 83.0
416x312 84.0
400x300 85.0 86.0 87.0 88.0 89.0
360x200 90.0
320x240 91.0 92.0 93.0 94.0
320x200 95.0
320x175 96.0
1024x768_60.00 (0x338) 63.5MHz
h: width 1024 start 1072 end 1176 total 1328 skew 0 clock 47.8KHz
v: height 768 start 771 end 775 total 798 clock 59.9Hz


thanks
 
Old 08-23-2010, 09:26 AM   #7
TheMadIndian
Member
 
Registered: Dec 2007
Distribution: Fedora Slackware CentOS slax RHEL
Posts: 114

Rep: Reputation: 23
Quote:
Originally Posted by fedora.linux.64 View Post
hello when I run the command I am not sure what is going on if this is right?

xrandr -q
Screen 0: minimum 320 x 175, current 1024 x 768, maximum 1024 x 768
default connected 1024x768+0+0 0mm x 0mm
1024x768 50.0* 52.0 53.0 54.0 55.0
800x600 51.0 57.0 58.0 59.0 60.0 61.0 62.0 63.0
832x624 56.0
720x400 64.0
700x525 65.0 66.0
640x512 67.0 68.0 69.0
640x480 70.0 71.0 72.0 73.0 74.0 75.0
640x400 76.0
640x350 77.0
576x432 78.0
512x384 79.0 80.0 81.0 82.0 83.0
416x312 84.0
400x300 85.0 86.0 87.0 88.0 89.0
360x200 90.0
320x240 91.0 92.0 93.0 94.0
320x200 95.0
320x175 96.0
1024x768_60.00 (0x338) 63.5MHz
h: width 1024 start 1072 end 1176 total 1328 skew 0 clock 47.8KHz
v: height 768 start 771 end 775 total 798 clock 59.9Hz


thanks
is the hdmi cable plugged in at that point?
 
Old 08-23-2010, 09:54 AM   #8
fedora.linux.64
Member
 
Registered: Sep 2009
Posts: 34

Original Poster
Rep: Reputation: 15
reply

hello
yes I have the vizo tv hdmi plugged in to the laptop.
I think I see part of the problem, I had to open a terminal on the vizo tv screen and run the command:

# xrandr -q
Screen 1: minimum 320 x 175, current 640 x 400, maximum 640 x 400
default connected 640x400+0+0 0mm x 0mm
640x400 50.0*
640x350 51.0
360x200 52.0
320x175 53.0
512x384 54.0 55.0 56.0 57.0 58.0
416x312 59.0
400x300 60.0 61.0 62.0 63.0 64.0
320x240 65.0 66.0 67.0 68.0
320x200 69.0




this is the command from the laptop screen:

xrandr -q
Screen 0: minimum 320 x 175, current 1024 x 768, maximum 1024 x 768
default connected 1024x768+0+0 0mm x 0mm
1024x768 50.0* 52.0 53.0 54.0 55.0
800x600 51.0 57.0 58.0 59.0 60.0 61.0 62.0 63.0
832x624 56.0
720x400 64.0
700x525 65.0 66.0
640x512 67.0 68.0 69.0
640x480 70.0 71.0 72.0 73.0 74.0 75.0
640x400 76.0
640x350 77.0
576x432 78.0
512x384 79.0 80.0 81.0 82.0 83.0
416x312 84.0
400x300 85.0 86.0 87.0 88.0 89.0
360x200 90.0
320x240 91.0 92.0 93.0 94.0
320x200 95.0
320x175 96.0
1024x768_60.00 (0x338) 63.5MHz
h: width 1024 start 1072 end 1176 total 1328 skew 0 clock 47.8KHz
v: height 768 start 771 end 775 total 798 clock 59.9Hz



thanks for your help still not sure what to do though?
 
Old 08-23-2010, 09:59 AM   #9
TheMadIndian
Member
 
Registered: Dec 2007
Distribution: Fedora Slackware CentOS slax RHEL
Posts: 114

Rep: Reputation: 23
Quote:
Originally Posted by fedora.linux.64 View Post
hello
yes I have the vizo tv hdmi plugged in to the laptop.
I think I see part of the problem, I had to open a terminal on the vizo tv screen and run the command:

# xrandr -q
Screen 1: minimum 320 x 175, current 640 x 400, maximum 640 x 400
default connected 640x400+0+0 0mm x 0mm
640x400 50.0*
640x350 51.0
360x200 52.0
320x175 53.0
512x384 54.0 55.0 56.0 57.0 58.0
416x312 59.0
400x300 60.0 61.0 62.0 63.0 64.0
320x240 65.0 66.0 67.0 68.0
320x200 69.0




this is the command from the laptop screen:

xrandr -q
Screen 0: minimum 320 x 175, current 1024 x 768, maximum 1024 x 768
default connected 1024x768+0+0 0mm x 0mm
1024x768 50.0* 52.0 53.0 54.0 55.0
800x600 51.0 57.0 58.0 59.0 60.0 61.0 62.0 63.0
832x624 56.0
720x400 64.0
700x525 65.0 66.0
640x512 67.0 68.0 69.0
640x480 70.0 71.0 72.0 73.0 74.0 75.0
640x400 76.0
640x350 77.0
576x432 78.0
512x384 79.0 80.0 81.0 82.0 83.0
416x312 84.0
400x300 85.0 86.0 87.0 88.0 89.0
360x200 90.0
320x240 91.0 92.0 93.0 94.0
320x200 95.0
320x175 96.0
1024x768_60.00 (0x338) 63.5MHz
h: width 1024 start 1072 end 1176 total 1328 skew 0 clock 47.8KHz
v: height 768 start 771 end 775 total 798 clock 59.9Hz



thanks for your help still not sure what to do though?
do you have an xorg.conf defined? this could be stopping you from seeing all available screens

do you see multiple screens defined in /var/log/Xorg.0.log? Look for "Display Devices"
 
Old 08-23-2010, 10:52 AM   #10
fedora.linux.64
Member
 
Registered: Sep 2009
Posts: 34

Original Poster
Rep: Reputation: 15
reply

I am using xorg.conf that nvidia X server settings made for me.
I will include that and the log file you asked for I searched but didnt find what you asked for

thanks
Attached Files
File Type: txt xorg.conf.txt (3.0 KB, 4 views)
File Type: txt Xorg.0.log.txt (38.2 KB, 5 views)
 
Old 08-23-2010, 01:48 PM   #11
TheMadIndian
Member
 
Registered: Dec 2007
Distribution: Fedora Slackware CentOS slax RHEL
Posts: 114

Rep: Reputation: 23
Quote:
Originally Posted by fedora.linux.64 View Post
I am using xorg.conf that nvidia X server settings made for me.
I will include that and the log file you asked for I searched but didnt find what you asked for

thanks
This is the part I was talking about

Code:
29.643] (--) NVIDIA(0): Connected display device(s) on GeForce 9300M GS at PCI:1:0:0:
[    29.643] (--) NVIDIA(0):     AUO (DFP-0)
[    29.643] (--) NVIDIA(0):     VIZ VW42L HDTV10A (DFP-1)
[    29.643] (--) NVIDIA(0): AUO (DFP-0): 330.0 MHz maximum pixel clock
[    29.643] (--) NVIDIA(0): AUO (DFP-0): Internal Dual Link LVDS
[    29.643] (--) NVIDIA(0): VIZ VW42L HDTV10A (DFP-1): 165.0 MHz maximum pixel clock
[    29.643] (--) NVIDIA(0): VIZ VW42L HDTV10A (DFP-1): Internal Single Link TMDS
Your TV is DFP-1

so thats what replaces VGA1 in the instructions
 
Old 08-23-2010, 03:55 PM   #12
fedora.linux.64
Member
 
Registered: Sep 2009
Posts: 34

Original Poster
Rep: Reputation: 15
reply

hello, I tryed the command but gettin a error:

xrandr --addmode DFP-1 1024x768_60.00
xrandr: cannot find output "DFP-1"


thanks
 
Old 08-23-2010, 04:44 PM   #13
TheMadIndian
Member
 
Registered: Dec 2007
Distribution: Fedora Slackware CentOS slax RHEL
Posts: 114

Rep: Reputation: 23
Quote:
Originally Posted by fedora.linux.64 View Post
hello, I tryed the command but gettin a error:

xrandr --addmode DFP-1 1024x768_60.00
xrandr: cannot find output "DFP-1"


thanks
Ok

Two things

First - have you tried running nvidia-settings as root and manipulating the displays that way but turning off the laptop screen and only using the hdmi screen rather than using twinview?

and second

This can sometimes be because of the xorg.conf file (default connected), we can try renaming it so there is no xorg.conf file and see if that helps in identifying the screens with xrandr (you may have to copy it back in runlevel 1 or 3 if it fails) or based on the Xorg.0.log we can attempt setting it in xorg.conf ignoring edid

so to do that do something like

Code:
mv /etc/X11/xorg.conf /etc/X11/xorg.conf.old
and reboot and then run xrandr -q when its back up see if default connected is gone and the two screens are correctly identified
 
Old 08-23-2010, 11:24 PM   #14
fedora.linux.64
Member
 
Registered: Sep 2009
Posts: 34

Original Poster
Rep: Reputation: 15
reply

hi I have tryed running nvidia-settings from root
I can get the laptop and the tv working, the problem is the resolution on the tv is way to big even at 400x300 the desktop is really really big,
I do know the tv picks up the laptop at 720p and I was thinking this was the resolution problem?

I moved the xorg.conf and rebooted,
I had to run nvidia-settings again to get both screens working
but as you can see below its still not picking them up right?

xrandr -q
Screen 0: minimum 320 x 175, current 1440 x 900, maximum 1440 x 900
default connected 1440x900+0+0 0mm x 0mm
1440x900 50.0*
1024x768 51.0 52.0 53.0 54.0 55.0
832x624 56.0
800x600 57.0 58.0 59.0 60.0 61.0 62.0 63.0 64.0
720x400 65.0
700x525 66.0 67.0
640x512 68.0 69.0 70.0
640x480 71.0 72.0 73.0 74.0 75.0 76.0
640x400 77.0
640x350 78.0
576x432 79.0
512x384 80.0 81.0 82.0 83.0 84.0
416x312 85.0
400x300 86.0 87.0 88.0 89.0 90.0
360x200 91.0
320x240 92.0 93.0 94.0 95.0
320x200 96.0
320x175 97.0
 
Old 08-24-2010, 01:56 PM   #15
TheMadIndian
Member
 
Registered: Dec 2007
Distribution: Fedora Slackware CentOS slax RHEL
Posts: 114

Rep: Reputation: 23
Quote:
Originally Posted by fedora.linux.64 View Post
hi I have tryed running nvidia-settings from root
I can get the laptop and the tv working, the problem is the resolution on the tv is way to big even at 400x300 the desktop is really really big,
I do know the tv picks up the laptop at 720p and I was thinking this was the resolution problem?

I moved the xorg.conf and rebooted,
I had to run nvidia-settings again to get both screens working
but as you can see below its still not picking them up right?

xrandr -q
Screen 0: minimum 320 x 175, current 1440 x 900, maximum 1440 x 900
default connected 1440x900+0+0 0mm x 0mm
1440x900 50.0*
1024x768 51.0 52.0 53.0 54.0 55.0
832x624 56.0
800x600 57.0 58.0 59.0 60.0 61.0 62.0 63.0 64.0
720x400 65.0
700x525 66.0 67.0
640x512 68.0 69.0 70.0
640x480 71.0 72.0 73.0 74.0 75.0 76.0
640x400 77.0
640x350 78.0
576x432 79.0
512x384 80.0 81.0 82.0 83.0 84.0
416x312 85.0
400x300 86.0 87.0 88.0 89.0 90.0
360x200 91.0
320x240 92.0 93.0 94.0 95.0
320x200 96.0
320x175 97.0
One more thing you can try (make sure you back up your config)

Change this

Code:
# Removed Option "metamodes" "DFP-1: nvidia-auto-select +0+0"
    Identifier     "Screen1"
    Device         "Device1"
    Monitor        "Monitor1"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "metamodes" "DFP-1: 640x400 +0+0; DFP-1: 640x350 +0+0; DFP-1: 360x200 +0+0; DFP-1: 320x175 +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
to

Code:
# Removed Option "metamodes" "DFP-1: nvidia-auto-select +0+0"
    Identifier     "Screen1"
    Device         "Device1"
    Monitor        "Monitor1"
    DefaultDepth    24
    Option         "TwinView" "0"
    #Option         "metamodes" "DFP-1: 640x400 +0+0; DFP-1: 640x350 +0+0; DFP-1: 360x200 +0+0; DFP-1: 320x175 +0+0"
    Option         "ModeValidation" "NoEdidDFPMaxSizeCheck" 
    Option         "ModeValidation" "NoMaxPClkCheck" 
    Option         "ModeValidation" "NoDFPNativeResolutionCheck"
    Modeline       "1920x1080_60.00"  173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsync
    SubSection     "Display"
        Depth       24
	Modes       "1920x1080" "1920x1080"
	Virtual	    1920 1080
    EndSubSection
EndSection
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora 13 nVidia dual displays help needed fedora.linux.64 Linux - Hardware 11 06-21-2010 05:05 PM
Dual Displays in RedHat Enterprise 4 with NVIDIA video card sptech01 Linux - Desktop 2 01-06-2010 06:56 AM
Using dual monitors/dual heads displays a black screen (Fedora 6) ttnunam Linux - General 4 04-21-2007 12:50 AM
nvidia quadro fx 540 linux dual displays microlaser Linux - Hardware 0 10-30-2005 07:20 PM
Fedora wont boot, displays nvidia splash screen over and over jeffreybluml Fedora 6 03-11-2004 01:08 PM


All times are GMT -5. The time now is 07:35 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration