LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (https://www.linuxquestions.org/questions/linux-general-1/)
-   -   Failed to check Filesystem... (https://www.linuxquestions.org/questions/linux-general-1/failed-to-check-filesystem-115660/)

keyz_182 11-13-2003 02:22 PM

Failed to check Filesystem...
 
I am running win Xp on my laptop, i have 3 partitions, windows fat32(18GB), linux ext2(6GB) and linux swapfile(700MB), i have installed mandrake but when i reboot and select linux from the bootloader it gives an error after about 5 mins saying;
Checking Root Filesystem
execvp : input/output
Failed to check filesystem. do you want to repair the errors? (Y/N)
(beware, you can lose data)
i type yes, then enter, but the error is repeated. i press y then enter again then it hangs and all i can do is use the off button.

I am using a Compaq Presario 922.uk, Mobile amd athlon xp 2000+, 1.66GHz, 512 Mb ram.

Any help would be greatly appreciated. (I'm A newby, Be gentle...):D

Mara 11-13-2003 04:36 PM

Was the same problem just after installation? It may mean that the partition was formatted incorrectly. In such case it's the only way to reinstall. I understand you don'thave important data on Linux?

keyz_182 11-13-2003 06:19 PM

I've formatted the drive two or three times but the same problem occurs, i've used the installer to format it once, and i used PowerQuest partition magic 8. if there is another way to partition it, could you explain how. i've seen a few ways but since i'm a real begginer i have no idea what they are talking about.

hulkt 11-14-2003 07:19 AM

hd is corrupted, compaq... whatever...

keyz_182 11-14-2003 07:37 AM

Basically i'm just a bit of a mong, and have never ever used Linux before, I'm the one and only n00b.

Wankstain Ben

Mara 11-15-2003 05:27 PM

Have you tried the disk with other OS/other distro? It may be that there's something wrong with the hd.

keyz_182 11-16-2003 06:25 AM

I've tried Suse And Kuppix(both run off the cd, not hd) but kuppix Kuppix and Mandrake Both get problems after mounting usb filesystem (kuppix just crashes, MDK gets the Filesystem error), Could it have anything to do with my usb ports, Nothing plugged in.

Mara 11-16-2003 04:30 PM

Do you mean you have the disks over USB? Could you post the model name?

keyz_182 11-22-2003 10:20 PM

oops, i really am stupid, after a week of trying to find out what was wrong, i had forgotten to set the linux partiton as active, now all works fine, except sound, but that isn't important just yet... thanks for the help from u lot anyhoo.:rolleyes:


All times are GMT -5. The time now is 09:45 AM.