-   Linux - General (
-   -   External USB hard drive (

bob10a 08-08-2003 07:07 PM

External USB hard drive
I am running SUSE and I am trying to set up an USB harddrive.

As root I modified /etc/fstab, I added the following line:
'/dev/sda1 /media/usb1 vfat noauto,root,rw, 0 0'

Then I restarted the system and tried to mount the harddrive, this is the outcoming message:
'mount: /dev/sda1 is not a valid block device'.

It seems sda1 is not the right device, but how can I find the proper device name and make it work?. Thanks in advance

bob10a 08-08-2003 08:22 PM

I think my problem is that I don't have the 'lsmod' installed.
How can I install this module?.

michaelk 08-08-2003 10:51 PM

lsmod isn't a module it is a command to list installed modules.


So what modules are being loaded?

The output of dmesg will indicate if the OS finds the drive and if it assigns a device id to it. If is the only SCSI device and or USB memory device then it will be /dev/sda

bob10a 08-09-2003 04:48 PM

You are right. I read dmesg and it says:
USB new device connect on bus1/1, assigned device number 2.
Then it says
USB disconnected on device 2.

I have two USB ports (i don't have anything else connected there) and I have tried both, I also have tried sdaX where X is 0,1,..., and sdbX, and I get the message about devrice block. ANy ideas?.

All times are GMT -5. The time now is 11:44 AM.