LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (https://www.linuxquestions.org/questions/linux-general-1/)
-   -   Exchanging packages from Distro to Distro. Can this be done? (https://www.linuxquestions.org/questions/linux-general-1/exchanging-packages-from-distro-to-distro-can-this-be-done-62557/)

Satriani 05-29-2003 05:10 PM

Exchanging packages from Distro to Distro. Can this be done?
 
Hi,

Im (still) trying to find my way in linux...

I just downloaded and installed fluxbox. This works great, however, i would like fbdesk also to run.

i did find a tarbal, tried to compile and install it, but I get a lot of errors compiling it. (I am not very familiar with this compiling)

So, I simply looked for a RPM, and did find one. Only thing is, the name suggests that its a mandrake package (mdk)

Can I install such a package without any problems? (I am using Redhat)

So, basically: can you install a package from Distro XXX on another Distro?

manthram 05-29-2003 05:21 PM

mandrake and redhat are similar in alot of aspects, but there are differences. it is not good to install rpms prepared for other ditro

goto rpmfind and look for the rpm for your disto. if yu cant find one then i seriously suggest that you build the package form the sources. if you have problems with building people here will help you with it

Satriani 05-29-2003 07:07 PM

Thanks manthram, I did not find a package, so I tried to compile myself.

However I see a lot of errors doing this...
I just compiled the latest version of fluxbox: That works!! Great, my first compiled program!!! (Yuah!!!!!)

But, fbdesk will not compile, i ran ./configure, and it all seems to go OK, untill the end: There its saying something about "no package xft installed"

Then it says fbdesk version 1.1.4 configured successfully.

But when I run make, it ends with errors:

collect2: ld returned 1 exit status
make[3]: *** [fbdesk] Error 1
make[3]: Leaving directory /home/user/fbdesk-1.1.4/src
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory /home/user/fbdesk-1.1.4/src
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory /home/user/fbdesk-1.1.4
make: *** [all] Error 2

And thats it.
Any ideas what i am doing wrong ???

Thanks for your help!

Franklin 05-29-2003 07:18 PM

I think you may need to include some of the lines above the one you posted. I assume you are using RH 7.3. fbdesk did compile fine for me in this distro. You need to make sure you have all the developement rpm's installed to compile from source or you will get errors. These are easily found on the RH CD - you don't need to download anything.

Satriani 05-31-2003 05:08 AM

Thanks for the Tip, I will try it this week ...


All times are GMT -5. The time now is 04:39 PM.