-   Linux - General (
-   -   Evolution 1.4.6 ceased send/receive, Redhat 9, IMAP (

actionjoe 03-25-2004 03:36 PM

Evolution 1.4.6 ceased send/receive, Redhat 9, IMAP
I've solved this problem roughly a month ago after a couple of days of Googling and checking bug reports, but now I've forgotten how I did fixed it last time. So, of course, the problem waited until it was safe to rear its head again. I'll continue the hunt and post an answer if I can find it again, but I'd just as soon somebody just told me how to fix it this time.

Here are the symptoms:
The client will work for many months just fine, then one day the user will find that he can no longer receive email by pressing the send/receive button. It says that X new messages are available, but they aren't displayed. Switching from another IMAP folder and coming back to the Inbox doesn't do any good. Email is sent just fine, but no new messages will come in. No error messages are displayed. If evolution is closed and opened again, it will find the new messages waiting on the server and display them.

I feel like the last time this happened, there was just some file in the evolution directory that had somehow become corrupted or full or somesuch and needed to be deleted.

Thanks in advance, Guys.


AutOPSY 03-25-2004 04:46 PM

maybe the client is busy, due to high network traffic.

actionjoe 03-25-2004 05:47 PM

Doesn't seem likely since only restarting the client will fix the problem. Also, its highly reproducible; happens every time now. Plus, its only happening to one user in a field of 15-20 other evolution users.

He took the box home with him tonight, but I found out how to run in debugging mode here:

It seems to me, that the debugger lead me to the culprit last time, too. If not, I'll post the debug info tomorrow and maybe somebody can help me parse it.

All times are GMT -5. The time now is 07:39 AM.