LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 06-04-2003, 06:51 AM   #1
plisken
Member
 
Registered: Dec 2001
Location: Scotland
Distribution: Slackware 9.1/13.37/14/14.2 RH 6.2/7/EL6.5 SuSE 8.2/11.1
Posts: 484

Rep: Reputation: 30
errors while copying/moving files


I seem to get a lot of errors when copying or moving large amounts of data, ie complete websites etc.

The error is as follows:
cp: reading 'foldername/filename.jpg': Input/output error

This would not seem to be a permissions issue.

I also notice that during copying or moving folders of this size, which can sometimes take a couple of hours, the system is VERY slow to resond, even when not running X, this is of great concern to me...

Don't really want to start comparing to Win2K again, but I have no such problems when doing such tasks on that machine, which is similarly equiped.

Any ideas?
 
Old 06-04-2003, 06:55 AM   #2
plisken
Member
 
Registered: Dec 2001
Location: Scotland
Distribution: Slackware 9.1/13.37/14/14.2 RH 6.2/7/EL6.5 SuSE 8.2/11.1
Posts: 484

Original Poster
Rep: Reputation: 30
Arrow More information

If the error points to a file which is actually an image, then when viewing the image, it is corrupt at both the source and destination, most normally with half the image being visable.

Hope this helps...
 
Old 06-04-2003, 09:41 AM   #3
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 255Reputation: 255Reputation: 255
What size are we speaking of? Megabytes or Gigabytes.. etc, you never specified that. And are you moving just from one folder to another on the same drive, or over a network share, etc? Are you using just the cp command or any other command?
 
Old 06-04-2003, 05:49 PM   #4
plisken
Member
 
Registered: Dec 2001
Location: Scotland
Distribution: Slackware 9.1/13.37/14/14.2 RH 6.2/7/EL6.5 SuSE 8.2/11.1
Posts: 484

Original Poster
Rep: Reputation: 30
Movinf rom one folder to another on the same drive, either using cp -fr or when moving/copying in gnome.

The errors occur on file of varying size.

Also what I have noticed is that if I move say a folder which is 500Mb in size, it takes a seriously long time for the action to be completed.
 
Old 06-04-2003, 05:51 PM   #5
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981
ok, have you got dma working (man hdparm) and what are the file systems you're using here?
 
Old 06-04-2003, 07:46 PM   #6
plisken
Member
 
Registered: Dec 2001
Location: Scotland
Distribution: Slackware 9.1/13.37/14/14.2 RH 6.2/7/EL6.5 SuSE 8.2/11.1
Posts: 484

Original Poster
Rep: Reputation: 30
The following is the output from /sbin/hdparm -v /dev/hda6

/dev/hda6:
multcount = 0 (off)
I/O support = 0 (default 16-bit)
unmaskirq = 0 (off)
using_dma = 0 (off)
keepsettings = 0 (off)
nowerr = 0 (off)
readonly = 0 (off)
readahead = 8 (on)
geometry = 7473/255/63, sectors = 117900972, start = 2152773

Not sure how to check which filesystem I'm using
 
Old 06-04-2003, 07:53 PM   #7
plisken
Member
 
Registered: Dec 2001
Location: Scotland
Distribution: Slackware 9.1/13.37/14/14.2 RH 6.2/7/EL6.5 SuSE 8.2/11.1
Posts: 484

Original Poster
Rep: Reputation: 30
When I run the mount command, I get the following:

/dev/hda6 on / type ext2 (rw)
none on /proc type proc (rw)
/dev/hda1 on /boot type ext2 (rw)
none on /dev/pts type devpts (rw,gid=5,mode=620)

I'm assuming this means the ext2 filesystem...

All help appreciated...
 
Old 06-04-2003, 08:10 PM   #8
emetib
Member
 
Registered: Feb 2003
Posts: 484

Rep: Reputation: 33
ext2 is very bad in terms of read/write performance compaired to any of the journaling filesystems. so yes it will take a while.

the error, i would cp -a whatever

hdparm -d1 /dev/hda

cheers.
 
Old 06-04-2003, 08:42 PM   #9
plisken
Member
 
Registered: Dec 2001
Location: Scotland
Distribution: Slackware 9.1/13.37/14/14.2 RH 6.2/7/EL6.5 SuSE 8.2/11.1
Posts: 484

Original Poster
Rep: Reputation: 30
After running hdparm -d1 /dev/hda and then running hdparm -t /dev/hda there is a vast improvement, however when rebooting, the dma setting defaults back to 0, is there anyway of preventing this, or would it be better/easier to have it set to 1 at boot time?

If ext is that bad, which filesystem should I be using for performance, and how can I change it, if possible?
 
Old 06-04-2003, 09:23 PM   #10
emetib
Member
 
Registered: Feb 2003
Posts: 484

Rep: Reputation: 33
i believe that the option that you want is -k, check the man pages to be sure. man hdparm.

it all depends on what you are doing on your computer. if you just have a workstation and are backing up your files, then i would use the reisersfs. if you are server then use ext3. do a google for journaling file systems. that should give you enough info on it for a long research attempt.

i use reisers on my system. i like that speed and the stability that it has. yet at the end of the month i will be switching and reinstalling everything.

to switch, you will have to reinstall by what i know. i believe that you can add journaling to an existing ext2, but i'm not positive. check google on that one or open another thread. you should get some responces to the thread.

cheers.
 
Old 06-05-2003, 07:14 AM   #11
plisken
Member
 
Registered: Dec 2001
Location: Scotland
Distribution: Slackware 9.1/13.37/14/14.2 RH 6.2/7/EL6.5 SuSE 8.2/11.1
Posts: 484

Original Poster
Rep: Reputation: 30
Tried the -k option but after reboot, things reverted back to the origional settings.

What I done was in /etc/sysconfig there is a file called harddisks, I simply added USE_DMA=1 to this file.

What happens is during boot up, the /etc/rc.sysinit checks this file and sets the hdparam parameters accordingly...

After a few reboots, I checked things out by using hdparm -v /dev/hda and now find that DMA is on.

I run hdparm -Tt /dev/hda with and without DMA being activated, the results are below:

DMA:0

Timing buffer-cache reads: 128 MB in 0.90 seconds =142.22 MB/sec
Timing buffered disk reads: 64 MB in 21.30 seconds = 3.00 MB/sec

DMA:1

Timing buffer-cache reads: 128 MB in 0.84 seconds =152.38 MB/sec
Timing buffered disk reads: 64 MB in 2.30 seconds = 27.83 MB/sec

There does seem to be a slight improvement in performace, especially when opening images etc, but I'll have to continue testing to see if this prevents the errors that I have been seeing while moving/copying files.

thanks...
 
Old 06-07-2003, 06:19 AM   #12
plisken
Member
 
Registered: Dec 2001
Location: Scotland
Distribution: Slackware 9.1/13.37/14/14.2 RH 6.2/7/EL6.5 SuSE 8.2/11.1
Posts: 484

Original Poster
Rep: Reputation: 30
I have reverted back to having DMA off, as I was notacing many kernel error messages.

Any ideas?
 
Old 06-07-2003, 06:28 AM   #13
Muddy
Member
 
Registered: May 2002
Location: Ohio
Distribution: Mandrake 9.2 Custom Kernel & Mythtv!
Posts: 256

Rep: Reputation: 30
If your using RH 6.2 that could use some updating... at least the kernel if not the whole distro. There have been many improvements made that would prob benefit you and possibly cure this problem. I don't have enough experience with hdparm other than what your already doing, however I do know a change in file system (ReiserFS) would help. However I don't know if you could change to that without waxing your data.
 
Old 06-07-2003, 06:40 AM   #14
plisken
Member
 
Registered: Dec 2001
Location: Scotland
Distribution: Slackware 9.1/13.37/14/14.2 RH 6.2/7/EL6.5 SuSE 8.2/11.1
Posts: 484

Original Poster
Rep: Reputation: 30
It is actually RH7 that is giving me these problems, but I presume that it could also do with an update or 2.

I may try a different filesystem, possibly a clean install, and if funds allow, then an additional HD would also be nice.

I don't actually recall an option during installation, to choose filesystem, must be there somewhere though...

Cheers.
 
Old 06-07-2003, 06:57 AM   #15
Muddy
Member
 
Registered: May 2002
Location: Ohio
Distribution: Mandrake 9.2 Custom Kernel & Mythtv!
Posts: 256

Rep: Reputation: 30
There for sure is, when you go into the partitioning part of it and your setting up swap, /boot etc.. you choose it there.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
copying files(s) in c climbingmerlin Programming 7 10-27-2005 03:00 PM
copying/moving stalls when moving a lot of data to a usb stick =X= Linux - Hardware 10 07-30-2004 06:29 AM
Disk Copying/Cloningwith LiLo errors sbnservices Linux - Newbie 4 06-14-2004 06:51 PM
Moving/Copying/Saving to Floppy chaswp54 Linux - General 1 10-23-2001 03:40 PM
Moving/Copying To Floppy chaswp54 Linux - Newbie 1 10-23-2001 03:38 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 08:19 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration