LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 03-17-2016, 10:19 AM   #16
suicidaleggroll
LQ Guru
 
Registered: Nov 2010
Location: Colorado
Distribution: OpenSUSE, CentOS
Posts: 5,573

Rep: Reputation: 2138Reputation: 2138Reputation: 2138Reputation: 2138Reputation: 2138Reputation: 2138Reputation: 2138Reputation: 2138Reputation: 2138Reputation: 2138Reputation: 2138

Does the arch system have a UID 1000? You can run "id 1000" to check or check /etc/passwd. You should also check whether the other systems have a UID 1001.

If the Arch system does not have a UID 1000, it would be easiest to change that one to match the other two.
If the Arch system does have a UID 1000 but the other two do not have a 1001, then it would be easiest to change the other two to match Arch.
If neither of the above applies, you'll need to find a new UID that is available on all systems, and change all three to that one.

Once you know what you're changing to, you would use the usermod, groupmod, and find commands I posted earlier to make the change.
 
Old 03-17-2016, 10:23 AM   #17
suicidaleggroll
LQ Guru
 
Registered: Nov 2010
Location: Colorado
Distribution: OpenSUSE, CentOS
Posts: 5,573

Rep: Reputation: 2138Reputation: 2138Reputation: 2138Reputation: 2138Reputation: 2138Reputation: 2138Reputation: 2138Reputation: 2138Reputation: 2138Reputation: 2138Reputation: 2138
Quote:
Originally Posted by John VV View Post
i run into this issue with opensuse and scientific linux
root is 500 or 1000
and the first non root user is 501 or 1001

i share drives and data with the two OS's so the user name and uid need to be the same

in my case 1000 and 1001 for both os's
Yeah, they keep changing the rules. Way back when it used to be that <100 was for system accounts and 100+ was for user accounts. Then this changed to 500, then 1000, and who knows where it's going next. And of course even if ALL of your other systems use UID 500, as soon as ONE of them decides that user accounts are now limited to 1000+, you have to go in and change ALL of the others to match, you can't stick with the lower value. A while back I got fed up with all of the rule changing and just made my UID 3000 on all systems. That should future-proof me at least a little bit, hopefully.
 
Old 03-17-2016, 04:32 PM   #18
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware, MX 18
Posts: 9,484

Original Poster
Blog Entries: 15

Rep: Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163
Quote:
Originally Posted by suicidaleggroll View Post
Does the arch system have a UID 1000? You can run "id 1000" to check or check /etc/passwd. You should also check whether the other systems have a UID 1001.

If the Arch system does not have a UID 1000, it would be easiest to change that one to match the other two.
If the Arch system does have a UID 1000 but the other two do not have a 1001, then it would be easiest to change the other two to match Arch.
If neither of the above applies, you'll need to find a new UID that is available on all systems, and change all three to that one.

Once you know what you're changing to, you would use the usermod, groupmod, and find commands I posted earlier to make the change.
Arch's system id is 1001.
Both Linux Mint install's uid are 1000. So if I understand you correctly it would be easiest to change Arch to 1000.
 
Old 03-17-2016, 04:48 PM   #19
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware, MX 18
Posts: 9,484

Original Poster
Blog Entries: 15

Rep: Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163
Does this have to be done in tty?

This is what I'm hoping will fix the problem.

Code:
usermod -u 1000 sifu
groupmod -g 1000 groups

find / -sifu 1001 -exec chown 1000 {} \;
find / -group 1001 -exec chgrp 1000 {} \;
Is this correct suicidaleggroll?

Last edited by Ztcoracat; 03-17-2016 at 10:25 PM.
 
Old 03-20-2016, 05:56 AM   #20
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Germany
Distribution: Whatever fits the task best
Posts: 17,148
Blog Entries: 2

Rep: Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867
Quote:
Originally Posted by Ztcoracat View Post
Does this have to be done in tty?

This is what I'm hoping will fix the problem.

Code:
usermod -u 1000 sifu
groupmod -g 1000 groups

find / -sifu 1001 -exec chown 1000 {} \;
find / -group 1001 -exec chgrp 1000 {} \;
Is this correct suicidaleggroll?
Nope, the third command should be
Code:
find / -user 1001 -exec chown 1000 {} \;
To speed this up a little bit I also would use a different notation for the last two commands, so that the chown and chgrp commands are not called for every single file, but rather for groups of files:
Code:
find / -user 1001 -exec chown 1000 {} +
find / -group 1001 -exec chgrp 1000 {} +
 
Old 03-20-2016, 09:50 AM   #21
suicidaleggroll
LQ Guru
 
Registered: Nov 2010
Location: Colorado
Distribution: OpenSUSE, CentOS
Posts: 5,573

Rep: Reputation: 2138Reputation: 2138Reputation: 2138Reputation: 2138Reputation: 2138Reputation: 2138Reputation: 2138Reputation: 2138Reputation: 2138Reputation: 2138Reputation: 2138
Quote:
Originally Posted by Ztcoracat View Post
Arch's system id is 1001.
Both Linux Mint install's uid are 1000. So if I understand you correctly it would be easiest to change Arch to 1000.
Only if Arch doesn't already have a UID 1000. Please see my previous post describing the three possible scenarios.
 
Old 03-20-2016, 05:03 PM   #22
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware, MX 18
Posts: 9,484

Original Poster
Blog Entries: 15

Rep: Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163
Quote:
Originally Posted by TobiSGD View Post
Nope, the third command should be
Code:
find / -user 1001 -exec chown 1000 {} \;
To speed this up a little bit I also would use a different notation for the last two commands, so that the chown and chgrp commands are not called for every single file, but rather for groups of files:
Code:
find / -user 1001 -exec chown 1000 {} +
find / -group 1001 -exec chgrp 1000 {} +
Thank You-
 
Old 03-20-2016, 05:06 PM   #23
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware, MX 18
Posts: 9,484

Original Poster
Blog Entries: 15

Rep: Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163
Quote:
Originally Posted by suicidaleggroll View Post
Only if Arch doesn't already have a UID 1000. Please see my previous post describing the three possible scenarios.
W/O fixing anything yet Arch's current uid is: 1001.

I'll work on this later tonight and let you know what the outcome is.
 
Old 03-20-2016, 07:03 PM   #24
Emerson
LQ Guru
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~arch
Posts: 6,317

Rep: Reputation: Disabled
suicidaleggroll meant make sure UID 1000 is not in use.
 
Old 03-20-2016, 07:06 PM   #25
suicidaleggroll
LQ Guru
 
Registered: Nov 2010
Location: Colorado
Distribution: OpenSUSE, CentOS
Posts: 5,573

Rep: Reputation: 2138Reputation: 2138Reputation: 2138Reputation: 2138Reputation: 2138Reputation: 2138Reputation: 2138Reputation: 2138Reputation: 2138Reputation: 2138Reputation: 2138
Quote:
Originally Posted by Ztcoracat View Post
W/O fixing anything yet Arch's current uid is: 1001.
No, your user's UID on the Arch system is 1001. Your user is not the only user on the system. You need to make sure that one of the others isn't using UID 1000 before you can change your user to 1000.
 
Old 03-20-2016, 07:28 PM   #26
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware, MX 18
Posts: 9,484

Original Poster
Blog Entries: 15

Rep: Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163
Quote:
You need to make sure that one of the others isn't using UID 1000 before you can change your user to 1000.
How to make sure of that?

Linux Mint KDE uid is 1000 and he is the only user on the system.
Linux Mint Cinnamon's uid is 1000 he is also the only user on the system.

Arch only has one user on the system.

Is is ok to change Arch to 1000 to match the other 2?

Last edited by Ztcoracat; 03-20-2016 at 07:35 PM.
 
Old 03-20-2016, 07:32 PM   #27
suicidaleggroll
LQ Guru
 
Registered: Nov 2010
Location: Colorado
Distribution: OpenSUSE, CentOS
Posts: 5,573

Rep: Reputation: 2138Reputation: 2138Reputation: 2138Reputation: 2138Reputation: 2138Reputation: 2138Reputation: 2138Reputation: 2138Reputation: 2138Reputation: 2138Reputation: 2138
See post #16
 
Old 03-20-2016, 07:39 PM   #28
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware, MX 18
Posts: 9,484

Original Poster
Blog Entries: 15

Rep: Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163
Quote:
Originally Posted by suicidaleggroll View Post
See post #16
Quote:
If the Arch system does not have a UID 1000, it would be easiest to change that one to match the other two.
It's clear now, Thank You.
 
Old 03-20-2016, 10:28 PM   #29
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware, MX 18
Posts: 9,484

Original Poster
Blog Entries: 15

Rep: Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163
After running those cmd's the tty returned chown:
Code:
 changing ownership of /proc/1470/ns/mnt: operation not permitted.
Code:
changing group of /proc/1484/task/1484, : operation not permitted
Leaving tty I used Ctrl+alt+f3 to return to the gui. It crashed.

Upon rebooting I don't have a gui at all.
I can't log in and when I do it just returns me to log in again.

I'm stuck in tty only and startx returns:

Code:
xauth timeout in locking authority
file /home/sifu/.Xauthority
How do I fix this?
 
Old 03-20-2016, 10:56 PM   #30
Emerson
LQ Guru
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~arch
Posts: 6,317

Rep: Reputation: Disabled
Why did you run this when you were logged on as sifu? I think earlier in this thread you were told not to do it. Common sense tells you not to do it. The solution is obvious, I do not think I need to spell it out for an experienced Slackware user?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Error opening /dev/sdb:Permission denied Neo@Matrix Linux - Newbie 20 09-20-2011 09:39 PM
excuting file resuls in permission denied error Panceisto Linux - Newbie 3 04-22-2010 03:12 AM
Acrobat Reader "error opening document - permission denied" Robhogg Linux - Software 5 04-25-2008 08:44 AM
Error opening type hash map aliases.db : permission denied Tazzmanian Linux - Software 2 08-24-2004 11:56 AM
permission denied when opening directory pilot1 Linux - General 1 10-23-2002 08:27 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 04:10 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration