LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 05-01-2020, 01:30 PM   #1
no-windose
LQ Newbie
 
Registered: Jun 2018
Posts: 27
Blog Entries: 2

Rep: Reputation: Disabled
Error message "Failed to start Load AppArmor profiles" at boot time


I have tried to upgrade Ubuntu from 18.04 bionic to 20.04 focal with the update manager. The process hanged for ever when installing a package called "libgdk-pixbuf" or something similar. So I had to restart the computer. After starting the upgrade process again, this time with the command line "$ apt upgrade", I could not boot. There was an error message:

"Failed to start Load AppArmor profiles."

Could someone please help me to repair the system?
 
Old 05-02-2020, 06:04 AM   #2
shruggy
Senior Member
 
Registered: Mar 2020
Posts: 1,004

Rep: Reputation: Disabled
Can you boot into rescue mode or emergency mode? See: https://www.ostechnix.com/how-to-boo...-ubuntu-18-04/

Quote:
Originally Posted by no-windose View Post
I have tried to upgrade Ubuntu from 18.04 bionic to 20.04 focal with the update manager.
From the Ubuntu 20.04 announcement:
Quote:
Users of Ubuntu 19.10 will be offered an automatic upgrade to 20.04 LTS
via Update Manager shortly. Users of 18.04 LTS will be offered the
automatic upgrade when 20.04.1 LTS is released, which is scheduled for
July 23rd.

Last edited by shruggy; 05-02-2020 at 11:22 AM.
 
Old 05-02-2020, 04:15 PM   #3
no-windose
LQ Newbie
 
Registered: Jun 2018
Posts: 27

Original Poster
Blog Entries: 2

Rep: Reputation: Disabled
I can choose "recovery mode" from the GRUB menu. Then the system hangs a bit at "running /scripts/local-premount ...". Then I get the "recovery menu": resume/clean/dpkg/fsck/grub/network/root/system-summary.
 
Old 05-03-2020, 04:24 AM   #4
shruggy
Senior Member
 
Registered: Mar 2020
Posts: 1,004

Rep: Reputation: Disabled
Select dpkg.
 
Old 05-03-2020, 06:53 AM   #5
no-windose
LQ Newbie
 
Registered: Jun 2018
Posts: 27

Original Poster
Blog Entries: 2

Rep: Reputation: Disabled
I have tried already to select dpkg. I have typed:
# dpkg -i libgdk-pixbuf2.0-0
But it makes no difference. I still can't boot.
 
Old 05-03-2020, 07:30 AM   #6
shruggy
Senior Member
 
Registered: Mar 2020
Posts: 1,004

Rep: Reputation: Disabled
You misunderstood. Selecting the menu item dpkg in the recovery menu will try to repair broken packages. This is what I mean.

Quote:
Originally Posted by no-windose View Post
# dpkg -i libgdk-pixbuf2.0-0
This command is wrong. The parameter to dpkg -i is supposed to be a .deb file.

Last edited by shruggy; 05-03-2020 at 07:31 AM.
 
Old 05-04-2020, 10:51 AM   #7
no-windose
LQ Newbie
 
Registered: Jun 2018
Posts: 27

Original Poster
Blog Entries: 2

Rep: Reputation: Disabled
Thanks shruggy. I have selected dpkg and the computer has downloaded some stuff which has resulted in a "partial upgrade". But I still can't boot. I get the following message when I try to boot:

A start job is running for /dev/mapper/cryptswap1
Failed to start Load AppArmor profiles.
See 'systemctl status apparmor.service' for details.
 
Old 05-12-2020, 03:50 PM   #8
no-windose
LQ Newbie
 
Registered: Jun 2018
Posts: 27

Original Poster
Blog Entries: 2

Rep: Reputation: Disabled
It turns out that I had wrongly upgraded from 18.04 to 20.04 on a 32-bit computer. I had changed the /etc/apt/sources.list file to allow the download of 20.04 packages. I should not have done so as 20.04 does not support 32-bit computers.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
I'm an rpi user and at boot I get the message "failed to load kernel modules", however the system seems to work just fine. Using stretch. rsmith53 Linux - Newbie 1 11-26-2019 02:02 PM
[SOLVED] apparmor="DENIED" operation="rename_src" profile="/usr/bin/freshclam Toadman Linux - Software 4 06-27-2018 08:52 AM
[SOLVED] 'failed to start apparmor initialization' JaiVes Linux - Newbie 1 02-07-2018 04:34 AM
Got "Error: Failed to load library [libGL.so]." message when loading Descent 3 game Linux.Blue472 Linux - Software 12 08-27-2013 08:34 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 08:22 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration