-   Linux - General (
-   -   E297: Write error in swap file (

kumarrbt 12-25-2006 10:32 AM

E297: Write error in swap file
Hi, I am getting this error when I tried to edit a file "E297: Write error in swap file". Can somebody help me in resolving this issue?


bigrigdriver 12-25-2006 12:20 PM


*E296* *E297*
Seek error in swap file write
Write error in swap file

This mostly happens when the disk is full. Vim could not write text into the
|swap-file|. It's not directly harmful, but when Vim unexpectedly exits some
text may be lost without recovery being possible. Vim might run out of memory
when this problem persists.
It's time to do some house cleaning to remove old log files, trim down some large log files, clear out browser caches, etc. The partition is full from the sound of it. No room left to write to the hard drive. It isn't a problem with the swap partition unless the swap partition is way too small for the demands of the system.

syg00 12-25-2006 03:58 PM

Quick test looks like the swap is allocated in the directory of the file being editted.
You can choose not to use a swap file - see "man vim".

qubodup 08-25-2014 10:52 PM

I just had the same error. The reason for this was that I ran out of hard drive storage space. I was going to write a note while copying files from an SD card and saw the error.

`df` showed me that the partition I used was 100% full and had 0 bytes available.

This answer is relevant and timely because it has not yet been answered while this page is a top result for whatever query I used to search for this error.

All times are GMT -5. The time now is 06:01 PM.