Welcome to the most active Linux Forum on the web.
Go Back > Forums > Linux Forums > Linux - General
User Name
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.


  Search this Thread
Old 12-16-2002, 02:13 AM   #1
Registered: May 2002
Location: Sydney Australia
Distribution: Redhat 6.1 & 7.2
Posts: 91

Rep: Reputation: 15
duel Booting question


I am trying to get my machine to boot two seperate O/S's, namely Linux on one HDD & win 2000 server on the other
These are both running as primary masters on seperate controllers. I am only able to boot Linux at the moment. When running lilo see below i get this warning. What does it mean??. Is it a false positive??
Reading boot sector from /dev/hdc
Warning: /dev/hdc is not on the first disk
Merging with /boot/boot.b
Mapping message file /boot/message
Boot image: /boot/vmlinuz-2.4.18-18.8.0
Mapping RAM disk /boot/initrd-2.4.18-18.8.0.img
Added linux *
Boot other: /dev/hdc1, on /dev/hdc, loader /boot/chain.b
Added DOS
/boot/boot.1600 exists - no backup copy made.
Writing boot sector.

Fdisk -l gives this output

fdisk -l

Disk /dev/hdc: 255 heads, 63 sectors, 1247 cylinders
Units = cylinders of 16065 * 512 bytes

Device Boot Start End Blocks Id System
/dev/hdc1 * 1 1247 10016496 17 Hidden HPFS/NTFS

Disk /dev/hda: 255 heads, 63 sectors, 4865 cylinders
Units = cylinders of 16065 * 512 bytes

Device Boot Start End Blocks Id System
/dev/hda1 1 13 104391 83 Linux
/dev/hda2 14 4784 38323057+ 83 Linux
/dev/hda3 * 4785 4865 650632+ 82 Linux swap

What am i doing wrong??


Old 12-16-2002, 02:54 AM   #2
Senior Member
Registered: Sep 2001
Location: Brisvegas, Antipodes
Distribution: Slackware
Posts: 4,590

Rep: Reputation: 56
It looks like your trying to install lilo to hdc (secondary master) when it should be installed to hda (primary master).
Old 12-16-2002, 03:14 AM   #3
LQ Newbie
Registered: Dec 2002
Location: Brisbane
Distribution: Slackware & LFS 4.0
Posts: 6

Rep: Reputation: 0
G'day, I am a new member here so just thought I'd let someone know I exist.

Anyway, I had the same problem when I wanted to boot WinXP and Slackware. There's a HOWTO which gives a pretty good explanation on my slackware CD, but I'll go the long winded one anyway.

I found the best way was to use the WinNT boot menu (Win2K and XP both work too). [edit] Of course, this only works if lilo is not already installed on the MBR of the first hard disk. Windoze has to have it's mark there, meaning that it starts up as the default OS at boot time. [/edit] To do this, go into the linux distro you want to boot to (via a boot disk or however you want to get there), then change lilo.conf so that the "boot" option points to the hdd partition you want to boot to (ie "boot=/dev/hda5" or /dev/hdc if that's where your distro resides) and the part down the bottom containing the info for each OS to boot only contains the info for the one you are currently in.

After this, run lilo to install the boot info to the start of the partition (or disk) that your distro is on. Once that is done, run:
dd if=/dev/<partition> of=/root/bootlinux bs=512 count=1

The <partition> is the name of the partition where your distro is (mine is /dev/hda5) and the /root/bootlinux is the output file. Make sure you type those other two or you'll be waiting a while for it to finish Type 'man dd' if you want to know what these are!

Once you've done this, put the file (/root/bootlinux) on a floppy or shared partition to move it to Win2K (I have a shared FAT32 partition able to be used by both Linux and WinXP).

Copy the file to C:\bootlinux and open the C:\boot.ini file. I don't know how well you know windows, so if you can't see it go to the tools menu on "My Computer" and select "folder options". select the view tab and enable "view hidden files and folders".

When you are in boot.ini, add a line at the end something like: C:\bootlinux="Redhat Linux 7.2".
Save this file and reboot, you should now get a menu at the startup of windows that shows Windows 2000 and Redhat Linux 7.2 as options. You can also change the default OS to boot and the timeout in boot.ini.

Hope this helps.

Matty Jenko

Last edited by MoRoSiS; 12-16-2002 at 06:31 AM.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Need Help Duel Booting FC3 after Ubuntu. zeroz52 Fedora - Installation 3 02-28-2005 09:42 AM
duel booting quick question endezeichen Mandriva 3 09-03-2004 06:22 AM
Duel Booting....*sigh*...yeah terry.trent Linux - Software 1 10-27-2003 07:54 PM
duel booting suse 8.2 & win2kpro HOW? fr0ggeh Linux - Distributions 15 08-08-2003 09:58 AM
Duel Booting Jedi_Cheese Linux - Newbie 4 01-14-2002 11:56 PM > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 11:47 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration