LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 07-24-2004, 06:54 PM   #1
mjs2000
LQ Newbie
 
Registered: Jul 2004
Distribution: Debian Sarge/Fedora Core 2
Posts: 2

Rep: Reputation: 0
Dual-booting with Windows 98?


My situation is the reverse of most peoples'--my machine is running Debian (sarge), which is installed on /dev/hda1, and I have just installed Windows 98 SE on /dev/hdb1.

Reason for this strange request: I've ordered a new video card in hopes of playing new games (incl. a certain new id Software game), and did not want to pay $200+ or resort to piracy for a copy of XP, so I installed my old copy of 98.

Now, all I need to do is add an entry to GRUB to boot to Windows (which I previously did by disconnecting the Linux drive and connecting the other to hda). I've found instructions on how to do this for 2000/XP, but none for 98. What commands do I use? And will I have to make changes to MBRs and stuff or change the order of the drives on the IDE cable?

thanks
-matt

(p.s. Even if I do get this working, I feel sorry for my poor copy of GRUB for having to deal with such a horrible OS. We need more commercial Linux games!)
 
Old 07-24-2004, 07:07 PM   #2
ilovelinux
LQ Newbie
 
Registered: Jul 2004
Location: BC, Canada
Distribution: Fedora Core 1
Posts: 1

Rep: Reputation: 0
Talking


I think the instructions are the same. You just edit the grub.conf file by adding a section that points to the partition that Windows is on. Then save the file and it should work. But I'm not sure. So you can still try it or keep on searching on other sites.

Tell me if it works or not.
 
Old 07-24-2004, 09:37 PM   #3
Franklin
Senior Member
 
Registered: Oct 2002
Distribution: Slackware, Windows 10
Posts: 1,271

Rep: Reputation: 80
If it were me, I would turn the drive that has win98 on it to the master (/dev/hda).
I would make the linux drive the slave (/dev/hdb) and change all the fstab entries to reflect the change from hda to hdb. I always thought win98 needed to be on /dev/hda1 or it would complain but I may be wrong. You'll need to boot into linux from a cd or boot disk and reinstall lilo (or grub) once the change is made.

My 2 cents
 
Old 07-24-2004, 10:07 PM   #4
zLinuxz
Senior Member
 
Registered: Feb 2002
Location: Shanghai, CHINA
Distribution: RH 5.0,5.1 6.0,6.1 7.0,7.1,7.2,7.3.,8.0,9.0, RH Enterprise, Fedora C1, C2
Posts: 1,216

Rep: Reputation: 45
msj2000, you can really plug your hardrives however you want, all you have to specify to grub is which hardrive has what, and whether it is a hda or hdb, a line like the following should be sufficient:

title Fedora Core (2.4.22-1.2115.nptl)
root (hd0,1)
kernel /vmlinuz-2.4.22-1.2115.nptl ro root=LABEL=/ hdc=ide-scsi rhgb
initrd /initrd-2.4.22-1.2115.nptl.img
title DOS
rootnoverify (hd0,0)
chainloader +1

what is different in yours, is the "hd0" I have, since I only have 1 hardrive. but since you have 2, you must specify which one will be hda and hdb.
Let us know how it goes.

zLinuxz
 
Old 07-24-2004, 11:10 PM   #5
mjs2000
LQ Newbie
 
Registered: Jul 2004
Distribution: Debian Sarge/Fedora Core 2
Posts: 2

Original Poster
Rep: Reputation: 0
I think you guys are right about the Windows drive needing to be on /dev/hda: this was how I had my old Redhat 9/Win98 box set up. I added the following to the bottom of my GRUB menu.lst:

Code:
title Windows 98 SE (use at own risk!)
rootnoverify (hd1,0)
chainloader +1
but when I select that option from GRUB, nothing happens. (Except the one time when I did it and the PC speaker went on a beeping rampage.) I'll try switching the drives around and see what I can do.

For reference, the other entry in my menu.lst is as follows:
Code:
title Debian GNU/Linux, kernel 2.4.26
root (hd0,0)
kernel /boot/vmlinuz-2.4.26 root=/dev/hda1 ro
initrd /boot/initrd.img-2.4.26
savedefault
boot
-matt
 
Old 07-25-2004, 12:22 AM   #6
kevinalm
Member
 
Registered: Oct 2003
Location: Iowa
Distribution: LFS 5.0, building 6.3, win98se, multiboot
Posts: 288

Rep: Reputation: 30
Try:

title Windows 98 SE (use at own risk!)
rootnoverify (hd1,0)
chainloader +0

That should be where the windoze first stage bootloader is located if it installed.

Last edited by kevinalm; 07-25-2004 at 12:24 AM.
 
Old 07-25-2004, 03:27 AM   #7
zLinuxz
Senior Member
 
Registered: Feb 2002
Location: Shanghai, CHINA
Distribution: RH 5.0,5.1 6.0,6.1 7.0,7.1,7.2,7.3.,8.0,9.0, RH Enterprise, Fedora C1, C2
Posts: 1,216

Rep: Reputation: 45
mjs2000, yep, I think you have to make the Windows drive, hd0, and the Linux drive, hd1, and then you probaly wont have any more problems. I just remembered that Windows doesn't like being second, or slave, or anything other than to think that it is by itself and that it is number 1....so the best bet is to have windows first and then Linux.

I have a duel pentium with 2 ultra wide scsi drives, sda and sdb, and sda is windows while sdb is Linux

I hope you get it working soon.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Dual booting SuSe 9.1 and Windows XP Bannor Linux - Newbie 4 10-05-2004 09:07 AM
Dual booting into windows 2k Tharkin Linux - Newbie 6 09-13-2004 02:42 PM
Dual dual booting with Suse 9.1 pro and windows 98SE UDflyer Linux - General 1 07-30-2004 02:37 PM
Dual booting Linux and Windows XP windozeman Linux - Newbie 2 03-24-2004 01:10 PM
Are you dual booting and Windows stopped working (booting) then here's the answer: rberry88 Linux - General 1 02-12-2004 09:05 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 03:17 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration