LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 09-03-2002, 03:47 PM   #1
dark_light
Member
 
Registered: Mar 2002
Location: On Mars
Posts: 115

Rep: Reputation: 15
Dual booting Red Hat Linux 7.3


Hi guys i m really having problems with this Redhat Linux 7.3 when i try to dual boot it with winxp

i have used RH Linux 7.0 and it worked fine while dual booting but when i do the same thing i.e putting mbr on boot partition " in 7.3 then it doesn't works , now im booting using a floppy which is very non-professional.

so help me out guys.

i have installed xp on hda0 and i have installed linux on hda6

everything else is fine .its just dualbooting which doesn't works

so guys plz help me out
 
Old 09-03-2002, 04:11 PM   #2
L.B
LQ Newbie
 
Registered: Jul 2002
Location: Netherlands, EU
Distribution: Ubuntu
Posts: 14

Rep: Reputation: 0
When you put 'MBR' on the Linux boot partition it will not enable you to start Linux.
You have to use the MBR of the drive, where you have the MS MBR at the moment.
You can do this by installing Grub or Lilo to the MBR (not the Linux boot partition) or by setting up the MS boot loader to chainload the Linux boot loader you already installed.
Search Google to find out how to do the above.
 
Old 09-04-2002, 08:23 PM   #3
dark_light
Member
 
Registered: Mar 2002
Location: On Mars
Posts: 115

Original Poster
Rep: Reputation: 15
Well can't u just tell me how can i do it. cause it will be a bit more time consuming to search on the web and i don't have time these days

i installed xp on hda0 first and then linux on hda6 .hence the boot partition is hda0 at the moment.

so what should i do. i have installed lilo but it doesn't works


thanks in advance
 
Old 09-04-2002, 08:32 PM   #4
Thymox
Senior Member
 
Registered: Apr 2001
Location: Plymouth, England.
Distribution: Mostly Debian based systems
Posts: 4,368

Rep: Reputation: 63
Check the very first line of the file /etc/lilo.conf. Normally this should be /dev/hda to put LiLo into the MBR on the primary master disk. It sounds like yours it probably /dev/hda6 or something.

Try changing this line (you'll need to be root to edit the file), then rerun lilo (/sbin/lilo) to put the settings in place.
 
Old 09-04-2002, 08:54 PM   #5
chem1
Member
 
Registered: Jun 2002
Location: White House, Washignton DC
Distribution: Red Hat 9
Posts: 270

Rep: Reputation: 30
WHy don't you let the Windows MBR do the booting for both Linux and Windows
IF you are interested then I can explain to you how to achieve that. I am using the smae technique on RH 7.3 and W2K and it works fine.
ON the other hand when I earlier installed LILO into the MBR of the primary disk and tried to boot Mandrake 8.1, my MBR was screwed up and I had to format my drive, since W2K rescue console was unable to repair the MBR

Hope this helps...
 
Old 09-04-2002, 09:51 PM   #6
exigent
Member
 
Registered: Aug 2002
Distribution: damnsmalllinux
Posts: 205

Rep: Reputation: 30
i was under the impression that xp didn't allow changing of the MBR on the master block. i'm not sure, but i think that you can't change it if you are using xp.... am i wrong?
 
Old 09-04-2002, 11:20 PM   #7
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 681Reputation: 681Reputation: 681Reputation: 681Reputation: 681Reputation: 681
Here is a Microsoft link for instructions on editing the boot.ini menu in Windows XP.
http://support.micro$oft.com/default...;EN-US;q289022
HOW TO: Edit the Boot.ini File in Windows XP

This site has an example of a Win XP / Red Hat linux multiboot setup.http://www.zen.home.att.net/linxp.html

My HP laptop has a hidden partition (HDA1) that is formatted in FAT rather then NTFS so the MBR resided there, I didn't have to do anything special for multibooting to work.


note: the first link keeps getting the letter 's' changed to a dollar sign. I tried re-editing twice. What gives?

Last edited by jschiwal; 09-04-2002 at 11:34 PM.
 
Old 09-05-2002, 05:05 AM   #8
born4linux
Senior Member
 
Registered: Sep 2002
Location: Philippines
Distribution: Slackware, RHEL&variants, AIX, SuSE
Posts: 1,127

Rep: Reputation: 49
you post for us the output of fdisk -l in your linux system and the contents of grub.conf. We can help you quickly with that info.
 
Old 09-05-2002, 10:14 PM   #9
dark_light
Member
 
Registered: Mar 2002
Location: On Mars
Posts: 115

Original Poster
Rep: Reputation: 15
Alright chem1 im interested in ur way .
Show me how to do it.
actually i was looking for it but couldn't find a way to change window mbr
 
Old 09-05-2002, 11:15 PM   #10
exigent
Member
 
Registered: Aug 2002
Distribution: damnsmalllinux
Posts: 205

Rep: Reputation: 30
the windows mbr is probably on the master block. however, i think that xp automatically changes it everytime you boot up. i think that you might be able to download and use a third-party boot utility, like partition magic or system commander. i use system commander with suse and win98se, and it works wonderfully, automatically detecting all the partitions and giving me the options that i need...
 
Old 09-05-2002, 11:47 PM   #11
Kryptow
LQ Newbie
 
Registered: Aug 2002
Location: Miami, Florida
Distribution: Redhat 7.3 / 8.0
Posts: 23

Rep: Reputation: 15
I'm not sure if this can work with LILO since it was made to be implemented with GRUB but here you go.

The following you would add to your GRUB.conf file:

Code:
title windows xp
rootnoverify (hd0,0)
chainloader +1
This works if you installed Windows first and placed the boot loader in the MBR.

But there is also another way of doing it during the installation of the boot loaderi n redhat 7.3 if you specified a label for your windows partition it would automatically give you the dual boot option. But if you didn't then you would have to use the code mentioned above.
 
Old 09-06-2002, 03:16 PM   #12
dark_light
Member
 
Registered: Mar 2002
Location: On Mars
Posts: 115

Original Poster
Rep: Reputation: 15
Nobig deal i will install Grub but im very new to linux so how can i know the partitions information of My harddisk. i have tried fdisk but i think im doing it wrong as i don't know the command that much

The hda0 is the partition where linux is installed?

How will i edit the Grub.config file?

The code u told would be written at the start or end?

In this case the mbr should be on First sector or boot partition ?



I know all of them are silly questions but ......
 
Old 09-07-2002, 02:49 AM   #13
awdoyle
Member
 
Registered: Aug 2002
Location: Portland, OR
Distribution: Xubuntu
Posts: 135

Rep: Reputation: 15
dark_light - to tell you the truth, I booted my system from CD to re-discover my partition setup.

I have a similar setup that has been gnawing at me. 80gb drive with XP and Red Hat 7.3, but it only boots to XP. The partition table in disk druid looks like:
hda1=xp
hda2=boot
hda3=root
hda4=ext
hda5=swap
XP was installed first, and during the disk druid portion of the RH install, GRUB was installed to the first sector of the root partition, as opposed to MBR (oops I think). The page http://www.zen.home.att.net/linxp.html (great link jschiwal!) does show a good walk-through - most web searches I've done have pointed to similar fixes. The below formula of commands ends up putting a 1kb copy of bootsect.lin on my disk. I'll paste the shell log:
# mount -t msdos /dev/fd0 /mnt
# dd if=/dev/hda3 bs=512 count=1 of=mnt/bootsect.lin
1+0 records in
1+0 records out
# umount /dev/fd0
When I copy the bootsect.lin to my winxp c:\ root directory, then add
c:\bootsect.lin="Linux"
as the last line of my boot.ini file and reboot, the menu offers both xp and linux, but when I select linux, it hangs. I think the file copied incorrectly to floppy, and wasn't big enough. But I don't know how to fix it. I don't think this part matters (yet), but my GRUB.conf file does include the last 3 lines pointed out by Kryptow. Can someone point out my mistakes or suggest a better fix?
Many thanks in advance!
 
Old 09-08-2002, 07:00 AM   #14
itismike
Member
 
Registered: Aug 2002
Location: East Coast, USA
Distribution: Ubuntu
Posts: 75

Rep: Reputation: 15
I'm just testing a theory for jschiwal here...If I'm wrong then this post will look kind of silly. Since we're on linuxquestions.org, I think any mention of the micro$oft name (I typed an 's' there,) gets changed to micro$oft (I typed a dollar sign '$.')

BTW, if it's capitalized, Microsoft keeps it's 's.'

-Mike
 
Old 09-08-2002, 03:12 PM   #15
exigent
Member
 
Registered: Aug 2002
Distribution: damnsmalllinux
Posts: 205

Rep: Reputation: 30
microsoft

wow, that's really weird....
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
dual booting Red Hat 9 and Win98SE stoney55 Red Hat 0 02-13-2005 04:37 PM
Dual Booting XP and Red Hat jackp Linux - Newbie 7 12-23-2004 12:34 AM
Dual booting Windows 98 and Red Hat 6 psarangi Linux - Software 14 07-07-2004 10:19 PM
Dual booting Red Hat Linux with Windows XP Agbo Linux - Software 7 04-08-2004 08:10 AM
Problems with Dual booting XP and Red Hat 9 skull_leader Linux - Newbie 1 12-16-2003 09:23 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 03:35 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration