LinuxQuestions.org

LinuxQuestions.org (http://www.linuxquestions.org/questions/index.php)
-   Linux - General (http://www.linuxquestions.org/questions/forumdisplay.php?f=1)
-   -   Dual boot problem with Windows 7 (http://www.linuxquestions.org/questions/showthread.php?t=4175453052)

Micik 03-07-2013 12:07 AM

Dual boot problem with Windows 7
 
Hello to all,

I hope you'll be able to help me.
I have win 7 installed on my laptop. I decided to make dual boot with open suse. First I tried to install version 11.4 from windows (putting installl CD while using windows) This installation was corrupt so I end up that my windows boot manager at startup shows choice (win and linux while win is default). This bothers me. I thought that correct installation will solve this. Windows is working without problem

I have installed opensuse 12 and it installed grub boot loader in which I have option to chose from linux (default) or windows.

When I choose windows win boot manager is started and showing me list with choices (old problem).

Both OS works fine (open suse 12 and win 7) but still what bothers me is that old suse 11.4 that is showing in the windows manager boot list.

I have downloaded Easy BCD to rectify this but this program cannot find BCD file.
Also even though I'm admin when type bcdedit in comm prompt I get message error that access is denided.

How to rectify this? I dono't want to use win install CD because I think it will corrupt existing open suse working isntallation.

The problem is only how to remove this ghost entry in win boot managerm because I Easy BCD cannot locate it.


I have installed windows 7, so when turning ON computer first grub is started and then after win is chosen I get this win boot manager with choices.


Thank you

Philip Lacroix 03-07-2013 06:28 AM

Quote:

Originally Posted by Micik (Post 4906437)
This installation was corrupt so I end up that my windows boot manager at startup shows choice (win and linux while win is default). This bothers me. I thought that correct installation will solve this. Windows is working without problem.

I have installed opensuse 12 and it installed grub boot loader in which I have option to chose from linux (default) or windows.

When I choose windows win boot manager is started and showing me list with choices (old problem).

Both OS works fine (open suse 12 and win 7) but still what bothers me is that old suse 11.4 that is showing in the windows manager boot list.

The problem is only how to remove this ghost entry in win boot managerm because I Easy BCD cannot locate it.

Hi,

if you are able to load both systems, probably nothing is corrupt: you just have win's boot manager enabled. You can disable it in the system settings. Right-click on Computer, go to Properties, then something like Advanced options and finally something like Boot and recovery settings (sorry, the M$ machine I have here has a non-English installation). There you can disable the operating systems list option, keeping win as the default.

Now when you'll choose win in grub you will never see that ugly menu again. ;)

Kind regards,

Philip

Micik 03-08-2013 02:27 AM

Solved
 
Hello,

I have managed to solve my problem. Thank you for the reply Philip, but you probably didn't understand my problem.

I tried to install suse linux 11.4 from window7 and this installation failed, but this was enough that linux is listed as second choice in windows manager boot list.

So after turning on the computer, win boot manager offered me the choice to choose between win and suse.

Then I installed successfully open suse 12.2 and it installed grub. So when I turn ON the computer, I get grub manager which offers me to boot from linux (default) or windows. If I choose windows I get again win boot manager with second entry about broken linux.

So problem was possible only to solve this in windows. I installed EasyBCD software to edit boot options in windows but was unable to find BCD file.

I went to disk management and saw "system reserved" partition 100 MB. I assigned drive letter to this partition and found BCD file, and then I skipped the windows manager boot menu and deleted entry in the list.

This solved my problem with ghost entry in the win boot list.


Thank you.

Philip Lacroix 03-08-2013 03:19 AM

Hi Micik,

yes, I understood your problem but probably my answer wasn't explicit enough. :) The steps I described had to be done in Windows 7 (I did them myself):

Quote:

Right-click on Computer, go to Properties, then something like Advanced options [twice!] and finally something like Boot and recovery settings (sorry, the M$ machine I have here has a non-English installation). There you can disable the operating systems list option, keeping win as the default.
Your method was correct as well. Both are (officially) described here:

https://answers.microsoft.com/en-us/...2-62e2c8b2647d

Best wishes,

Philip


All times are GMT -5. The time now is 12:32 PM.