LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 08-29-2002, 03:30 AM   #1
chad
LQ Newbie
 
Registered: Aug 2002
Location: UK
Distribution: SuSE 8.00
Posts: 14

Rep: Reputation: 0
Unhappy DOH! no lilo and no mbr!


erm.... I'm a tad embaressed about this one....

I had a duel boot system 2000/SuSE
hda was my 2000 drive and hdb was my linux one...

I decided that I no longer need to have 2000 installed, so I deleted my partitions for hda, and repartitioned the disk to be linux.

However.... after doing so, I decided to remove the boot loader from linux (LILO) thinking 'oh I dont need this any more, cos I'm not duel-booting'...... what a muppet!

So anyhow, I'm now in the situation where I have my second hard drive with linux on it /hdb1 for /boot, with no means of booting the system, cos I've wiped the boot details from MBR on disk 1!!!

Anyone got any ideas where I can go from here to recover my system and get back to booting up??

I have set hdb1 to be type bootable in linux fdisk
I have tried lilo /mbr but I don't have a lilo.conf and don't really want to risk screwing up the entire system by 'playing' (cos I've already done that!!!! ;o)

Any advice would be welcome

Cheers
 
Old 08-29-2002, 04:53 AM   #2
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 69
If you have your rescue disk, you can try liloconfig. If that is not an option.

Also, your CDROM should act as a rescue disk as well as an install, so plop that in and see if you have any options there.

HTH

And you sir, have the coolest name! Word to the Chads!

Cool
 
Old 08-29-2002, 08:28 AM   #3
chad
LQ Newbie
 
Registered: Aug 2002
Location: UK
Distribution: SuSE 8.00
Posts: 14

Original Poster
Rep: Reputation: 0
Thanks MasterC,

lol @ the cool name thing!

I've decided to back up some of my config files
and re-install - it's much quicker to wipe it and play wiv
a full system again than mess about trying to figure
out what's up...

I've got me samba files/printer stuff already backed up anyhow.

Cheers anyhow!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Lilo on MBR tez Slackware - Installation 3 10-22-2004 09:20 AM
Lilo only on MBR? Teoryn Slackware - Installation 9 03-30-2004 04:10 AM
LILO not in MBR contactsanil Linux - Newbie 1 01-12-2004 03:49 AM
lilo on MBR roofy Linux - General 5 05-19-2003 04:15 PM
mbr had over write so lilo is gone how to rewrite lilo to mbr mch Linux - Software 4 10-25-2002 02:55 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 10:32 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration