LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 12-24-2004, 11:00 PM   #1
TimmyP
Member
 
Registered: Dec 2003
Location: Newark, DE
Distribution: Debian "sarge"
Posts: 50

Rep: Reputation: 15
/dev/sequencer missing


hello all,

when ever i try and play a midi file a get this error: can not open /dev/sequencer, probably there is another program using it.

i looked in /dev, there is no /dev/sequencer

this is what is in my /dev/sndstat file:

Sound Driver:3.8.1a-980706 (ALSA v1.0.4rc2 emulation code)
Kernel: Linux Grendel 2.6.5-1-k7 #2 Fri Apr 30 20:46:35 EST 2004 i686
Config options: 0

Installed drivers:
Type 10: ALSA emulation

Card config:
VIA 8235 at 0xe400, irq 5

Audio devices:
0: VIA 8235 (DUPLEX)

Synth devices: NOT ENABLED IN CONFIG

Midi devices: NOT ENABLED IN CONFIG

Timers:
7: system timer

Mixers:
0: C-Media Electronics id 83


It is very important that i be able to listen to midi files, as I use my computer to write music.

anyone have any ideas?

~TimmyP
 
Old 12-25-2004, 03:56 AM   #2
valerie_tux
Member
 
Registered: Aug 2003
Distribution: Debian
Posts: 150

Rep: Reputation: 15
Had the same problem a while ago. I fixed it by adding the sequencer modules to my kernel, specifically SEQUENCER_SUPPORT under ALSA and OSS_SEQUENCER_API. Now I can see the snd_seq_device module when I list all the modules running.

BTW.. there is still a little problem. I cant seem to play any midi files through KMIDI but not with KMid or timidity.

I hope there is a better answer somwhere...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
/dev/sequencer not present jagot Linux - Hardware 2 10-22-2006 03:12 PM
/dev/sequencer on FC3 Sornen Fedora 0 11-14-2004 01:18 PM
Removing /dev/sequencer Qhayaal Mandriva 0 02-09-2004 06:57 AM
/dev/sequencer not found. scott231ca Linux - Hardware 14 10-24-2003 09:15 AM
Sequencer Dev question Zarik Linux - Newbie 0 02-14-2003 01:19 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 12:49 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration